1 # New ports collection makefile for: lua50-filename
2 # Date created: 28 Mar 2005
5 PORTNAME
= lua50-filename
9 DISTNAME
= luafilename-
${PORTVERSION}
12 LIB_DEPENDS
= lua50.5
:${PORTSDIR}/lang
/lua50
13 BUILD_DEPENDS
= ${LOCALBASE}/bin
/lua50c51
:${PORTSDIR}/devel
/lua50-compat51
14 RUN_DEPENDS
= ${LOCALBASE}/bin
/lua50c51
:${PORTSDIR}/devel
/lua50-compat51 \
15 ${LOCALBASE}/share
/lua
/5.0/posix.lua
:${PORTSDIR}/devel
/lua50-posix
17 MAINTAINER
= cpressey@catseye.mine.nu
18 COMMENT
= Filename-manipulating functions for Lua
5.0.x
20 PLIST_FILES
= share
/lua
/5.0/filename.lua
23 @if
[ ! -f
${_DISTDIR}${DISTNAME}${EXTRACT_SUFX} ]; then \
25 ${ECHO_MSG} "Distfile ${DISTNAME}${EXTRACT_SUFX} not found!"; \
27 ${ECHO_MSG} "This is an 'INTERNAL' port, meaning that the distfile is not retrieved"; \
28 ${ECHO_MSG} "from the Internet, but rather created from a local checkout of the"; \
29 ${ECHO_MSG} "BSD Installer CVS repository. Please see the shell scripts in the"; \
30 ${ECHO_MSG} "scripts/build directory of the repository for more information on how"; \
31 ${ECHO_MSG} "to create these distfiles."; \
36 @
${ECHO} "No building required."
39 ${CP} ${WRKSRC}/filename.lua
${LOCALBASE}/share
/lua
/5.0/filename.lua
41 OSTYPE
!=sysctl
-n kern.ostype
43 .if
${OSTYPE} == "FreeBSD"
44 .
include <bsd.port.mk
>
47 .if
${OSTYPE} == "DragonFly"
48 .
include <bsd.dfport.mk
>