Reduce differences with root_skels in contrib.
[dragonfly.git] / contrib / bsdinstaller-1.1.6 / ports / devel / lua50-filename / Makefile
bloba62c2e5637ff63c363e8586d1df88e495d17af23
1 # New ports collection makefile for: lua50-filename
2 # Date created: 28 Mar 2005
3 # Whom: Chris Pressey
5 PORTNAME= lua50-filename
6 PORTVERSION= 0.1
7 INTERNAL= YES
8 CATEGORIES= devel
9 DISTNAME= luafilename-${PORTVERSION}
10 WRKSRC= work/filename
12 LIB_DEPENDS= lua50.5:${PORTSDIR}/lang/lua50
13 BUILD_DEPENDS= ${LOCALBASE}/bin/lua50c51:${PORTSDIR}/devel/lua50-compat51
14 RUN_DEPENDS= ${LOCALBASE}/bin/lua50c51:${PORTSDIR}/devel/lua50-compat51 \
15 ${LOCALBASE}/share/lua/5.0/posix.lua:${PORTSDIR}/devel/lua50-posix
17 MAINTAINER= cpressey@catseye.mine.nu
18 COMMENT= Filename-manipulating functions for Lua 5.0.x
20 PLIST_FILES= share/lua/5.0/filename.lua
22 do-fetch:
23 @if [ ! -f ${_DISTDIR}${DISTNAME}${EXTRACT_SUFX} ]; then \
24 ${ECHO_MSG}; \
25 ${ECHO_MSG} "Distfile ${DISTNAME}${EXTRACT_SUFX} not found!"; \
26 ${ECHO_MSG}; \
27 ${ECHO_MSG} "This is an 'INTERNAL' port, meaning that the distfile is not retrieved"; \
28 ${ECHO_MSG} "from the Internet, but rather created from a local checkout of the"; \
29 ${ECHO_MSG} "BSD Installer CVS repository. Please see the shell scripts in the"; \
30 ${ECHO_MSG} "scripts/build directory of the repository for more information on how"; \
31 ${ECHO_MSG} "to create these distfiles."; \
32 false; \
35 do-build:
36 @${ECHO} "No building required."
38 do-install:
39 ${CP} ${WRKSRC}/filename.lua ${LOCALBASE}/share/lua/5.0/filename.lua
41 OSTYPE!=sysctl -n kern.ostype
43 .if ${OSTYPE} == "FreeBSD"
44 .include <bsd.port.mk>
45 .endif
47 .if ${OSTYPE} == "DragonFly"
48 .include <bsd.dfport.mk>
49 .endif