Reduce differences with root_skels in contrib.
[dragonfly.git] / contrib / bsdinstaller-1.1.6 / ports / devel / lua50-curses / Makefile
blob6f255a6274c8f18a7a884d1c8e42b6a61dd5deda
1 # New ports collection makefile for: lua50-curses
2 # Date created: 10 Feb 2005
3 # Whom: Chris Pressey
5 PORTNAME= lua50-curses
6 PORTVERSION= 0.1a
7 CATEGORIES= devel
8 DISTNAME= lcurses-0.1-devel
9 MASTER_SITES= http://mega.ist.utl.pt/~tngd/lua/
11 LIB_DEPENDS= lua50.5:${PORTSDIR}/lang/lua50
12 BUILD_DEPENDS= ${LOCALBASE}/bin/lua50c51:${PORTSDIR}/devel/lua50-compat51
13 RUN_DEPENDS= ${LOCALBASE}/bin/lua50c51:${PORTSDIR}/devel/lua50-compat51
15 MAINTAINER= cpressey@catseye.mine.nu
16 COMMENT= Curses binding for Lua 5.0.x
18 PLIST_FILES= lib/lua/5.0/lcurses.so
20 do-install:
21 ${INSTALL_DATA} ${WRKSRC}/lcurses.so ${PREFIX}/lib/lua/5.0
23 OSTYPE!=sysctl -n kern.ostype
25 .if ${OSTYPE} == "FreeBSD"
26 .include <bsd.port.mk>
27 .endif
29 .if ${OSTYPE} == "DragonFly"
30 .include <bsd.dfport.mk>
31 .endif