Makefile: add debug module to the testimage target
[dracut/plouj.git] / dracut.spec
bloba1f2526a4f04380772cc05011acefac3db7f26aa
1 %if 0%{?fedora} < 12
2 %define with_switch_root 1
3 %else
4 %define with_switch_root 1
5 %endif
7 %if %{defined gittag}
8 %define rdist 1.git%{gittag}%{?dist}
9 %define dashgittag -%{gittag}
10 %else
11 %define rdist %{?dist}
12 %endif
14 Name: dracut
15 Version: 0.4
16 Release: 1%{?rdist}
17 Summary: Initramfs generator using udev
18 Group: System Environment/Base
19 License: GPLv2+
20 URL: http://apps.sourceforge.net/trac/dracut/wiki
21 Source0: dracut-%{version}%{?dashgittag}.tar.bz2
22 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
23 Requires: udev
24 Requires: util-linux-ng
25 Requires: module-init-tools
26 Requires: cpio
27 Requires: coreutils
28 Requires: findutils
29 Requires: binutils
30 Requires: grep
31 Requires: mktemp
32 Requires: mount
33 Requires: bash
34 Requires: /bin/sh
35 Requires: fileutils, grep, mount, gzip, tar, mktemp >= 1.5-5, findutils
36 Requires: lvm2 >= 2.02.33-9, dhclient
37 Requires: filesystem >= 2.1.0, cpio, device-mapper, initscripts >= 8.63-1
38 Requires: e2fsprogs >= 1.38-12, libselinux, libsepol, coreutils
39 Requires: mdadm, elfutils-libelf, plymouth >= 0.7.0
40 Requires: cryptsetup-luks
41 %ifnarch s390 s390x
42 Requires: dmraid
43 Requires: kbd
44 %endif
46 %if ! 0%{?with_switch_root}
47 Requires: /sbin/switch_root
48 BuildArch: noarch
49 %endif
51 %description
52 dracut is a new, event-driven initramfs infrastructure based around udev.
55 %package generic
56 Summary: Metapackage to build a generic initramfs
57 Requires: %{name} = %{version}-%{release}
58 Requires: rpcbind nfs-utils
59 Requires: iscsi-initiator-utils
60 Requires: nbd
61 Requires: net-tools iproute
62 Requires: kernel-firmware
63 Requires: ql2100-firmware
64 Requires: ql2200-firmware
65 Requires: ql23xx-firmware
66 Requires: ql2400-firmware
67 Requires: ql2500-firmware
69 %description generic
70 This package requires everything which is needed to build a generic
71 all purpose initramfs.
73 %prep
74 %setup -q -n %{name}-%{version}%{?dashgittag}
76 %build
77 make
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 make install DESTDIR=$RPM_BUILD_ROOT sbindir=/sbin sysconfdir=/etc mandir=%{_mandir}
84 %if ! 0%{?with_switch_root}
85 rm -f $RPM_BUILD_ROOT/sbin/switch_root
86 %endif
88 %clean
89 rm -rf $RPM_BUILD_ROOT
91 %files
92 %defattr(-,root,root,0755)
93 %doc README HACKING TODO COPYING AUTHORS
94 /sbin/dracut
95 %if 0%{?with_switch_root}
96 /sbin/switch_root
97 %endif
98 %dir %{_datadir}/dracut
99 %{_datadir}/dracut/dracut-functions
100 %{_datadir}/dracut/modules.d
101 %config(noreplace) /etc/dracut.conf
102 %{_mandir}/man8/dracut.8*
104 %files generic
105 %defattr(-,root,root,0755)
106 %doc README.generic
108 %changelog
109 * Sat Jul 04 2009 Harald Hoyer <harald@redhat.com> 0.4-1
110 - version 0.4
112 * Thu Jul 02 2009 Harald Hoyer <harald@redhat.com> 0.3-1
113 - version 0.3
115 * Wed Jul 01 2009 Harald Hoyer <harald@redhat.com> 0.2-1
116 - version 0.2
118 * Fri Jun 19 2009 Harald Hoyer <harald@redhat.com> 0.1-1
119 - first release
121 * Thu Dec 18 2008 Jeremy Katz <katzj@redhat.com> - 0.0-1
122 - Initial build