dracut-lib: getarg(), getargs() read command line also from /etc/cmdline
[dracut/plouj.git] / dracut.spec
blobf0a7f939600162e9ad1ec2d8eec4d2273478d446
1 %if 0%{?fedora} < 12
2 %define with_switch_root 1
3 %else
4 %define with_switch_root 1
5 %endif
7 %if %{defined gittag}
8 %define rdist 1.git%{gittag}%{?dist}
9 %define dashgittag -%{gittag}
10 %else
11 %define rdist %{?dist}
12 %endif
14 Name: dracut
15 Version: 0.6
16 Release: 1%{?rdist}
17 Summary: Initramfs generator using udev
18 Group: System Environment/Base
19 License: GPLv2+
20 URL: http://apps.sourceforge.net/trac/dracut/wiki
21 Source0: dracut-%{version}%{?dashgittag}.tar.bz2
22 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
23 Requires: udev
24 Requires: util-linux-ng
25 Requires: module-init-tools
26 Requires: cpio
27 Requires: coreutils
28 Requires: findutils
29 Requires: binutils
30 Requires: grep
31 Requires: mktemp
32 Requires: mount
33 Requires: bash
34 Requires: /bin/sh
35 Requires: fileutils, grep, mount, gzip, tar, mktemp >= 1.5-5, findutils
36 Requires: lvm2 >= 2.02.33-9, dhclient
37 Requires: filesystem >= 2.1.0, cpio, device-mapper, initscripts >= 8.63-1
38 Requires: e2fsprogs >= 1.38-12, libselinux, libsepol, coreutils
39 Requires: mdadm, elfutils-libelf, plymouth >= 0.7.0
40 Requires: cryptsetup-luks
41 %ifnarch s390 s390x
42 Requires: dmraid
43 Requires: kbd
44 %endif
46 %if ! 0%{?with_switch_root}
47 Requires: /sbin/switch_root
48 BuildArch: noarch
49 %endif
51 %description
52 dracut is a new, event-driven initramfs infrastructure based around udev.
54 %package generic
55 Summary: Metapackage to build a generic initramfs
56 Requires: %{name} = %{version}-%{release}
57 Requires: rpcbind nfs-utils
58 Requires: iscsi-initiator-utils
59 Requires: nbd
60 Requires: bridge-utils
61 Requires: net-tools iproute
62 Requires: plymouth-system-theme plymouth-theme-charge plymouth-theme-solar
64 %description generic
65 This package requires everything which is needed to build a generic
66 all purpose initramfs.
68 %package kernel
69 Summary: Metapackage to build generic initramfs with only kernel modules
70 Requires: %{name} = %{version}-%{release}
71 Requires: ql2100-firmware
72 Requires: ql2200-firmware
73 Requires: ql23xx-firmware
74 Requires: ql2400-firmware
75 Requires: ql2500-firmware
77 %description kernel
78 This package requires everything which is needed to build a initramfs with all
79 kernel modules and firmware files needed by dracut modules.
81 %prep
82 %setup -q -n %{name}-%{version}%{?dashgittag}
84 %build
85 make
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 make install DESTDIR=$RPM_BUILD_ROOT sbindir=/sbin sysconfdir=/etc mandir=%{_mandir}
92 %if ! 0%{?with_switch_root}
93 rm -f $RPM_BUILD_ROOT/sbin/switch_root
94 %endif
96 %clean
97 rm -rf $RPM_BUILD_ROOT
99 %files
100 %defattr(-,root,root,0755)
101 %doc README HACKING TODO COPYING AUTHORS
102 /sbin/dracut
103 /sbin/dracut-gencmdline
104 %if 0%{?with_switch_root}
105 /sbin/switch_root
106 %endif
107 %dir %{_datadir}/dracut
108 %{_datadir}/dracut/dracut-functions
109 %{_datadir}/dracut/modules.d
110 %config(noreplace) /etc/dracut.conf
111 %{_mandir}/man8/dracut.8*
113 %files generic
114 %defattr(-,root,root,0755)
115 %doc README.generic
117 %files kernel
118 %defattr(-,root,root,0755)
119 %doc README.kernel
121 %changelog
122 * Wed Jul 22 2009 Harald Hoyer harald@redhat.com 0.6-1
123 - version 0.6
125 * Fri Jul 17 2009 Harald Hoyer <harald@redhat.com> 0.5-1
126 - version 0.5
128 * Sat Jul 04 2009 Harald Hoyer <harald@redhat.com> 0.4-1
129 - version 0.4
131 * Thu Jul 02 2009 Harald Hoyer <harald@redhat.com> 0.3-1
132 - version 0.3
134 * Wed Jul 01 2009 Harald Hoyer <harald@redhat.com> 0.2-1
135 - version 0.2
137 * Fri Jun 19 2009 Harald Hoyer <harald@redhat.com> 0.1-1
138 - first release
140 * Thu Dec 18 2008 Jeremy Katz <katzj@redhat.com> - 0.0-1
141 - Initial build