crypt: remove emergency source of dracut-lib.sh
[dracut.git] / dracut.spec
blob5e9db8f319078f32dee82130bff29fc0b9cb0a1e
1 # Variables must be defined
2 %define with_switch_root 1
3 %define with_nbd 1
5 # switchroot provided by util-linux-ng in F-12+
6 %if 0%{?fedora} > 11 || 0%{?rhel} >= 6
7 %define with_switch_root 0
8 %endif
9 # nbd in Fedora only
10 %if 0%{?rhel} >= 6
11 %define with_nbd 0
12 %endif
14 %if %{defined gittag}
15 %define rdist .git%{gittag}%{?dist}
16 %define dashgittag -%{gittag}
17 %else
18 %define rdist %{?dist}
19 %endif
21 Name: dracut
22 Version: 006
23 Release: 1%{?rdist}
24 Summary: Initramfs generator using udev
25 Group: System Environment/Base
26 License: GPLv2+
27 URL: http://apps.sourceforge.net/trac/dracut/wiki
28 # Source can be generated by
29 # http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=snapshot;h=%{?dashgittag};sf=tgz
30 Source0: dracut-%{version}%{?dashgittag}.tar.bz2
31 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
33 %if 0%{?fedora} > 12 || 0%{?rhel} >= 6
34 # no "provides", because dracut does not offer
35 # all functionality of the obsoleted packages
36 Obsoletes: mkinitrd <= 6.0.93
37 Obsoletes: mkinitrd-devel <= 6.0.93
38 Obsoletes: nash <= 6.0.93
39 Obsoletes: libbdevid-python <= 6.0.93
40 %endif
41 Obsoletes: dracut-kernel < 005
42 Provides: dracut-kernel = %{version}-%{release}
44 Requires: bash
45 Requires: bzip2
46 Requires: coreutils
47 Requires: cpio
48 Requires: dash
49 Requires: filesystem >= 2.1.0
50 Requires: findutils
51 Requires: grep
52 Requires: gzip
53 Requires: initscripts >= 8.63-1
54 Requires: kbd
55 Requires: mktemp >= 1.5-5
56 Requires: module-init-tools >= 3.7-9
57 Requires: mount
58 Requires: plymouth >= 0.8.0-0.2009.29.09.19.1
59 Requires: sed
60 Requires: tar
61 Requires: udev
62 Requires: util-linux-ng >= 2.16
63 Requires: which
65 %if ! 0%{?with_switch_root}
66 BuildArch: noarch
67 %endif
69 %description
70 Dracut contains tools to create a bootable initramfs for 2.6 Linux kernels.
71 Unlike existing implementations, dracut does hard-code as little as possible
72 into the initramfs. Dracut contains various modules which are driven by the
73 event-based udev. Having root on MD, DM, LVM2, LUKS is supported as well as
74 NFS, iSCSI, NBD, FCoE with the dracut-network package.
76 %package network
77 Summary: Dracut modules to build a dracut initramfs with network support
78 Requires: %{name} = %{version}-%{release}
79 Requires: rpcbind nfs-utils
80 Requires: iscsi-initiator-utils
81 Requires: dhclient
82 %if %{with_nbd}
83 Requires: nbd
84 %endif
85 Requires: net-tools iproute
86 Requires: bridge-utils
87 Requires: vconfig
89 %description network
90 This package requires everything which is needed to build a generic
91 all purpose initramfs with network support with dracut.
93 %package fips
94 Summary: Dracut modules to build a dracut initramfs with an integrity check
95 Requires: %{name} = %{version}-%{release}
96 Requires: hmaccalc
97 %if 0%{?rhel} > 5
98 # For Alpha 3, we want nss instead of nss-softokn
99 Requires: nss
100 %else
101 Requires: nss-softokn
102 %endif
103 Requires: nss-softokn-freebl
105 %description fips
106 This package requires everything which is needed to build an
107 all purpose initramfs with dracut, which does an integrity check.
109 %package generic
110 Summary: Metapackage to build a generic initramfs with dracut
111 Requires: %{name} = %{version}-%{release}
112 Requires: %{name}-network = %{version}-%{release}
114 %description generic
115 This package requires everything which is needed to build a generic
116 all purpose initramfs with dracut.
118 %package tools
119 Summary: Dracut tools to build the local initramfs
120 Requires: coreutils cryptsetup-luks device-mapper
121 Requires: diffutils dmraid findutils grep lvm2 gawk
122 Requires: module-init-tools sed
123 Requires: cpio gzip
124 Requires: %{name} = %{version}-%{release}
126 %description tools
127 This package contains tools to assemble the local initrd and host configuration.
129 %prep
130 %setup -q -n %{name}-%{version}%{?dashgittag}
132 %build
133 make WITH_SWITCH_ROOT=0%{?with_switch_root}
135 %install
136 rm -rf $RPM_BUILD_ROOT
137 make install DESTDIR=$RPM_BUILD_ROOT sbindir=/sbin \
138 sysconfdir=/etc mandir=%{_mandir} WITH_SWITCH_ROOT=0%{?with_switch_root}
140 echo %{name}-%{version}-%{release} > $RPM_BUILD_ROOT/%{_datadir}/dracut/modules.d/10rpmversion/dracut-version
141 rm $RPM_BUILD_ROOT/%{_datadir}/dracut/modules.d/01fips/check
143 mkdir -p $RPM_BUILD_ROOT/boot/dracut
144 mkdir -p $RPM_BUILD_ROOT/var/lib/dracut/overlay
145 mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log
146 touch $RPM_BUILD_ROOT%{_localstatedir}/log/dracut.log
148 %if 0%{?fedora} <= 12 && 0%{?rhel} < 6
149 rm $RPM_BUILD_ROOT/sbin/mkinitrd
150 rm $RPM_BUILD_ROOT/sbin/lsinitrd
151 %endif
153 %clean
154 rm -rf $RPM_BUILD_ROOT
156 %files
157 %defattr(-,root,root,0755)
158 %doc README HACKING TODO COPYING AUTHORS NEWS
159 /sbin/dracut
160 %if 0%{?with_switch_root}
161 /sbin/switch_root
162 %endif
163 %if 0%{?fedora} > 12 || 0%{?rhel} >= 6
164 /sbin/mkinitrd
165 /sbin/lsinitrd
166 %endif
167 %dir %{_datadir}/dracut
168 %{_datadir}/dracut/dracut-functions
169 %config(noreplace) /etc/dracut.conf
170 %dir /etc/dracut.conf.d
171 %{_mandir}/man8/dracut.8*
172 %{_mandir}/man5/dracut.conf.5*
173 %{_datadir}/dracut/modules.d/00dash
174 %{_datadir}/dracut/modules.d/10redhat-i18n
175 %{_datadir}/dracut/modules.d/10rpmversion
176 %{_datadir}/dracut/modules.d/50plymouth
177 %{_datadir}/dracut/modules.d/60xen
178 %{_datadir}/dracut/modules.d/90btrfs
179 %{_datadir}/dracut/modules.d/90crypt
180 %{_datadir}/dracut/modules.d/90dm
181 %{_datadir}/dracut/modules.d/90dmraid
182 %{_datadir}/dracut/modules.d/90dmsquash-live
183 %{_datadir}/dracut/modules.d/90kernel-modules
184 %{_datadir}/dracut/modules.d/90lvm
185 %{_datadir}/dracut/modules.d/90mdraid
186 %{_datadir}/dracut/modules.d/90multipath
187 %{_datadir}/dracut/modules.d/95debug
188 %{_datadir}/dracut/modules.d/95resume
189 %{_datadir}/dracut/modules.d/95rootfs-block
190 %{_datadir}/dracut/modules.d/95dasd
191 %{_datadir}/dracut/modules.d/95dasd_mod
192 %{_datadir}/dracut/modules.d/95zfcp
193 %{_datadir}/dracut/modules.d/95terminfo
194 %{_datadir}/dracut/modules.d/95udev-rules
195 %{_datadir}/dracut/modules.d/95uswsusp
196 %{_datadir}/dracut/modules.d/98selinux
197 %{_datadir}/dracut/modules.d/98syslog
198 %{_datadir}/dracut/modules.d/99base
199 # logfile needs no logrotate, because it gets overwritten
200 # for every dracut run
201 %attr(0644,root,root) %ghost %config(missingok,noreplace) %{_localstatedir}/log/dracut.log
203 %files network
204 %defattr(-,root,root,0755)
205 %{_datadir}/dracut/modules.d/40network
206 %{_datadir}/dracut/modules.d/95fcoe
207 %{_datadir}/dracut/modules.d/95iscsi
208 %{_datadir}/dracut/modules.d/95nbd
209 %{_datadir}/dracut/modules.d/95nfs
210 %{_datadir}/dracut/modules.d/45ifcfg
211 %{_datadir}/dracut/modules.d/95znet
213 %files fips
214 %defattr(-,root,root,0755)
215 %{_datadir}/dracut/modules.d/01fips
217 %files generic
218 %defattr(-,root,root,0755)
219 %doc README.generic
221 %files tools
222 %defattr(-,root,root,0755)
223 %{_mandir}/man8/dracut-gencmdline.8*
224 %{_mandir}/man8/dracut-catimages.8*
225 /sbin/dracut-gencmdline
226 /sbin/dracut-catimages
227 %dir /boot/dracut
228 %dir /var/lib/dracut
229 %dir /var/lib/dracut/overlay
231 %changelog
232 * Thu Jun 17 2010 Harald Hoyer <harald@redhat.com> 006-1
233 - version 006
235 * Fri Jun 11 2010 Harald Hoyer <harald@redhat.com>
236 - Remove requirements, which are not really needed
237 Resolves: rhbz#598509
238 - fixed copy of network config to /dev/.initramfs/ (patch 146)
239 Resolves: rhbz#594649
240 - more password beauty (patch 142)
241 Resolves: rhbz#561092
242 - support multiple iSCSI disks (patch 143)
243 Resolves: rbhz#580190
244 - fixed selinux=0 (patch 130)
245 Resolves: rhbz#593080
246 - add support for booting LVM snapshot root volume (patch 145)
247 Resolves: rbhz#602723
248 - remove hardware field from BOOTIF= (patch 148)
249 Resolves: rhbz#599593
250 - add aes kernel modules and fix crypt handling (patch 137, patch 140 and patch 147)
251 Resolves: rhbz#600170
253 * Thu May 27 2010 Harald Hoyer <harald@redhat.com>
254 - fixed Requirements
255 - fixed autoip6
256 Resolves: rhbz#538388
257 - fixed multipath
258 Resolves: rhbz#595719
260 * Thu May 06 2010 Harald Hoyer <harald@redhat.com>
261 - only display short password messages
262 Resolves: rhbz#561092
264 * Thu May 06 2010 Harald Hoyer <harald@redhat.com>
265 - fixed dracut manpages
266 Resolves: rhbz#589109
267 - use ccw-init and ccw rules from s390utils
268 Resolves: rhbz#533494
269 - fixed fcoe
270 Resolves: rhbz#486244
271 - various other bugfixes seen in Fedora
273 * Tue Apr 20 2010 Harald Hoyer <harald@redhat.com>
274 - fixed network with multiple nics
275 - fixed nfsidmap paths
276 - do not run blkid on non active container raids
277 - fixed cdrom polling mechanism
278 - update to latest git
280 * Thu Apr 15 2010 Harald Hoyer <harald@redhat.com>
281 - fixed dracut manpages
282 - dmraid parse different error messages
283 - add cdrom polling mechanism for slow cdroms
284 - add module btrfs
285 - teach dmsquash live-root to use rootflags
286 - trigger udev with action=add
287 - fixed add_drivers handling
288 - add sr_mod
289 - use pigz instead of gzip, if available
291 * Thu Mar 25 2010 Harald Hoyer <harald@redhat.com>
292 - removed firmware requirements (rhbz#572634)
293 - add /etc/dracut.conf.d
294 - Resolves: rhbz#572634
296 * Fri Mar 19 2010 Harald Hoyer <harald@redhat.com>
297 - version 005
299 * Fri Mar 19 2010 Harald Hoyer <harald@redhat.com>
300 - fixed rpmlint errors (rhbz#570547)
301 - removed firmware package from dracut-kernel (rhbz#572634)
302 - add dcb support to dracut's FCoE support (rhbz#563794)
303 - force install some modules in hostonly mode (rhbz#573094)
304 - various other bugfixes
305 - Resolves: rhbz#570547, rhbz#572634, rhbz#563794, rhbz#573094
307 * Thu Feb 18 2010 Harald Hoyer <harald@redhat.com> 004-15
308 - fixed "selinux=0" booting (rhbz#566376)
309 - fixed internal IFS handling
310 - Resolves: rhbz#566376
312 * Fri Jan 29 2010 Harald Hoyer <harald@redhat.com> 004-5
313 - fixed firmware.sh bug (#559975 #559597)
315 * Tue Jan 26 2010 Harald Hoyer <harald@redhat.com> 004-4
316 - add multipath check
318 * Tue Jan 26 2010 Harald Hoyer <harald@redhat.com> 004-3
319 - fix selinux handling if .autorelabel is present
320 - Resolves: rhbz#557744
322 * Wed Jan 20 2010 Harald Hoyer <harald@redhat.com> 004-2
323 - fix emergency_shell argument parsing
324 - Related: rhbz#543948
326 * Fri Jan 15 2010 Harald Hoyer <harald@redhat.com> 004-1
327 - version 004
328 - Resolves: rhbz#529339 rhbz#533494 rhbz#548550
329 - Resolves: rhbz#548555 rhbz#553195
331 * Wed Jan 13 2010 Harald Hoyer <harald@redhat.com> 003-3
332 - add Obsoletes of mkinitrd/nash/libbdevid-python
333 - Related: rhbz#543948
335 * Wed Jan 13 2010 Warren Togami <wtogami@redhat.com> 003-2
336 - nbd is Fedora only
338 * Fri Nov 27 2009 Harald Hoyer <harald@redhat.com> 003-1
339 - version 003
341 * Mon Nov 23 2009 Harald Hoyer <harald@redhat.com> 002-26
342 - add WITH_SWITCH_ROOT make flag
343 - add fips requirement conditional
344 - add more device mapper modules (bug #539656)
346 * Fri Nov 20 2009 Dennis Gregorovic <dgregor@redhat.com> - 002-25.1
347 - nss changes for Alpha 3
349 * Thu Nov 19 2009 Harald Hoyer <harald@redhat.com> 002-25
350 - add more requirements for dracut-fips (bug #539257)
352 * Tue Nov 17 2009 Harald Hoyer <harald@redhat.com> 002-24
353 - put fips module in a subpackage (bug #537619)
355 * Tue Nov 17 2009 Harald Hoyer <harald@redhat.com> 002-23
356 - install xdr utils for multipath (bug #463458)
358 * Thu Nov 12 2009 Harald Hoyer <harald@redhat.com> 002-22
359 - add module 90multipath
360 - add module 01fips
361 - renamed module 95ccw to 95znet (bug #533833)
362 - crypt: ignore devices in /etc/crypttab (root is not in there)
363 - dasd: only install /etc/dasd.conf in hostonly mode (bug #533833)
364 - zfcp: only install /etc/zfcp.conf in hostonly mode (bug #533833)
365 - kernel-modules: add scsi_dh scsi_dh_rdac scsi_dh_emc (bug #527750)
366 - dasd: use dasdconf.sh from s390utils (bug #533833)
368 * Fri Nov 06 2009 Harald Hoyer <harald@redhat.com> 002-21
369 - fix rd_DASD argument handling (bug #531720)
370 - Resolves: rhbz#531720
372 * Wed Nov 04 2009 Harald Hoyer <harald@redhat.com> 002-20
373 - fix rd_DASD argument handling (bug #531720)
374 - Resolves: rhbz#531720
376 * Tue Nov 03 2009 Harald Hoyer <harald@redhat.com> 002-19
377 - changed rd_DASD to rd_DASD_MOD (bug #531720)
378 - Resolves: rhbz#531720
380 * Tue Oct 27 2009 Harald Hoyer <harald@redhat.com> 002-18
381 - renamed lvm/device-mapper udev rules according to upstream changes
382 - fixed dracut search path issue
384 * Mon Oct 26 2009 Harald Hoyer <harald@redhat.com> 002-17
385 - load dm_mod module (bug #530540)
387 * Fri Oct 09 2009 Jesse Keating <jkeating@redhat.com> - 002-16
388 - Upgrade plymouth to Requires(pre) to make it show up before kernel
390 * Thu Oct 08 2009 Harald Hoyer <harald@redhat.com> 002-15
391 - s390 ccw: s/layer1/layer2/g
393 * Thu Oct 08 2009 Harald Hoyer <harald@redhat.com> 002-14
394 - add multinic support
395 - add s390 zfcp support
396 - add s390 network support
398 * Wed Oct 07 2009 Harald Hoyer <harald@redhat.com> 002-13
399 - fixed init=<command> handling
400 - kill loginit if "rdinitdebug" specified
401 - run dmsquash-live-root after udev has settled (bug #527514)
403 * Tue Oct 06 2009 Harald Hoyer <harald@redhat.com> 002-12
404 - add missing loginit helper
405 - corrected dracut manpage
407 * Thu Oct 01 2009 Harald Hoyer <harald@redhat.com> 002-11
408 - fixed dracut-gencmdline for root=UUID or LABEL
410 * Thu Oct 01 2009 Harald Hoyer <harald@redhat.com> 002-10
411 - do not destroy assembled raid arrays if mdadm.conf present
412 - mount /dev/shm
413 - let udevd not resolve group and user names
414 - preserve timestamps of tools on initramfs generation
415 - generate symlinks for binaries correctly
416 - moved network from udev to initqueue
417 - mount nfs3 with nfsvers=3 option and retry with nfsvers=2
418 - fixed nbd initqueue-finished
419 - improved debug output: specifying "rdinitdebug" now logs
420 to dmesg, console and /init.log
421 - stop udev before killing it
422 - add ghost /var/log/dracut.log
423 - dmsquash: use info() and die() rather than echo
424 - strip kernel modules which have no x bit set
425 - redirect stdin, stdout, stderr all RW to /dev/console
426 so the user can use "less" to view /init.log and dmesg
428 * Tue Sep 29 2009 Harald Hoyer <harald@redhat.com> 002-9
429 - make install of new dm/lvm udev rules optionally
430 - correct dasd module typo
432 * Fri Sep 25 2009 Warren Togami <wtogami@redhat.com> 002-8
433 - revert back to dracut-002-5 tarball 845dd502
434 lvm2 was reverted to pre-udev
436 * Wed Sep 23 2009 Harald Hoyer <harald@redhat.com> 002-7
437 - build with the correct tarball
439 * Wed Sep 23 2009 Harald Hoyer <harald@redhat.com> 002-6
440 - add new device mapper udev rules and dmeventd
441 bug 525319, 525015
443 * Wed Sep 23 2009 Warren Togami <wtogami@redaht.com> 002-5
444 - Revert back to -3, Add umount back to initrd
445 This makes no functional difference to LiveCD. See Bug #525319
447 * Mon Sep 21 2009 Warren Togami <wtogami@redhat.com> 002-4
448 - Fix LiveCD boot regression
450 * Mon Sep 21 2009 Harald Hoyer <harald@redhat.com> 002-3
451 - bail out if selinux policy could not be loaded and
452 selinux=0 not specified on kernel command line
453 (bug #524113)
454 - set finished criteria for dmsquash live images
456 * Fri Sep 18 2009 Harald Hoyer <harald@redhat.com> 002-2
457 - do not cleanup dmraids
458 - copy over lvm.conf
460 * Thu Sep 17 2009 Harald Hoyer <harald@redhat.com> 002-1
461 - version 002
462 - set correct PATH
463 - workaround for broken mdmon implementation
465 * Wed Sep 16 2009 Harald Hoyer <harald@redhat.com> 001-12
466 - removed lvm/mdraid/dmraid lock files
467 - add missing ifname= files
469 * Wed Sep 16 2009 Harald Hoyer <harald@redhat.com> 001-11
470 - generate dracut-version during rpm build time
472 * Tue Sep 15 2009 Harald Hoyer <harald@redhat.com> 001-10
473 - add ifname= argument for persistent netdev names
474 - new /initqueue-finished to check if the main loop can be left
475 - copy mdadm.conf if --mdadmconf set or mdadmconf in dracut.conf
477 * Wed Sep 09 2009 Harald Hoyer <harald@redhat.com> 001-9
478 - added Requires: plymouth-scripts
480 * Wed Sep 09 2009 Harald Hoyer <harald@redhat.com> 001-8
481 - plymouth: use plymouth-populate-initrd
482 - add add_drivers for dracut and dracut.conf
483 - do not mount /proc and /selinux manually in selinux-load-policy
485 * Wed Sep 09 2009 Harald Hoyer <harald@redhat.com> 001-7
486 - add scsi_wait_scan to be sure everything was scanned
488 * Tue Sep 08 2009 Harald Hoyer <harald@redhat.com> 001-6
489 - fixed several problems with md raid containers
490 - fixed selinux policy loading
492 * Tue Sep 08 2009 Harald Hoyer <harald@redhat.com> 001-5
493 - patch does not honor file modes, fixed them manually
495 * Mon Sep 07 2009 Harald Hoyer <harald@redhat.com> 001-4
496 - fixed mdraid for IMSM
498 * Mon Sep 07 2009 Harald Hoyer <harald@redhat.com> 001-3
499 - fixed bug, which prevents installing 61-persistent-storage.rules (bug #520109)
501 * Thu Sep 03 2009 Harald Hoyer <harald@redhat.com> 001-2
502 - fixed missing grep for md
503 - reorder cleanup
505 * Wed Sep 02 2009 Harald Hoyer <harald@redhat.com> 001-1
506 - version 001
507 - see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
509 * Fri Aug 14 2009 Harald Hoyer <harald@redhat.com> 0.9-1
510 - version 0.9
512 * Thu Aug 06 2009 Harald Hoyer <harald@redhat.com> 0.8-1
513 - version 0.8
514 - see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
516 * Fri Jul 24 2009 Harald Hoyer <harald@redhat.com> 0.7-1
517 - version 0.7
518 - see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
520 * Wed Jul 22 2009 Harald Hoyer <harald@redhat.com> 0.6-1
521 - version 0.6
522 - see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
524 * Fri Jul 17 2009 Harald Hoyer <harald@redhat.com> 0.5-1
525 - version 0.5
526 - see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
528 * Sat Jul 04 2009 Harald Hoyer <harald@redhat.com> 0.4-1
529 - version 0.4
530 - see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
532 * Thu Jul 02 2009 Harald Hoyer <harald@redhat.com> 0.3-1
533 - version 0.3
534 - see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
536 * Wed Jul 01 2009 Harald Hoyer <harald@redhat.com> 0.2-1
537 - version 0.2
539 * Fri Jun 19 2009 Harald Hoyer <harald@redhat.com> 0.1-1
540 - first release
542 * Thu Dec 18 2008 Jeremy Katz <katzj@redhat.com> - 0.0-1
543 - Initial build