test/TEST-50-MULTINIC: install all nfsidmap libs for server
[dracut.git] / dracut.spec
blobe2b6f448ad90e0d82b31eaed4eee89b03bd59c62
1 # Variables must be defined
2 %define with_switch_root 1
3 %define with_nbd 1
5 # switchroot provided by util-linux-ng in F-12+
6 %if 0%{?fedora} > 11 || 0%{?rhel} >= 6
7 %define with_switch_root 0
8 %endif
9 # nbd in Fedora only
10 %if 0%{?rhel} >= 6
11 %define with_nbd 0
12 %endif
14 %if %{defined gittag}
15 %define rdist .git%{gittag}%{?dist}
16 %define dashgittag -%{gittag}
17 %else
18 %define rdist %{?dist}
19 %endif
21 Name: dracut
22 Version: 005
23 Release: 1%{?rdist}
24 Summary: Initramfs generator using udev
25 Group: System Environment/Base
26 License: GPLv2+
27 URL: http://apps.sourceforge.net/trac/dracut/wiki
28 # Source can be generated by
29 # http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=snapshot;h=%{?dashgittag};sf=tgz
30 Source0: dracut-%{version}%{?dashgittag}.tar.bz2
31 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
33 %if 0%{?fedora} > 12 || 0%{?rhel} >= 6
34 # no "provides", because dracut does not offer
35 # all functionality of the obsoleted packages
36 Obsoletes: mkinitrd <= 6.0.93
37 Obsoletes: mkinitrd-devel <= 6.0.93
38 Obsoletes: nash <= 6.0.93
39 Obsoletes: libbdevid-python <= 6.0.93
40 %endif
41 Obsoletes: dracut-kernel < 005
42 Provides: dracut-kernel = %{version}-%{release}
44 Requires: udev
45 Requires: util-linux-ng
46 Requires: module-init-tools >= 3.7-9
47 Requires: cpio
48 Requires: coreutils
49 Requires: findutils
50 Requires: binutils
51 Requires: grep
52 Requires: which
53 Requires: mktemp >= 1.5-5
54 Requires: mount
55 Requires: bash
56 Requires: dash
57 Requires: /bin/sh
58 Requires: fileutils, gzip, tar
59 Requires: lvm2 >= 2.02.33-9, dhclient
60 Requires: filesystem >= 2.1.0, cpio, device-mapper, initscripts >= 8.63-1
61 Requires: e2fsprogs >= 1.38-12, coreutils
62 Requires: mdadm, elfutils-libelf
63 Requires(pre): plymouth >= 0.8.0-0.2009.29.09.19.1
64 Requires: plymouth >= 0.8.0-0.2009.29.09.19.1
65 Requires: cryptsetup-luks
66 Requires: file
67 Requires: bzip2
68 Requires: dmraid
69 Requires: kbd
70 Requires: plymouth-scripts
72 %if ! 0%{?with_switch_root}
73 Requires: util-linux-ng >= 2.16
74 BuildArch: noarch
75 %endif
77 %description
78 Dracut contains tools to create a bootable initramfs for 2.6 Linux kernels.
79 Unlike existing implementations, dracut does hard-code as little as possible
80 into the initramfs. Dracut contains various modules which are driven by the
81 event-based udev. Having root on MD, DM, LVM2, LUKS is supported as well as
82 NFS, iSCSI, NBD, FCoE with the dracut-network package.
84 %package network
85 Summary: Dracut modules to build a dracut initramfs with network support
86 Requires: %{name} = %{version}-%{release}
87 Requires: rpcbind nfs-utils
88 Requires: iscsi-initiator-utils
89 %if %{with_nbd}
90 Requires: nbd
91 %endif
92 Requires: net-tools iproute
93 Requires: bridge-utils
95 %description network
96 This package requires everything which is needed to build a generic
97 all purpose initramfs with network support with dracut.
99 %package fips
100 Summary: Dracut modules to build a dracut initramfs with an integrity check
101 Requires: %{name} = %{version}-%{release}
102 Requires: hmaccalc
103 %if 0%{?rhel} > 5
104 # For Alpha 3, we want nss instead of nss-softokn
105 Requires: nss
106 %else
107 Requires: nss-softokn
108 %endif
109 Requires: nss-softokn-freebl
111 %description fips
112 This package requires everything which is needed to build an
113 all purpose initramfs with dracut, which does an integrity check.
115 %package generic
116 Summary: Metapackage to build a generic initramfs with dracut
117 Requires: %{name} = %{version}-%{release}
118 Requires: %{name}-network = %{version}-%{release}
120 %description generic
121 This package requires everything which is needed to build a generic
122 all purpose initramfs with dracut.
124 %package tools
125 Summary: Dracut tools to build the local initramfs
126 Requires: coreutils cryptsetup-luks device-mapper
127 Requires: diffutils dmraid findutils gawk grep lvm2
128 Requires: module-init-tools sed
129 Requires: cpio gzip
131 %description tools
132 This package contains tools to assemble the local initrd and host configuration.
134 %prep
135 %setup -q -n %{name}-%{version}%{?dashgittag}
137 %build
138 make WITH_SWITCH_ROOT=0%{?with_switch_root}
140 %install
141 rm -rf $RPM_BUILD_ROOT
142 make install DESTDIR=$RPM_BUILD_ROOT sbindir=/sbin \
143 sysconfdir=/etc mandir=%{_mandir} WITH_SWITCH_ROOT=0%{?with_switch_root}
145 echo %{name}-%{version}-%{release} > $RPM_BUILD_ROOT/%{_datadir}/dracut/modules.d/10rpmversion/dracut-version
146 rm $RPM_BUILD_ROOT/%{_datadir}/dracut/modules.d/01fips/check
148 mkdir -p $RPM_BUILD_ROOT/boot/dracut
149 mkdir -p $RPM_BUILD_ROOT/var/lib/dracut/overlay
150 mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log
151 touch $RPM_BUILD_ROOT%{_localstatedir}/log/dracut.log
153 %if 0%{?fedora} <= 12 && 0%{?rhel} < 6
154 rm $RPM_BUILD_ROOT/sbin/mkinitrd
155 rm $RPM_BUILD_ROOT/sbin/lsinitrd
156 %endif
158 %clean
159 rm -rf $RPM_BUILD_ROOT
161 %files
162 %defattr(-,root,root,0755)
163 %doc README HACKING TODO COPYING AUTHORS NEWS
164 /sbin/dracut
165 %if 0%{?with_switch_root}
166 /sbin/switch_root
167 %endif
168 %if 0%{?fedora} > 12 || 0%{?rhel} >= 6
169 /sbin/mkinitrd
170 /sbin/lsinitrd
171 %endif
172 %dir %{_datadir}/dracut
173 %{_datadir}/dracut/dracut-functions
174 %config(noreplace) /etc/dracut.conf
175 %dir /etc/dracut.conf.d
176 %{_mandir}/man8/dracut.8*
177 %{_mandir}/man5/dracut.conf.5*
178 %{_datadir}/dracut/modules.d/00dash
179 %{_datadir}/dracut/modules.d/10redhat-i18n
180 %{_datadir}/dracut/modules.d/10rpmversion
181 %{_datadir}/dracut/modules.d/50plymouth
182 %{_datadir}/dracut/modules.d/60xen
183 %{_datadir}/dracut/modules.d/90btrfs
184 %{_datadir}/dracut/modules.d/90crypt
185 %{_datadir}/dracut/modules.d/90dm
186 %{_datadir}/dracut/modules.d/90dmraid
187 %{_datadir}/dracut/modules.d/90dmsquash-live
188 %{_datadir}/dracut/modules.d/90kernel-modules
189 %{_datadir}/dracut/modules.d/90lvm
190 %{_datadir}/dracut/modules.d/90mdraid
191 %{_datadir}/dracut/modules.d/90multipath
192 %{_datadir}/dracut/modules.d/95debug
193 %{_datadir}/dracut/modules.d/95resume
194 %{_datadir}/dracut/modules.d/95rootfs-block
195 %{_datadir}/dracut/modules.d/95dasd
196 %{_datadir}/dracut/modules.d/95dasd_mod
197 %{_datadir}/dracut/modules.d/95zfcp
198 %{_datadir}/dracut/modules.d/95znet
199 %{_datadir}/dracut/modules.d/95terminfo
200 %{_datadir}/dracut/modules.d/95udev-rules
201 %{_datadir}/dracut/modules.d/95uswsusp
202 %{_datadir}/dracut/modules.d/98syslog
203 %{_datadir}/dracut/modules.d/99base
204 # logfile needs no logrotate, because it gets overwritten
205 # for every dracut run
206 %attr(0644,root,root) %ghost %config(missingok,noreplace) %{_localstatedir}/log/dracut.log
208 %files network
209 %defattr(-,root,root,0755)
210 %doc README HACKING TODO COPYING AUTHORS NEWS
211 %{_datadir}/dracut/modules.d/40network
212 %{_datadir}/dracut/modules.d/95fcoe
213 %{_datadir}/dracut/modules.d/95iscsi
214 %{_datadir}/dracut/modules.d/95nbd
215 %{_datadir}/dracut/modules.d/95nfs
216 %{_datadir}/dracut/modules.d/45ifcfg
218 %files fips
219 %defattr(-,root,root,0755)
220 %doc COPYING
221 %{_datadir}/dracut/modules.d/01fips
223 %files generic
224 %defattr(-,root,root,0755)
225 %doc README.generic
227 %files tools
228 %defattr(-,root,root,0755)
229 %doc COPYING NEWS
230 %{_mandir}/man8/dracut-gencmdline.8*
231 %{_mandir}/man8/dracut-catimages.8*
232 /sbin/dracut-gencmdline
233 /sbin/dracut-catimages
234 %dir /boot/dracut
235 %dir /var/lib/dracut
236 %dir /var/lib/dracut/overlay
238 %changelog
239 * Fri Jan 15 2010 Harald Hoyer <harald@redhat.com> 004-1
240 - version 004
241 - Resolves: rhbz#529339 rhbz#533494 rhbz#548550
242 - Resolves: rhbz#548555 rhbz#553195
244 * Wed Jan 13 2010 Harald Hoyer <harald@redhat.com> 003-3
245 - add Obsoletes of mkinitrd/nash/libbdevid-python
246 - Related: rhbz#543948
248 * Wed Jan 13 2010 Warren Togami <wtogami@redhat.com> 003-2
249 - nbd is Fedora only
251 * Fri Nov 27 2009 Harald Hoyer <harald@redhat.com> 003-1
252 - version 003
254 * Mon Nov 23 2009 Harald Hoyer <harald@redhat.com> 002-26
255 - add WITH_SWITCH_ROOT make flag
256 - add fips requirement conditional
257 - add more device mapper modules (bug #539656)
259 * Fri Nov 20 2009 Dennis Gregorovic <dgregor@redhat.com> - 002-25.1
260 - nss changes for Alpha 3
262 * Thu Nov 19 2009 Harald Hoyer <harald@redhat.com> 002-25
263 - add more requirements for dracut-fips (bug #539257)
265 * Tue Nov 17 2009 Harald Hoyer <harald@redhat.com> 002-24
266 - put fips module in a subpackage (bug #537619)
268 * Tue Nov 17 2009 Harald Hoyer <harald@redhat.com> 002-23
269 - install xdr utils for multipath (bug #463458)
271 * Thu Nov 12 2009 Harald Hoyer <harald@redhat.com> 002-22
272 - add module 90multipath
273 - add module 01fips
274 - renamed module 95ccw to 95znet (bug #533833)
275 - crypt: ignore devices in /etc/crypttab (root is not in there)
276 - dasd: only install /etc/dasd.conf in hostonly mode (bug #533833)
277 - zfcp: only install /etc/zfcp.conf in hostonly mode (bug #533833)
278 - kernel-modules: add scsi_dh scsi_dh_rdac scsi_dh_emc (bug #527750)
279 - dasd: use dasdconf.sh from s390utils (bug #533833)
281 * Fri Nov 06 2009 Harald Hoyer <harald@redhat.com> 002-21
282 - fix rd_DASD argument handling (bug #531720)
283 - Resolves: rhbz#531720
285 * Wed Nov 04 2009 Harald Hoyer <harald@redhat.com> 002-20
286 - fix rd_DASD argument handling (bug #531720)
287 - Resolves: rhbz#531720
289 * Tue Nov 03 2009 Harald Hoyer <harald@redhat.com> 002-19
290 - changed rd_DASD to rd_DASD_MOD (bug #531720)
291 - Resolves: rhbz#531720
293 * Tue Oct 27 2009 Harald Hoyer <harald@redhat.com> 002-18
294 - renamed lvm/device-mapper udev rules according to upstream changes
295 - fixed dracut search path issue
297 * Mon Oct 26 2009 Harald Hoyer <harald@redhat.com> 002-17
298 - load dm_mod module (bug #530540)
300 * Fri Oct 09 2009 Jesse Keating <jkeating@redhat.com> - 002-16
301 - Upgrade plymouth to Requires(pre) to make it show up before kernel
303 * Thu Oct 08 2009 Harald Hoyer <harald@redhat.com> 002-15
304 - s390 ccw: s/layer1/layer2/g
306 * Thu Oct 08 2009 Harald Hoyer <harald@redhat.com> 002-14
307 - add multinic support
308 - add s390 zfcp support
309 - add s390 network support
311 * Wed Oct 07 2009 Harald Hoyer <harald@redhat.com> 002-13
312 - fixed init=<command> handling
313 - kill loginit if "rdinitdebug" specified
314 - run dmsquash-live-root after udev has settled (bug #527514)
316 * Tue Oct 06 2009 Harald Hoyer <harald@redhat.com> 002-12
317 - add missing loginit helper
318 - corrected dracut manpage
320 * Thu Oct 01 2009 Harald Hoyer <harald@redhat.com> 002-11
321 - fixed dracut-gencmdline for root=UUID or LABEL
323 * Thu Oct 01 2009 Harald Hoyer <harald@redhat.com> 002-10
324 - do not destroy assembled raid arrays if mdadm.conf present
325 - mount /dev/shm
326 - let udevd not resolve group and user names
327 - preserve timestamps of tools on initramfs generation
328 - generate symlinks for binaries correctly
329 - moved network from udev to initqueue
330 - mount nfs3 with nfsvers=3 option and retry with nfsvers=2
331 - fixed nbd initqueue-finished
332 - improved debug output: specifying "rdinitdebug" now logs
333 to dmesg, console and /init.log
334 - stop udev before killing it
335 - add ghost /var/log/dracut.log
336 - dmsquash: use info() and die() rather than echo
337 - strip kernel modules which have no x bit set
338 - redirect stdin, stdout, stderr all RW to /dev/console
339 so the user can use "less" to view /init.log and dmesg
341 * Tue Sep 29 2009 Harald Hoyer <harald@redhat.com> 002-9
342 - make install of new dm/lvm udev rules optionally
343 - correct dasd module typo
345 * Fri Sep 25 2009 Warren Togami <wtogami@redhat.com> 002-8
346 - revert back to dracut-002-5 tarball 845dd502
347 lvm2 was reverted to pre-udev
349 * Wed Sep 23 2009 Harald Hoyer <harald@redhat.com> 002-7
350 - build with the correct tarball
352 * Wed Sep 23 2009 Harald Hoyer <harald@redhat.com> 002-6
353 - add new device mapper udev rules and dmeventd
354 bug 525319, 525015
356 * Wed Sep 23 2009 Warren Togami <wtogami@redaht.com> 002-5
357 - Revert back to -3, Add umount back to initrd
358 This makes no functional difference to LiveCD. See Bug #525319
360 * Mon Sep 21 2009 Warren Togami <wtogami@redhat.com> 002-4
361 - Fix LiveCD boot regression
363 * Mon Sep 21 2009 Harald Hoyer <harald@redhat.com> 002-3
364 - bail out if selinux policy could not be loaded and
365 selinux=0 not specified on kernel command line
366 (bug #524113)
367 - set finished criteria for dmsquash live images
369 * Fri Sep 18 2009 Harald Hoyer <harald@redhat.com> 002-2
370 - do not cleanup dmraids
371 - copy over lvm.conf
373 * Thu Sep 17 2009 Harald Hoyer <harald@redhat.com> 002-1
374 - version 002
375 - set correct PATH
376 - workaround for broken mdmon implementation
378 * Wed Sep 16 2009 Harald Hoyer <harald@redhat.com> 001-12
379 - removed lvm/mdraid/dmraid lock files
380 - add missing ifname= files
382 * Wed Sep 16 2009 Harald Hoyer <harald@redhat.com> 001-11
383 - generate dracut-version during rpm build time
385 * Tue Sep 15 2009 Harald Hoyer <harald@redhat.com> 001-10
386 - add ifname= argument for persistent netdev names
387 - new /initqueue-finished to check if the main loop can be left
388 - copy mdadm.conf if --mdadmconf set or mdadmconf in dracut.conf
390 * Wed Sep 09 2009 Harald Hoyer <harald@redhat.com> 001-9
391 - added Requires: plymouth-scripts
393 * Wed Sep 09 2009 Harald Hoyer <harald@redhat.com> 001-8
394 - plymouth: use plymouth-populate-initrd
395 - add add_drivers for dracut and dracut.conf
396 - do not mount /proc and /selinux manually in selinux-load-policy
398 * Wed Sep 09 2009 Harald Hoyer <harald@redhat.com> 001-7
399 - add scsi_wait_scan to be sure everything was scanned
401 * Tue Sep 08 2009 Harald Hoyer <harald@redhat.com> 001-6
402 - fixed several problems with md raid containers
403 - fixed selinux policy loading
405 * Tue Sep 08 2009 Harald Hoyer <harald@redhat.com> 001-5
406 - patch does not honor file modes, fixed them manually
408 * Mon Sep 07 2009 Harald Hoyer <harald@redhat.com> 001-4
409 - fixed mdraid for IMSM
411 * Mon Sep 07 2009 Harald Hoyer <harald@redhat.com> 001-3
412 - fixed bug, which prevents installing 61-persistent-storage.rules (bug #520109)
414 * Thu Sep 03 2009 Harald Hoyer <harald@redhat.com> 001-2
415 - fixed missing grep for md
416 - reorder cleanup
418 * Wed Sep 02 2009 Harald Hoyer <harald@redhat.com> 001-1
419 - version 001
420 - see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
422 * Fri Aug 14 2009 Harald Hoyer <harald@redhat.com> 0.9-1
423 - version 0.9
425 * Thu Aug 06 2009 Harald Hoyer <harald@redhat.com> 0.8-1
426 - version 0.8
427 - see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
429 * Fri Jul 24 2009 Harald Hoyer <harald@redhat.com> 0.7-1
430 - version 0.7
431 - see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
433 * Wed Jul 22 2009 Harald Hoyer <harald@redhat.com> 0.6-1
434 - version 0.6
435 - see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
437 * Fri Jul 17 2009 Harald Hoyer <harald@redhat.com> 0.5-1
438 - version 0.5
439 - see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
441 * Sat Jul 04 2009 Harald Hoyer <harald@redhat.com> 0.4-1
442 - version 0.4
443 - see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
445 * Thu Jul 02 2009 Harald Hoyer <harald@redhat.com> 0.3-1
446 - version 0.3
447 - see http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=blob_plain;f=NEWS
449 * Wed Jul 01 2009 Harald Hoyer <harald@redhat.com> 0.2-1
450 - version 0.2
452 * Fri Jun 19 2009 Harald Hoyer <harald@redhat.com> 0.1-1
453 - first release
455 * Thu Dec 18 2008 Jeremy Katz <katzj@redhat.com> - 0.0-1
456 - Initial build