1 # Variables must be defined
2 %define with_switch_root
1
5 # switchroot provided by util-linux-ng in F-12+
6 %if 0%{?fedora} > 11 || 0%{?rhel} >= 6
7 %define with_switch_root
0
15 %define rdist .git
%{gittag}%{?dist}
16 %define dashgittag
-%{gittag}
18 %define rdist
%{?dist}
24 Summary: Initramfs generator using udev
25 Group: System Environment
/Base
27 URL: http
://apps.sourceforge.net
/trac
/dracut
/wiki
28 # Source can be generated by
29 # http://dracut.git.sourceforge.net/git/gitweb.cgi?p=dracut/dracut;a=snapshot;h=%{?dashgittag};sf=tgz
30 Source0: dracut
-%{version}%{?dashgittag}.tar.bz2
31 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n
)
32 BuildRequires
: docbook
-style
-xsl docbook
-dtds docbook
-style
-xsl libxslt
34 %if 0%{?fedora} > 12 || 0%{?rhel} >= 6
35 # no "provides", because dracut does not offer
36 # all functionality of the obsoleted packages
37 Obsoletes
: mkinitrd
<= 6.0.93
38 Obsoletes
: mkinitrd
-devel
<= 6.0.93
39 Obsoletes
: nash
<= 6.0.93
40 Obsoletes
: libbdevid
-python
<= 6.0.93
42 Obsoletes
: dracut
-kernel
< 005
43 Provides: dracut
-kernel
= %{version}-%{release}
50 Requires: filesystem
>= 2.1.0
54 Requires: initscripts
>= 8.63-1
56 Requires: mktemp
>= 1.5-5
57 Requires: module
-init
-tools
>= 3.7-9
59 Requires: plymouth
>= 0.8.0-0.2009.29.09.19.1
63 Requires: util
-linux
-ng
>= 2.16
65 %if ! 0%{?with_switch_root}
70 Dracut contains tools to create a bootable initramfs
for 2.6 Linux kernels.
71 Unlike existing implementations
, dracut does hard
-code as little as possible
72 into the initramfs. Dracut contains various modules which are driven by the
73 event
-based udev. Having root on MD
, DM
, LVM2
, LUKS is supported as well as
74 NFS
, iSCSI
, NBD
, FCoE with the dracut
-network package.
77 Summary: Dracut modules to build a dracut initramfs with network support
78 Requires: %{name} = %{version}-%{release}
79 Requires: rpcbind nfs
-utils
80 Requires: iscsi
-initiator
-utils
85 Requires: net
-tools iproute
86 Requires: bridge
-utils
90 This package requires everything which is needed to build a generic
91 all purpose initramfs with network support with dracut.
94 Summary: Dracut modules to build a dracut initramfs with an integrity check
95 Requires: %{name} = %{version}-%{release}
98 # For Alpha 3, we want nss instead of nss-softokn
101 Requires: nss
-softokn
103 Requires: nss
-softokn
-freebl
106 This package requires everything which is needed to build an
107 all purpose initramfs with dracut
, which does an integrity check.
110 Summary: Metapackage to build a generic initramfs with dracut
111 Requires: %{name} = %{version}-%{release}
112 Requires: %{name}-network = %{version}-%{release}
115 This package requires everything which is needed to build a generic
116 all purpose initramfs with dracut.
119 Summary: Dracut tools to build the
local initramfs
120 Requires: coreutils cryptsetup
-luks device
-mapper
121 Requires: diffutils dmraid findutils grep lvm2 gawk
122 Requires: module
-init
-tools sed
124 Requires: %{name} = %{version}-%{release}
127 This package contains tools to assemble the
local initrd and host configuration.
130 %setup -q
-n
%{name}-%{version}%{?dashgittag}
133 make WITH_SWITCH_ROOT
=0%{?with_switch_root}
136 rm -rf $RPM_BUILD_ROOT
137 make install DESTDIR
=$RPM_BUILD_ROOT sbindir
=/sbin \
138 sysconfdir
=/etc mandir
=%{_mandir} WITH_SWITCH_ROOT=0%{?with_switch_root}
140 echo %{name}-%{version}-%{release} > $RPM_BUILD_ROOT/%{_datadir}/dracut
/modules.d
/10rpmversion
/dracut
-version
141 rm $RPM_BUILD_ROOT
/%{_datadir}/dracut
/modules.d
/01fips
/check
142 # remove gentoo specific modules
143 rm -fr $RPM_BUILD_ROOT
/%{_datadir}/dracut
/modules.d
/50gensplash
145 mkdir -p $RPM_BUILD_ROOT
/boot
/dracut
146 mkdir -p $RPM_BUILD_ROOT
/var
/lib
/dracut
/overlay
147 mkdir -p $RPM_BUILD_ROOT
%{_localstatedir}/log
148 touch $RPM_BUILD_ROOT
%{_localstatedir}/log
/dracut.log
149 install -m
0644 dracut.conf.d
/fedora.conf.example $RPM_BUILD_ROOT
/etc
/dracut.conf.d
/fedora.conf
151 %if 0%{?fedora} <= 12 && 0%{?rhel} < 6
152 rm $RPM_BUILD_ROOT
/sbin
/mkinitrd
153 rm $RPM_BUILD_ROOT
/sbin
/lsinitrd
157 rm -rf $RPM_BUILD_ROOT
160 %defattr(-,root
,root
,0755)
161 %doc README HACKING TODO COPYING AUTHORS NEWS
163 %if 0%{?with_switch_root}
166 %if 0%{?fedora} > 12 || 0%{?rhel} >= 6
170 %dir %{_datadir}/dracut
171 %{_datadir}/dracut
/dracut
-functions
172 %config(noreplace
) /etc
/dracut.conf
173 %config(noreplace
) /etc
/dracut.conf.d
/fedora.conf
174 %dir /etc
/dracut.conf.d
175 %{_mandir}/man8
/dracut
.8*
176 %{_mandir}/man7
/dracut.kernel
.7*
177 %{_mandir}/man5
/dracut.conf
.5*
178 %{_datadir}/dracut
/modules.d
/00bootchart
179 %{_datadir}/dracut
/modules.d
/00dash
180 %{_datadir}/dracut
/modules.d
/10i18n
181 %{_datadir}/dracut
/modules.d
/10rpmversion
182 %{_datadir}/dracut
/modules.d
/50plymouth
183 %{_datadir}/dracut
/modules.d
/60xen
184 %{_datadir}/dracut
/modules.d
/90btrfs
185 %{_datadir}/dracut
/modules.d
/90crypt
186 %{_datadir}/dracut
/modules.d
/90dm
187 %{_datadir}/dracut
/modules.d
/90dmraid
188 %{_datadir}/dracut
/modules.d
/90dmsquash
-live
189 %{_datadir}/dracut
/modules.d
/90kernel
-modules
190 %{_datadir}/dracut
/modules.d
/90lvm
191 %{_datadir}/dracut
/modules.d
/90mdraid
192 %{_datadir}/dracut
/modules.d
/90multipath
193 %{_datadir}/dracut
/modules.d
/95debug
194 %{_datadir}/dracut
/modules.d
/95resume
195 %{_datadir}/dracut
/modules.d
/95rootfs
-block
196 %{_datadir}/dracut
/modules.d
/95dasd
197 %{_datadir}/dracut
/modules.d
/95dasd_mod
198 %{_datadir}/dracut
/modules.d
/95zfcp
199 %{_datadir}/dracut
/modules.d
/95terminfo
200 %{_datadir}/dracut
/modules.d
/95udev
-rules
201 %{_datadir}/dracut
/modules.d
/95uswsusp
202 %{_datadir}/dracut
/modules.d
/98selinux
203 %{_datadir}/dracut
/modules.d
/98syslog
204 %{_datadir}/dracut
/modules.d
/99base
205 # logfile needs no logrotate, because it gets overwritten
206 # for every dracut run
207 %attr(0644,root
,root
) %ghost %config(missingok
,noreplace
) %{_localstatedir}/log
/dracut.log
210 %defattr(-,root
,root
,0755)
211 %{_datadir}/dracut
/modules.d
/40network
212 %{_datadir}/dracut
/modules.d
/95fcoe
213 %{_datadir}/dracut
/modules.d
/95iscsi
214 %{_datadir}/dracut
/modules.d
/95nbd
215 %{_datadir}/dracut
/modules.d
/95nfs
216 %{_datadir}/dracut
/modules.d
/45ifcfg
217 %{_datadir}/dracut
/modules.d
/95znet
220 %defattr(-,root
,root
,0755)
221 %{_datadir}/dracut
/modules.d
/01fips
224 %defattr(-,root
,root
,0755)
228 %defattr(-,root
,root
,0755)
229 %{_mandir}/man8
/dracut
-gencmdline
.8*
230 %{_mandir}/man8
/dracut
-catimages
.8*
231 /sbin
/dracut
-gencmdline
232 /sbin
/dracut
-catimages
235 %dir /var
/lib
/dracut
/overlay
238 * Thu Jun
17 2010 Harald Hoyer
<harald@redhat.com
> 006-1
241 * Fri Jun
11 2010 Harald Hoyer
<harald@redhat.com
>
242 - Remove requirements
, which are not really needed
243 Resolves
: rhbz
#598509
244 - fixed copy of network config to
/dev
/.initramfs
/ (patch
146)
245 Resolves
: rhbz
#594649
246 - more password beauty
(patch
142)
247 Resolves
: rhbz
#561092
248 - support multiple iSCSI disks
(patch
143)
249 Resolves
: rbhz
#580190
250 - fixed selinux
=0 (patch
130)
251 Resolves
: rhbz
#593080
252 - add support
for booting LVM snapshot root volume
(patch
145)
253 Resolves
: rbhz
#602723
254 - remove hardware field from BOOTIF
= (patch
148)
255 Resolves
: rhbz
#599593
256 - add aes kernel modules and fix crypt handling
(patch
137, patch
140 and patch
147)
257 Resolves
: rhbz
#600170
259 * Thu May
27 2010 Harald Hoyer
<harald@redhat.com
>
262 Resolves
: rhbz
#538388
264 Resolves
: rhbz
#595719
266 * Thu May
06 2010 Harald Hoyer
<harald@redhat.com
>
267 - only display short password messages
268 Resolves
: rhbz
#561092
270 * Thu May
06 2010 Harald Hoyer
<harald@redhat.com
>
271 - fixed dracut manpages
272 Resolves
: rhbz
#589109
273 - use ccw
-init and ccw rules from s390utils
274 Resolves
: rhbz
#533494
276 Resolves
: rhbz
#486244
277 - various other bugfixes seen
in Fedora
279 * Tue Apr
20 2010 Harald Hoyer
<harald@redhat.com
>
280 - fixed network with multiple nics
281 - fixed nfsidmap paths
282 - do not run blkid on non active container raids
283 - fixed cdrom polling mechanism
284 - update to latest git
286 * Thu Apr
15 2010 Harald Hoyer
<harald@redhat.com
>
287 - fixed dracut manpages
288 - dmraid parse different error messages
289 - add cdrom polling mechanism
for slow cdroms
291 - teach dmsquash live
-root to use rootflags
292 - trigger udev with action
=add
293 - fixed add_drivers handling
295 - use pigz instead of gzip
, if available
297 * Thu Mar
25 2010 Harald Hoyer
<harald@redhat.com
>
298 - removed firmware requirements
(rhbz
#572634)
299 - add
/etc
/dracut.conf.d
300 - Resolves
: rhbz
#572634
302 * Fri Mar
19 2010 Harald Hoyer
<harald@redhat.com
>
305 * Fri Mar
19 2010 Harald Hoyer
<harald@redhat.com
>
306 - fixed rpmlint errors
(rhbz
#570547)
307 - removed firmware package from dracut
-kernel
(rhbz
#572634)
308 - add dcb support to dracut's FCoE support
(rhbz
#563794)
309 - force
install some modules
in hostonly mode
(rhbz
#573094)
310 - various other bugfixes
311 - Resolves
: rhbz
#570547, rhbz#572634, rhbz#563794, rhbz#573094
313 * Thu Feb
18 2010 Harald Hoyer
<harald@redhat.com
> 004-15
314 - fixed "selinux
=0" booting
(rhbz
#566376)
315 - fixed internal IFS handling
316 - Resolves
: rhbz
#566376
318 * Fri Jan
29 2010 Harald Hoyer
<harald@redhat.com
> 004-5
319 - fixed firmware.sh bug
(#559975 #559597)
321 * Tue Jan
26 2010 Harald Hoyer
<harald@redhat.com
> 004-4
322 - add multipath check
324 * Tue Jan
26 2010 Harald Hoyer
<harald@redhat.com
> 004-3
325 - fix selinux handling
if .autorelabel is present
326 - Resolves
: rhbz
#557744
328 * Wed Jan
20 2010 Harald Hoyer
<harald@redhat.com
> 004-2
329 - fix emergency_shell argument parsing
330 - Related
: rhbz
#543948
332 * Fri Jan
15 2010 Harald Hoyer
<harald@redhat.com
> 004-1
334 - Resolves
: rhbz
#529339 rhbz#533494 rhbz#548550
335 - Resolves
: rhbz
#548555 rhbz#553195
337 * Wed Jan
13 2010 Harald Hoyer
<harald@redhat.com
> 003-3
338 - add Obsoletes of mkinitrd
/nash
/libbdevid
-python
339 - Related
: rhbz
#543948
341 * Wed Jan
13 2010 Warren Togami
<wtogami@redhat.com
> 003-2
344 * Fri Nov
27 2009 Harald Hoyer
<harald@redhat.com
> 003-1
347 * Mon Nov
23 2009 Harald Hoyer
<harald@redhat.com
> 002-26
348 - add WITH_SWITCH_ROOT
make flag
349 - add fips requirement conditional
350 - add more device mapper modules
(bug
#539656)
352 * Fri Nov
20 2009 Dennis Gregorovic
<dgregor@redhat.com
> - 002-25.1
353 - nss changes
for Alpha
3
355 * Thu Nov
19 2009 Harald Hoyer
<harald@redhat.com
> 002-25
356 - add more requirements
for dracut
-fips
(bug
#539257)
358 * Tue Nov
17 2009 Harald Hoyer
<harald@redhat.com
> 002-24
359 - put fips module
in a subpackage
(bug
#537619)
361 * Tue Nov
17 2009 Harald Hoyer
<harald@redhat.com
> 002-23
362 - install xdr utils
for multipath
(bug
#463458)
364 * Thu Nov
12 2009 Harald Hoyer
<harald@redhat.com
> 002-22
365 - add module
90multipath
367 - renamed module
95ccw to
95znet
(bug
#533833)
368 - crypt
: ignore devices
in /etc
/crypttab
(root is not
in there
)
369 - dasd
: only
install /etc
/dasd.conf
in hostonly mode
(bug
#533833)
370 - zfcp
: only
install /etc
/zfcp.conf
in hostonly mode
(bug
#533833)
371 - kernel
-modules
: add scsi_dh scsi_dh_rdac scsi_dh_emc
(bug
#527750)
372 - dasd
: use dasdconf.sh from s390utils
(bug
#533833)
374 * Fri Nov
06 2009 Harald Hoyer
<harald@redhat.com
> 002-21
375 - fix rd_DASD argument handling
(bug
#531720)
376 - Resolves
: rhbz
#531720
378 * Wed Nov
04 2009 Harald Hoyer
<harald@redhat.com
> 002-20
379 - fix rd_DASD argument handling
(bug
#531720)
380 - Resolves
: rhbz
#531720
382 * Tue Nov
03 2009 Harald Hoyer
<harald@redhat.com
> 002-19
383 - changed rd_DASD to rd_DASD_MOD
(bug
#531720)
384 - Resolves
: rhbz
#531720
386 * Tue Oct
27 2009 Harald Hoyer
<harald@redhat.com
> 002-18
387 - renamed lvm
/device
-mapper udev rules according to upstream changes
388 - fixed dracut search path issue
390 * Mon Oct
26 2009 Harald Hoyer
<harald@redhat.com
> 002-17
391 - load dm_mod module
(bug
#530540)
393 * Fri Oct
09 2009 Jesse Keating
<jkeating@redhat.com
> - 002-16
394 - Upgrade plymouth to
Requires(pre
) to
make it show up before kernel
396 * Thu Oct
08 2009 Harald Hoyer
<harald@redhat.com
> 002-15
397 - s390 ccw
: s
/layer1
/layer2
/g
399 * Thu Oct
08 2009 Harald Hoyer
<harald@redhat.com
> 002-14
400 - add multinic support
401 - add s390 zfcp support
402 - add s390 network support
404 * Wed Oct
07 2009 Harald Hoyer
<harald@redhat.com
> 002-13
405 - fixed init
=<command> handling
406 - kill loginit
if "rdinitdebug" specified
407 - run dmsquash
-live
-root after udev has settled
(bug
#527514)
409 * Tue Oct
06 2009 Harald Hoyer
<harald@redhat.com
> 002-12
410 - add missing loginit helper
411 - corrected dracut manpage
413 * Thu Oct
01 2009 Harald Hoyer
<harald@redhat.com
> 002-11
414 - fixed dracut
-gencmdline
for root
=UUID or LABEL
416 * Thu Oct
01 2009 Harald Hoyer
<harald@redhat.com
> 002-10
417 - do not destroy assembled raid arrays
if mdadm.conf present
419 - let udevd not resolve group and user names
420 - preserve timestamps of tools on initramfs generation
421 - generate symlinks
for binaries correctly
422 - moved network from udev to initqueue
423 - mount nfs3 with nfsvers
=3 option and retry with nfsvers
=2
424 - fixed nbd initqueue
-finished
425 - improved debug output
: specifying "rdinitdebug" now logs
426 to dmesg
, console and
/init.log
427 - stop udev before killing it
428 - add ghost
/var
/log
/dracut.log
429 - dmsquash
: use info
() and die
() rather than
echo
430 - strip kernel modules which have no x bit
set
431 - redirect stdin
, stdout
, stderr all RW to
/dev
/console
432 so the user can use "less" to view
/init.log and dmesg
434 * Tue Sep
29 2009 Harald Hoyer
<harald@redhat.com
> 002-9
435 - make install of new dm
/lvm udev rules optionally
436 - correct dasd module typo
438 * Fri Sep
25 2009 Warren Togami
<wtogami@redhat.com
> 002-8
439 - revert back to dracut
-002-5 tarball
845dd502
440 lvm2 was reverted to pre
-udev
442 * Wed Sep
23 2009 Harald Hoyer
<harald@redhat.com
> 002-7
443 - build with the correct tarball
445 * Wed Sep
23 2009 Harald Hoyer
<harald@redhat.com
> 002-6
446 - add new device mapper udev rules and dmeventd
449 * Wed Sep
23 2009 Warren Togami
<wtogami@redaht.com
> 002-5
450 - Revert back to
-3, Add umount back to initrd
451 This makes no functional difference to LiveCD. See Bug
#525319
453 * Mon Sep
21 2009 Warren Togami
<wtogami@redhat.com
> 002-4
454 - Fix LiveCD boot regression
456 * Mon Sep
21 2009 Harald Hoyer
<harald@redhat.com
> 002-3
457 - bail out
if selinux policy could not be loaded and
458 selinux
=0 not specified on kernel
command line
460 - set finished criteria
for dmsquash live images
462 * Fri Sep
18 2009 Harald Hoyer
<harald@redhat.com
> 002-2
463 - do not cleanup dmraids
466 * Thu Sep
17 2009 Harald Hoyer
<harald@redhat.com
> 002-1
469 - workaround
for broken mdmon implementation
471 * Wed Sep
16 2009 Harald Hoyer
<harald@redhat.com
> 001-12
472 - removed lvm
/mdraid
/dmraid lock files
473 - add missing ifname
= files
475 * Wed Sep
16 2009 Harald Hoyer
<harald@redhat.com
> 001-11
476 - generate dracut
-version during rpm build
time
478 * Tue Sep
15 2009 Harald Hoyer
<harald@redhat.com
> 001-10
479 - add ifname
= argument
for persistent netdev names
480 - new
/initqueue
-finished to check
if the main loop can be left
481 - copy mdadm.conf
if --mdadmconf
set or mdadmconf
in dracut.conf
483 * Wed Sep
09 2009 Harald Hoyer
<harald@redhat.com
> 001-9
484 - added
Requires: plymouth
-scripts
486 * Wed Sep
09 2009 Harald Hoyer
<harald@redhat.com
> 001-8
487 - plymouth
: use plymouth
-populate
-initrd
488 - add add_drivers
for dracut and dracut.conf
489 - do not mount
/proc and
/selinux manually
in selinux
-load
-policy
491 * Wed Sep
09 2009 Harald Hoyer
<harald@redhat.com
> 001-7
492 - add scsi_wait_scan to be sure everything was scanned
494 * Tue Sep
08 2009 Harald Hoyer
<harald@redhat.com
> 001-6
495 - fixed several problems with md raid containers
496 - fixed selinux policy loading
498 * Tue Sep
08 2009 Harald Hoyer
<harald@redhat.com
> 001-5
499 - patch does not honor file modes
, fixed them manually
501 * Mon Sep
07 2009 Harald Hoyer
<harald@redhat.com
> 001-4
502 - fixed mdraid
for IMSM
504 * Mon Sep
07 2009 Harald Hoyer
<harald@redhat.com
> 001-3
505 - fixed bug
, which prevents installing
61-persistent
-storage.rules
(bug
#520109)
507 * Thu Sep
03 2009 Harald Hoyer
<harald@redhat.com
> 001-2
508 - fixed missing grep
for md
511 * Wed Sep
02 2009 Harald Hoyer
<harald@redhat.com
> 001-1
513 - see http
://dracut.git.sourceforge.net
/git
/gitweb.cgi?p
=dracut
/dracut
;a
=blob_plain
;f
=NEWS
515 * Fri Aug
14 2009 Harald Hoyer
<harald@redhat.com
> 0.9-1
518 * Thu Aug
06 2009 Harald Hoyer
<harald@redhat.com
> 0.8-1
520 - see http
://dracut.git.sourceforge.net
/git
/gitweb.cgi?p
=dracut
/dracut
;a
=blob_plain
;f
=NEWS
522 * Fri Jul
24 2009 Harald Hoyer
<harald@redhat.com
> 0.7-1
524 - see http
://dracut.git.sourceforge.net
/git
/gitweb.cgi?p
=dracut
/dracut
;a
=blob_plain
;f
=NEWS
526 * Wed Jul
22 2009 Harald Hoyer
<harald@redhat.com
> 0.6-1
528 - see http
://dracut.git.sourceforge.net
/git
/gitweb.cgi?p
=dracut
/dracut
;a
=blob_plain
;f
=NEWS
530 * Fri Jul
17 2009 Harald Hoyer
<harald@redhat.com
> 0.5-1
532 - see http
://dracut.git.sourceforge.net
/git
/gitweb.cgi?p
=dracut
/dracut
;a
=blob_plain
;f
=NEWS
534 * Sat Jul
04 2009 Harald Hoyer
<harald@redhat.com
> 0.4-1
536 - see http
://dracut.git.sourceforge.net
/git
/gitweb.cgi?p
=dracut
/dracut
;a
=blob_plain
;f
=NEWS
538 * Thu Jul
02 2009 Harald Hoyer
<harald@redhat.com
> 0.3-1
540 - see http
://dracut.git.sourceforge.net
/git
/gitweb.cgi?p
=dracut
/dracut
;a
=blob_plain
;f
=NEWS
542 * Wed Jul
01 2009 Harald Hoyer
<harald@redhat.com
> 0.2-1
545 * Fri Jun
19 2009 Harald Hoyer
<harald@redhat.com
> 0.1-1
548 * Thu Dec
18 2008 Jeremy Katz
<katzj@redhat.com
> - 0.0-1