Update copyright notices.
[dput.git] / debian / rules
blob8c7f1cf56797ff2b2798c780738014366e6aa218
1 #! /usr/bin/make -f
3 # debian/rules
4 # Part of Debian ‘dput’ package.
6 # Copyright © 2015–2016 Ben Finney <ben+debian@benfinney.id.au>
8 # This is free software: you may copy, modify, and/or distribute this work
9 # under the terms of the GNU General Public License as published by the
10 # Free Software Foundation; version 2 of that license or any later version.
11 # No warranty expressed or implied. See the file ‘LICENSE.GPL-2’ for details.
13 PACKAGE_NAME = dput
14 LC_ALL := C.UTF-8
15 export LC_ALL
17 package_share_dir = /usr/share/${PACKAGE_NAME}
18 export PYBUILD_INSTALL_ARGS ?= \
19 --install-lib=${package_share_dir}/ \
20 --install-scripts=${package_share_dir}/
24 dh $@ --with=python2 --buildsystem=pybuild
27 override_dh_clean:
28 dh_clean
29 make clean
31 override_dh_installman:
32 dh_installman --language=C
35 # Local variables:
36 # coding: utf-8
37 # mode: make
38 # End:
39 # vim: fileencoding=utf-8 filetype=make :