Document in the changelog the ‘dcut’ completion improvement.
[dput.git] / debian / rules
blobb9914a04fe898d5dc21a499d87c932aa8a4a9441
1 #! /usr/bin/make -f
3 # debian/rules
4 # Part of Debian ‘dput’ package.
6 # This is free software, and you are welcome to redistribute it under
7 # certain conditions; see the end of this file for copyright
8 # information, grant of license, and disclaimer of warranty.
10 PACKAGE_NAME = dput
12 export LC_ALL := C.UTF-8
13 export PYTHONIOENCODING := utf-8
15 package_share_dir = /usr/share/${PACKAGE_NAME}
16 export PYBUILD_INSTALL_ARGS ?= \
17 --install-lib=${package_share_dir}/ \
18 --install-scripts=${package_share_dir}/
22 dh $@ --with=bash-completion,python2 --buildsystem=pybuild
25 override_dh_clean:
26 dh_clean
27 make clean
29 override_dh_installman:
30 dh_installman --language=C
33 # Copyright © 2015–2016 Ben Finney <bignose@debian.org>
35 # This is free software: you may copy, modify, and/or distribute this work
36 # under the terms of the GNU General Public License as published by the
37 # Free Software Foundation; version 2 of that license or any later version.
38 # No warranty expressed or implied. See the file ‘LICENSE.GPL-2’ for details.
41 # Local variables:
42 # coding: utf-8
43 # mode: make
44 # End:
45 # vim: fileencoding=utf-8 filetype=make :