fixed emesene
[dottout.git] / net-dialup / hsoconnect / hsoconnect-1.2.19.ebuild
blob3679053161e0f3655f94628505acb584f57c65c8
1 # Copyright 1999-2009 Gentoo Technologies, Inc.
2 # Distributed under the terms of the GNU General Public License v2
4 inherit rpm
6 DESCRIPTION="HSO UMTS PyGTK Connection Manager"
7 HOMEPAGE="http://www.pharscape.org/"
8 SRC_URI="http://www.pharscape.org/Downloads.html/RPM/hsoconnect-py2.5-1.1.128-2.noarch.rpm"
9 SLOT="0"
10 LICENSE="GPL-2"
11 KEYWORDS="~x86 ~amd64"
13 RDEPEND="=dev-lang/python-2.5*
14 net-dialup/hsolink
15 sys-apps/usb_modeswitch
16 sys-fs/udev"
18 src_install() {
19 chmod -R go-w "${WORKDIR}/usr/"
20 chgrp -R uucp "${WORKDIR}/usr/share/HSOconnect/"
21 chmod g+sw "${WORKDIR}/usr/share/HSOconnect/"
22 chmod -R g+w "${WORKDIR}/usr/share/HSOconnect/HSOconnect.cfg"
23 chmod -R g+w "${WORKDIR}/usr/share/HSOconnect/profiles/"
24 chmod g+s "${WORKDIR}"/usr/share/HSOconnect/profiles/*/
25 mv "${WORKDIR}"/* "${D}"
27 insinto /etc/udev/rules.d/
28 doins "${FILESDIR}"/91-usb_modeswitch.rules
30 echo 'CONFIG_PROTECT="/usr/share/HSOconnect"' > "${T}/50${PN}"
31 echo 'CONFIG_PROTECT_MASK="/usr/share/HSOconnect/images /usr/share/HSOconnect/languages"' >> "${T}/50${PN}"
32 doenvd "${T}/50${PN}"