removed old me-tv, updated sopcast
[dottout.git] / media-video / elisa / elisa-0.3.5.ebuild
blob17ac06d77510984fe951a8bb5f52fb7d15a9faf1
1 # Copyright 2006-2007 BreakMyGentoo.org
2 # Copyright 2008 Daniel Gryniewcz
3 # Distributed under the terms of the GNU General Public License v2
5 inherit distutils python
7 DESCRIPTION="Elisa is an open source, cross platform media center solution for Linux, MacOSX and Windows on top of GStreamer."
8 HOMEPAGE="http://elisa.fluendo.com/"
9 SRC_URI="http://elisa.fluendo.com/static/download/${PN}/${P}.tar.gz"
11 RESTRICT="nomirror"
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="-* ~amd64 ~ppc ~x86"
16 IUSE="daap doc dvd ipod lirc"
18 MAKEOPTS="-j1"
20 RDEPEND=">=dev-lang/python-2.5
21 dev-python/setuptools
22 >=dev-python/imaging-1
23 >=dev-python/twisted-2.2
24 dev-python/twisted-web
25 dev-python/gnome-python-extras
26 dev-python/pygtk
27 >=media-libs/pigment-0.3.5
28 >=dev-python/pigment-python-0.3.3
29 >=media-libs/gstreamer-0.10.4
30 >=dev-python/gst-python-0.10
31 >=media-plugins/gst-plugins-ogg-0.10
32 >=media-plugins/gst-plugins-vorbis-0.10
33 >=media-plugins/gst-plugins-theora-0.10
34 media-plugins/libvisual-plugins:0.4
35 dev-python/pyxdg
36 dvd? (
37 media-libs/libdvdcss
38 >=media-plugins/gst-plugins-ffmpeg-0.10
39 >=media-libs/gst-plugins-bad-0.10
40 >=media-libs/gst-plugins-ugly-0.10
41 dev-python/tagpy
43 lirc? (
44 app-misc/lirc
45 dev-python/pylirc
47 daap? (
48 dev-python/PythonDaap
49 >=sys-apps/dbus-1
50 >=dev-python/dbus-python-0.71
51 >=net-dns/avahi-0.6
53 ipod? (
54 media-libs/libgpod
55 >=sys-apps/dbus-1
56 >=dev-python/dbus-python-0.71
57 >=sys-apps/hal-0.5
61 DEPEND="${DEPEND}
62 >=dev-util/pkgconfig-0.9"
64 PDEPEND=">=media-plugins/elisa-plugins-good-${PV}
65 >=media-plugins/elisa-plugins-bad-${PV}
66 >=media-plugins/elisa-plugins-ugly-0.3.4"
68 DOCS="AUTHORS ChangeLog COPYING NEWS"
70 pkg_setup() {
71 if use daap ; then
72 if built_with_use net-dns/avahi python ; then
73 einfo "Avahi Python bindings found ..."
74 else
75 eerror "Please rebuild net-dns/avahi with python support enabled!"
76 eerror "Try USE=\"python\" emerge net-dns/avahi,"
77 eerror "or add \"python\" to your USE string in /etc/make.conf and"
78 eerror "emerge net-dns/avahi."
79 die "USE flag \"python\" must be enabled in net-dns/avahi"
84 if use ipod ; then
85 if built_with_use media-libs/libgpod python ; then
86 einfo "libgpod Python bindings found ..."
87 else
88 eerror "Please rebuild media-libs/libgpod with python support enabled!"
89 eerror "Try USE=\"python\" emerge media-libs/libgpod,"
90 eerror "or add \"python\" to your USE string in /etc/make.conf and"
91 eerror "emerge media-libs/libgpod."
92 die "USE flag \"python\" must be enabled in media-libs/libgpod"
96 addpredict "/root/.gstreamer-0.10"
99 pkg_postinst() {
101 einfo "After first run of the box, edit elisa.conf and add some media"
102 einfo "locations in [xmlmenu:locaions_builder]"
103 einfo "e.g."
104 einfo "locations = ['file://./sample_data/pictures', 'file:///media/videos']"
105 einfo ""
106 einfo "If you get failures loading plugins, delete ~/.elisa"