fixed amueladu-9999 typo
[dottout.git] / net-p2p / amuleadu / amuleadu-9999.ebuild
blob459fbd7781c87bffd778daf1fa3eacb06c46a64f
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.2.0_pre20070422.ebuild,v 1.1 2007/04/22 11:48:32 armin76 Exp $
5 inherit subversion autotools eutils flag-o-matic wxwidgets
7 ESVN_REPO_URI="https://amule-adunanza.svn.sourceforge.net/svnroot/amule-adunanza/branches/mrhyde_test"
8 ESVN_PROJECT="amule-adunanza"
9 S="${WORKDIR}/amule-adunanza"
11 DESCRIPTION="aMule AdunanzA, IL software p2p per la comunita' fastweb"
12 HOMEPAGE="http://www.adunanza.net/"
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~x86"
17 IUSE="daemon debug geoip gtk nls remote stats unicode upnp"
19 DEPEND="=x11-libs/wxGTK-2.8*
20 >=dev-libs/crypto++-5.5.2
21 >=sys-libs/zlib-1.2.1
22 stats? ( >=media-libs/gd-2.0.26 )
23 geoip? ( dev-libs/geoip )
24 upnp? ( >=net-libs/libupnp-1.6.6 )
25 remote? ( >=media-libs/libpng-1.2.0
26 unicode? ( >=media-libs/gd-2.0.26 ) )"
29 pkg_setup() {
30 ewarn ""
31 ewarn "Questo ebuild e' basato su SVN snapshot e sul relativo port"
32 ewarn "sperimentale della patch adunanza. Pertanto e' doppiamente "
33 ewarn "instabile e non vi e' garanzia di corretto funzionamento "
34 ewarn ""
36 if ! use gtk && ! use remote && ! use daemon; then
37 eerror ""
38 eerror "You have to specify at least one of gtk, remote or daemon"
39 eerror "USE flag to build amule."
40 eerror ""
41 die "Invalid USE flag set"
44 if use stats && ! use gtk; then
45 einfo "Note: You would need both the gtk and stats USE flags"
46 einfo "to compile aMule Statistics GUI."
47 einfo "I will now compile console versions only."
52 src_unpack() {
53 subversion_src_unpack
54 AT_M4DIR="m4" eautoreconf
55 elibtoolize
58 pkg_preinst() {
59 if use amuled || use remote; then
60 enewgroup p2p
61 enewuser p2p -1 -1 /home/p2p p2p
65 src_compile() {
66 local myconf
67 WX_GTK_VER="2.8"
69 if use gtk; then
70 einfo "wxGTK with gtk support will be used"
71 need-wxwidgets unicode
72 else
73 einfo "wxGTK without X support will be used"
74 need-wxwidgets base
77 if use gtk ; then
78 use stats && myconf="${myconf}
79 --enable-wxcas
80 --enable-alc"
81 use remote && myconf="${myconf}
82 --enable-amule-gui"
83 else
84 myconf="
85 --disable-monolithic
86 --disable-amule-gui
87 --disable-wxcas
88 --disable-alc"
91 econf \
92 --with-wx-config=${WX_CONFIG} \
93 --with-wxbase-config=${WX_CONFIG} \
94 --enable-amulecmd \
95 $(use_enable debug) \
96 $(use_enable !debug optimize) \
97 $(use_enable amuled amule-daemon) \
98 $(use_enable geoip) \
99 $(use_enable nls) \
100 $(use_enable remote webserver) \
101 $(use_enable stats cas) \
102 $(use_enable stats alcc) \
103 ${myconf} || die
106 emake -j1 || die
110 src_install() {
111 make DESTDIR=${D} install || die
113 if use amuled; then
114 newconfd ${FILESDIR}/amuled.confd amuled
115 newinitd ${FILESDIR}/amuled.initd amuled
118 if use remote; then
119 newconfd ${FILESDIR}/amuleweb.confd amuleweb
120 newinitd ${FILESDIR}/amuleweb.initd amuleweb
124 pkg_postinst() {
125 ewarn "Per maggiori informazioni sullo sviluppo di aMule AdunanzA"
126 ewarn "e per richieste di supporto potete consultare il forum della"
127 ewarn "comunita': http://forum.adunanza.net/forumdisplay.php?f=25"