updated libiphone-9999.ebuild
[dottout.git] / net-wireless / blueman / blueman-9999.ebuild
blob7d28763bac70fdf6fd96a0d66a00c7d9227dad9c
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header$
5 inherit subversion autotools multilib python
7 ESVN_REPO_URI="https://fsckyou.info/svn/blueman/trunk"
9 DESCRIPTION="GTK+ Bluetooth Manager, designed to be simple and intuitive for everyday bluetooth tasks."
10 HOMEPAGE="http://blueman-project.org/"
12 LICENSE="GPL-3"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="gnome network nls"
17 CDEPEND="dev-libs/glib:2
18 >=x11-libs/gtk+-2.12:2
19 x11-libs/startup-notification
20 >=dev-lang/python-2.5
21 dev-python/pygobject
22 net-wireless/bluez"
23 DEPEND="${CDEPEND}
24 nls? ( dev-util/intltool sys-devel/gettext )
25 dev-util/pkgconfig
26 >=dev-python/pyrex-0.9.8"
27 RDEPEND="${CDEPEND}
28 >=app-mobilephone/obex-data-server-0.4.4
29 gnome-extra/policykit-gnome
30 x11-misc/notification-daemon
31 sys-apps/dbus
32 dev-python/pygtk
33 dev-python/notify-python
34 dev-python/dbus-python
35 gnome? ( dev-python/gconf-python )
36 network? ( || ( net-dns/dnsmasq =net-misc/dhcp-3* ) )"
38 src_unpack() {
39 subversion_src_unpack
40 ./autogen.sh || die
42 src_prepare() {
43 # disable pyc compiling
44 rm py-compile
45 ln -s $(type -P true) py-compile
48 src_configure() {
49 econf \
50 --with-no-runtime-deps-check \
51 $(use_enable nls)
54 src_install() {
55 emake DESTDIR="${D}" install || die "emake install failed"
56 dodoc AUTHORS ChangeLog NEWS README
58 if ! use gnome ; then
59 python_version
60 rm "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/blueman/plugins/config/Gconf.py"
63 python_need_rebuild
66 pkg_postinst() {
67 python_version
68 python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/blueman
71 pkg_postrm() {
72 python_mod_cleanup