updated usbmuxd
[dottout.git] / net-im / emesene2 / emesene2-9999.ebuild
blob07e5c80c8ae8e5581daa1fe8d0ab00f55987cd62
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
4 ESVN_REPO_URI="https://emesene.svn.sourceforge.net/svnroot/emesene/trunk/mesinyer"
5 ESVN_PROJECT="emesene2"
6 inherit subversion eutils
8 DESCRIPTION="Platform independent MSN Messenger client written in Python+GTK"
9 HOMEPAGE="http://www.emesene.org"
11 SLOT="0"
12 LICENSE="GPL-2"
13 KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
16 DEPEND="
17 >=dev-lang/python-2.4.3
18 >=x11-libs/gtk+-2.8.20
19 >=dev-python/pygtk-2.8.6
22 RDEPEND="${DEPEND}"
25 pkg_setup() {
27 ewarn "This is a LIVE SVN ebuild."
28 ewarn "That means there are NO promises it will work."
32 src_install() {
34 cd ${S}
35 dodir /usr/share/emesene2
36 insinto /usr/share/emesene2
37 doins -r ./*
38 dodir /usr/bin
39 exeinto /usr/bin
40 echo -e '#!/bin/sh \n cd /usr/share/emesene2/ \n python emesene.py'>> emesene2-start
41 doexe emesene2-start
43 newicon ${S}/themes/default/logo.png ${PN}.png
44 make_desktop_entry emesene2-start "EmeSeNe 2 (mesinyer)" ${PN}.png
48 pkg_postinst() {
49 ewarn "Remember, this stuff is SVN only code so dont cry when"
50 ewarn "I break you :)."
51 ewarn "If you want to report bugs, go to our forum at http://emesene.org/forums"