updated gtkpod ebuild
[dottout.git] / app-pda / gtkpod / gtkpod-9999.ebuild
blobb9f008670cc13e74405ba9edc833f50f3a76bb9b
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit git eutils
7 EGIT_REPO_URI="git://gtkpod.git.sourceforge.net/gitroot/gtkpod/gtkpod"
8 EGIT_BOOTSTRAP="./autogen.sh"
10 DESCRIPTION="GUI for iPod using GTK2"
11 HOMEPAGE="http://gtkpod.sourceforge.net"
13 SLOT="0"
14 LICENSE="GPL-2"
15 KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
16 IUSE="aac flac gnome hal ogg"
18 RDEPEND=">=x11-libs/gtk+-2.8
19 >=media-libs/libid3tag-0.15
20 >=gnome-base/libglade-2.4
21 >=gnome-base/libgnomecanvas-2.14
22 >=media-libs/libgpod-0.7
23 >=net-misc/curl-7.10
24 >=dev-libs/glib-2.16.0
25 mp3? ( media-sound/lame )
26 aac? ( media-libs/libmp4v2 )
27 ogg? ( media-libs/libvorbis
28 media-sound/vorbis-tools )
29 flac? ( media-libs/flac )"
30 DEPEND="${RDEPEND}
31 dev-util/pkgconfig
32 sys-devel/flex
33 dev-util/anjuta
34 nls? ( dev-util/intltool
35 sys-devel/gettext )"
37 pkg_setup() {
38 ewarn "This is a LIVE SVN ebuild."
39 ewarn "That means there are NO promises it will work."
42 src_compile() {
43 econf \
44 $(use_with ogg) \
45 $(use_with flac) \
46 $(use_enable nls)
49 src_install() {
50 emake DESTDIR="${D}" install || die
51 dodoc AUTHORS ChangeLog NEWS README TROUBLESHOOTING *.txt