added missing horizontal jumper icon
[dia.git] / dia.spec
blob573eaea2a4ac9fdd638c907f8533146d488f98a5
1 %define name dia
2 %define ver 0.91
4 Summary: A gtk+ based diagram creation program.
5 Name: %name
6 Version: %ver
7 Release: pre4
8 Copyright: GPL
9 Group: Applications/
10 Source: ftp://ftp.gnome.org/pub/GNOME/stable/sources/dia/%{name}-%{ver}.tar.gz
11 URL: http://www.lysator.liu.se/~alla/dia/dia.html
12 BuildRoot: /var/tmp/%{name}-%{ver}-root
14 Requires: libxml >= 2.3.9 gtk2 pango >= 1.1.5 freetype >= 2.0.9
15 BuildRequires: libxml2-devel >= 2.3.9 gtk2-devel pango-devel >= 1.1.5
16 BuildRequires: freetype-devel >= 2.0.9 intltool > 0.21
18 %description
19 Dia is a GNU program designed to be much like the Windows
20 program 'Visio'. It can be used to draw different kind of diagrams.
22 It can be used to draw a variety of diagram types, including UML, Network,
23 flowchart and others. The native file format for Dia is XML (optionally
24 gzip compressed). It has print support, and can export to a number of formats such as EPS, SVG, CGM and PNG.
26 %changelog
27 * Thu Feb 4 2003 Lars Clausen <lrclause@cs.uiuc.edu>
28 - update requirements.
29 - update prerelease number, move to release field.
30 * Thu Jan 30 2003 Lars Clausen <lrclause@cs.uiuc.edu>
31 - update version number.
32 * Sat Jun 1 2002 Cyrille Chepelov <cyrille@chepelov.org>
33 - update version number.
34 * Fri May 11 2001 James Henstridge <james@daa.com.au>
35 - update version number.
36 - Use make install rather than install-strip as it is causing some problems.
37 * Sun Aug 6 2000 James Henstridge <james@daa.com.au>
38 - update description as it was out of date, and increment version number.
39 * Sun Sep 5 1999 James Henstridge <james@daa.com.au>
40 - added $(prefix)/share/dia to files list.
41 * Thu Apr 29 1999 Enrico Scholz <enrico.scholz@wirtschaft.tu-chemnitz.de>
42 - Made %setup quiet
43 - Enabled build from cvs
44 - Removed superfluous mkdirs
45 - using DESTDIR and install-strip
46 * Fri Aug 28 1998 Francis J. Lacoste <francis@Contre.COM>
47 - First RPM release.
49 %prep
50 %setup -q
52 %build
54 # this is to make sure all translations are included in the build
55 unset LINGUAS || :
57 if [ -x ./configure ]; then
58 CFLAGS=$RPM_OPT_FLAGS ./configure --prefix=%{_prefix} --enable-gnome
59 else
60 CFLAGS=$RPM_OPT_FLAGS ./autogen.sh --prefix=%{_prefix} --enable-gnome
61 fi
62 make
64 %install
65 rm -fr $RPM_BUILD_ROOT
66 make prefix=$RPM_BUILD_ROOT%{_prefix} install
68 gzip --best $RPM_BUILD_ROOT%{_prefix}/man/man1/dia.1
70 %clean
71 rm -fr $RPM_BUILD_ROOT
73 %files
74 %defattr(-,root,root)
75 %doc README TODO NEWS INSTALL COPYING ChangeLog AUTHORS doc
76 %{_prefix}/bin/dia
77 %{_prefix}/lib/dia
78 %{_prefix}/man/man1/dia.1.gz
79 %{_prefix}/share/dia
80 %{_prefix}/share/gnome/apps/Applications/dia.desktop
81 %{_prefix}/share/locale/*/*/*
82 %{_prefix}/share/mime-info/*
83 %{_prefix}/share/pixmaps/*
84 %doc %{_prefix}/share/gnome/help/dia
85 # if you are building without gnome support, use /usr/share/dia/help instead