0.95-pre1 updates
[dia.git] / dia.spec
blobf04b4e1959502bc66ae2367d40242f99f85d9c05
1 %define name dia
2 # This is the full Dia version
3 %define ver 0.95
5 Summary: A gtk+ based diagram creation program.
6 Name: %name
7 Version: %ver
8 # This indicates changes to the spec file after last time %ver has changed.
9 Release: 1
10 Copyright: GPL
11 Group: Applications/
12 Source: ftp://ftp.gnome.org/pub/GNOME/stable/sources/dia/%{name}-%{ver}.tar.gz
13 URL: http://www.gnome.org/projects/dia/
14 BuildRoot: /var/tmp/%{name}-%{ver}-root
16 Requires: libxml2 >= 2.3.9 gtk2 pango >= 1.1.5 freetype2 >= 2.0.9
17 Requires: libgnome libgnomeui popt
18 Requires: python python-gtk
19 BuildRequires: libxml2-devel >= 2.3.9 gtk2-devel pango-devel >= 1.1.5
20 BuildRequires: freetype2-devel >= 2.0.9 intltool > 0.21
21 BuildRequires: libgnome-devel libgnomeui-devel popt-devel
22 BuildRequires: python python-gtk
24 %description
25 Dia is a GNU program designed to be much like the Windows
26 program 'Visio'. It can be used to draw different kind of diagrams.
28 It can be used to draw a variety of diagram types, including UML, Network,
29 flowchart and others. The native file format for Dia is XML (optionally
30 gzip compressed). It has print support, and can export to a number of formats such as EPS, SVG, CGM and PNG.
32 %changelog
33 * Mon Mar 29 2004 Lars Clausen <lars@raeder.dk>
34 - change url to www.gnome.org, fix freetype2 stuff, add python and gnome
35 - dependencies
36 * Thu Feb 4 2003 Lars Clausen <lrclause@cs.uiuc.edu>
37 - update requirements.
38 - update prerelease number, move to release field.
39 * Thu Jan 30 2003 Lars Clausen <lrclause@cs.uiuc.edu>
40 - update version number.
41 * Sat Jun 1 2002 Cyrille Chepelov <cyrille@chepelov.org>
42 - update version number.
43 * Fri May 11 2001 James Henstridge <james@daa.com.au>
44 - update version number.
45 - Use make install rather than install-strip as it is causing some problems.
46 * Sun Aug 6 2000 James Henstridge <james@daa.com.au>
47 - update description as it was out of date, and increment version number.
48 * Sun Sep 5 1999 James Henstridge <james@daa.com.au>
49 - added $(prefix)/share/dia to files list.
50 * Thu Apr 29 1999 Enrico Scholz <enrico.scholz@wirtschaft.tu-chemnitz.de>
51 - Made %setup quiet
52 - Enabled build from cvs
53 - Removed superfluous mkdirs
54 - using DESTDIR and install-strip
55 * Fri Aug 28 1998 Francis J. Lacoste <francis@Contre.COM>
56 - First RPM release.
58 %prep
59 %setup -q -n %name-%ver-%release
61 %build
63 # this is to make sure all translations are included in the build
64 unset LINGUAS || :
66 if [ -x ./configure ]; then
67 CFLAGS=$RPM_OPT_FLAGS ./configure --prefix=%{_prefix} --enable-gnome --with-python
68 else
69 CFLAGS=$RPM_OPT_FLAGS ./autogen.sh --prefix=%{_prefix} --enable-gnome --with-python
70 fi
71 make
73 %install
74 rm -fr $RPM_BUILD_ROOT
75 make prefix=$RPM_BUILD_ROOT%{_prefix} install
77 rm -rf $RPM_BUILD_ROOT/%{_prefix}/var
79 gzip --best $RPM_BUILD_ROOT%{_prefix}/man/man1/dia.1
81 %clean
82 rm -fr $RPM_BUILD_ROOT
84 %files
85 %defattr(-,root,root)
86 %doc README TODO NEWS INSTALL COPYING ChangeLog AUTHORS doc
87 %{_prefix}/bin/dia
88 %{_prefix}/lib/dia
89 %{_prefix}/man/man1/dia.1.gz
90 %{_prefix}/share/dia
91 %{_prefix}/share/applications/dia.desktop
92 %{_prefix}/share/locale/*/*/*
93 %{_prefix}/share/mime-info/*
94 %{_prefix}/share/pixmaps/*
95 %doc %{_prefix}/share/gnome/help/dia
96 # if you are building without gnome support, use /usr/share/dia/help instead