fixed dia_image_rgb_data() for non-alpha images
[dia.git] / dia.spec
blob83495a603f3550372bf309bd7d0e91dd252be47c
1 %define name dia
2 %define ver 0.90
4 Summary: A gtk+ based diagram creation program.
5 Name: %name
6 Version: %ver
7 Release: 1
8 Copyright: GPL
9 Group: Applications/
10 Source: ftp://ftp.gnome.org/pub/GNOME/stable/sources/dia/%{name}-%{ver}.tar.gz
11 URL: http://www.lysator.liu.se/~alla/dia/dia.html
12 BuildRoot: /var/tmp/%{name}-%{ver}-root
14 Requires: libxml >= 1.8.5
16 %description
17 Dia is a GNU program designed to be much like the Windows
18 program 'Visio'. It can be used to draw different kind of diagrams.
20 It can be used to draw a variety of diagram types, including UML, Network,
21 flowchart and others. The native file format for Dia is XML (optionally
22 gzip compressed). It has print support, and can export to a number of formats such as EPS, SVG, CGM and PNG.
24 %changelog
25 * Sat Jun 1 2002 Cyrille Chepelov <cyrille@chepelov.org>
26 - update version number.
27 * Fri May 11 2001 James Henstridge <james@daa.com.au>
28 - update version number.
29 - Use make install rather than install-strip as it is causing some problems.
30 * Sun Aug 6 2000 James Henstridge <james@daa.com.au>
31 - update description as it was out of date, and increment version number.
32 * Sun Sep 5 1999 James Henstridge <james@daa.com.au>
33 - added $(prefix)/share/dia to files list.
34 * Thu Apr 29 1999 Enrico Scholz <enrico.scholz@wirtschaft.tu-chemnitz.de>
35 - Made %setup quiet
36 - Enabled build from cvs
37 - Removed superfluous mkdirs
38 - using DESTDIR and install-strip
39 * Fri Aug 28 1998 Francis J. Lacoste <francis@Contre.COM>
40 - First RPM release.
42 %prep
43 %setup -q
45 %build
47 # this is to make sure all translations are included in the build
48 unset LINGUAS || :
50 if [ -x ./configure ]; then
51 CFLAGS=$RPM_OPT_FLAGS ./configure --prefix=%{_prefix} --enable-gnome
52 else
53 CFLAGS=$RPM_OPT_FLAGS ./autogen.sh --prefix=%{_prefix} --enable-gnome
54 fi
55 make
57 %install
58 rm -fr $RPM_BUILD_ROOT
59 make prefix=$RPM_BUILD_ROOT%{_prefix} install
61 gzip --best $RPM_BUILD_ROOT%{_prefix}/man/man1/dia.1
63 %clean
64 rm -fr $RPM_BUILD_ROOT
66 %files
67 %defattr(-,root,root)
68 %doc README TODO NEWS INSTALL COPYING ChangeLog AUTHORS doc
69 %{_prefix}/bin/dia
70 %{_prefix}/lib/dia
71 %{_prefix}/man/man1/dia.1.gz
72 %{_prefix}/share/dia
73 %{_prefix}/share/gnome/apps/Applications/dia.desktop
74 %{_prefix}/share/locale/*/*/*
75 %{_prefix}/share/mime-info/*
76 %{_prefix}/share/pixmaps/*
77 %doc %{_prefix}/share/gnome/help/dia
78 # if you are building without gnome support, use /usr/share/dia/help instead