re-adding .pngs as binary
[dia.git] / dia.spec
blobded8e02ef9c74a98dc3d1c7d93e4c06d35e84a1e
1 %define name dia
2 %define ver 0.90.RC1
4 Summary: A gtk+ based diagram creation program.
5 Name: %name
6 Version: %ver
7 Release: 1
8 Copyright: GPL
9 Group: Applications/
10 Source: ftp://ftp.gnome.org/pub/GNOME/stable/sources/dia/%{name}-%{ver}.tar.gz
11 URL: http://www.lysator.liu.se/~alla/dia/dia.html
12 BuildRoot: /var/tmp/%{name}-%{ver}-root
14 Requires: libxml >= 1.8.5
16 %description
17 Dia is a GNU program designed to be much like the Windows
18 program 'Visio'. It can be used to draw different kind of diagrams.
20 It can be used to draw a variety of diagram types, including UML, Network,
21 flowchart and others. The native file format for Dia is XML (optionally
22 gzip compressed). It has print support, and can export to a number of formats such as EPS, SVG, CGM and PNG.
24 %changelog
25 * Fri May 11 2001 James Henstridge <james@daa.com.au>
26 - update version number.
27 - Use make install rather than install-strip as it is causing some problems.
28 * Sun Aug 6 2000 James Henstridge <james@daa.com.au>
29 - update description as it was out of date, and increment version number.
30 * Sun Sep 5 1999 James Henstridge <james@daa.com.au>
31 - added $(prefix)/share/dia to files list.
32 * Thu Apr 29 1999 Enrico Scholz <enrico.scholz@wirtschaft.tu-chemnitz.de>
33 - Made %setup quiet
34 - Enabled build from cvs
35 - Removed superfluous mkdirs
36 - using DESTDIR and install-strip
37 * Fri Aug 28 1998 Francis J. Lacoste <francis@Contre.COM>
38 - First RPM release.
40 %prep
41 %setup -q
43 %build
45 # this is to make sure all translations are included in the build
46 unset LINGUAS || :
48 if [ -x ./configure ]; then
49 CFLAGS=$RPM_OPT_FLAGS ./configure --prefix=%{_prefix} --enable-gnome
50 else
51 CFLAGS=$RPM_OPT_FLAGS ./autogen.sh --prefix=%{_prefix} --enable-gnome
52 fi
53 make
55 %install
56 rm -fr $RPM_BUILD_ROOT
57 make prefix=$RPM_BUILD_ROOT%{_prefix} install
59 gzip --best $RPM_BUILD_ROOT%{_prefix}/man/man1/dia.1
61 %clean
62 rm -fr $RPM_BUILD_ROOT
64 %files
65 %defattr(-,root,root)
66 %doc README TODO NEWS INSTALL COPYING ChangeLog AUTHORS doc
67 %{_prefix}/bin/dia
68 %{_prefix}/lib/dia
69 %{_prefix}/man/man1/dia.1.gz
70 %{_prefix}/share/dia
71 %{_prefix}/share/gnome/apps/Applications/dia.desktop
72 %{_prefix}/share/locale/*/*/*
73 %{_prefix}/share/mime-info/*
74 %{_prefix}/share/pixmaps/*
75 %doc %{_prefix}/share/gnome/help/dia
76 # if you are building without gnome support, use /usr/share/dia/help instead