2004-05-17 Hans Breuer <hans@breuer.org>
[dia.git] / dia.spec
blobf4a4c2d528bf4c72f0b33c2e0bef11187ce4b42d
1 %define name dia
2 # This is the full Dia version
3 %define ver 0.93
5 Summary: A gtk+ based diagram creation program.
6 Name: %name
7 Version: %ver
8 # This indicates changes to the spec file after last time %ver has changed.
9 Release: pre2
10 Copyright: GPL
11 Group: Applications/
12 Source: ftp://ftp.gnome.org/pub/GNOME/stable/sources/dia/%{name}-%{ver}.tar.gz
13 URL: http://www.lysator.liu.se/~alla/dia/dia.html
14 BuildRoot: /var/tmp/%{name}-%{ver}-root
16 Requires: libxml2 >= 2.3.9 gtk2 pango >= 1.1.5 freetype2 >= 2.0.9
17 Requires: libgnome libgnomeui popt
18 BuildRequires: libxml2-devel >= 2.3.9 gtk2-devel pango-devel >= 1.1.5
19 BuildRequires: freetype2-devel >= 2.0.9 intltool > 0.21
20 BuildRequires: libgnome-devel libgnomeui-devel
22 %description
23 Dia is a GNU program designed to be much like the Windows
24 program 'Visio'. It can be used to draw different kind of diagrams.
26 It can be used to draw a variety of diagram types, including UML, Network,
27 flowchart and others. The native file format for Dia is XML (optionally
28 gzip compressed). It has print support, and can export to a number of formats such as EPS, SVG, CGM and PNG.
30 %changelog
31 * Sat Mar 27 2004 Lars Clausen <lars@raeder.dk>
32 - Update requirements to add the optional but always compiled in parts.
33 * Thu Feb 4 2003 Lars Clausen <lrclause@cs.uiuc.edu>
34 - update requirements.
35 - update prerelease number, move to release field.
36 * Thu Jan 30 2003 Lars Clausen <lrclause@cs.uiuc.edu>
37 - update version number.
38 * Sat Jun 1 2002 Cyrille Chepelov <cyrille@chepelov.org>
39 - update version number.
40 * Fri May 11 2001 James Henstridge <james@daa.com.au>
41 - update version number.
42 - Use make install rather than install-strip as it is causing some problems.
43 * Sun Aug 6 2000 James Henstridge <james@daa.com.au>
44 - update description as it was out of date, and increment version number.
45 * Sun Sep 5 1999 James Henstridge <james@daa.com.au>
46 - added $(prefix)/share/dia to files list.
47 * Thu Apr 29 1999 Enrico Scholz <enrico.scholz@wirtschaft.tu-chemnitz.de>
48 - Made %setup quiet
49 - Enabled build from cvs
50 - Removed superfluous mkdirs
51 - using DESTDIR and install-strip
52 * Fri Aug 28 1998 Francis J. Lacoste <francis@Contre.COM>
53 - First RPM release.
55 %prep
56 %setup -q -n %name-%ver-%release
58 %build
60 # this is to make sure all translations are included in the build
61 unset LINGUAS || :
63 if [ -x ./configure ]; then
64 CFLAGS=$RPM_OPT_FLAGS ./configure --prefix=%{_prefix} --enable-gnome
65 else
66 CFLAGS=$RPM_OPT_FLAGS ./autogen.sh --prefix=%{_prefix} --enable-gnome
67 fi
68 make
70 %install
71 rm -fr $RPM_BUILD_ROOT
72 make prefix=$RPM_BUILD_ROOT%{_prefix} install
74 rm -rf $RPM_BUILD_ROOT/%{_prefix}/var
76 gzip --best $RPM_BUILD_ROOT%{_prefix}/man/man1/dia.1
78 %clean
79 rm -fr $RPM_BUILD_ROOT
81 %files
82 %defattr(-,root,root)
83 %doc README TODO NEWS INSTALL COPYING ChangeLog AUTHORS doc
84 %{_prefix}/bin/dia
85 %{_prefix}/lib/dia
86 %{_prefix}/man/man1/dia.1.gz
87 %{_prefix}/share/dia
88 %{_prefix}/share/applications/dia.desktop
89 %{_prefix}/share/locale/*/*/*
90 %{_prefix}/share/mime-info/*
91 %{_prefix}/share/pixmaps/*
92 %doc %{_prefix}/share/gnome/help/dia
93 # if you are building without gnome support, use /usr/share/dia/help instead