Update copyright notice and descriptive comments.
[debian_lojban-common.git] / debian / rules
blob41fde6dd24012cf5d89494399fd7b03ce42175c3
1 #! /usr/bin/make -f
3 # debian/rules
4 # Part of Debian ‘lojban-common’ package.
6 # Copyright © 2005–2016 Ben Finney <ben+debian@benfinney.id.au>
7 # This is free software; you may copy, modify, and/or distribute this work
8 # under the terms of the GNU General Public License, version 3 or later.
9 # No warranty expressed or implied.
10 # See the file ‘/usr/share/common-licenses/GPL-3’ for details.
12 # Packaging variables.
13 PACKAGE_NAME = lojban-common
14 SHA1SUMS_FILE = debian/upstream.sha1sums
16 GET_ORIG_SOURCE = $(dir $_)get-orig-source
19 .PHONY: build
20 build: build-arch build-indep
21 dh $@
23 .PHONY: build-arch
24 build-arch:
25 dh $@
27 .PHONY: build-indep
28 build-indep:
29 dh $@
31 .PHONY: get-orig-source
32 get-orig-source:
33 $(GET_ORIG_SOURCE)
35 .PHONY: clean
36 clean:
37 dh $@
39 .PHONY: install
40 install: build
41 cut -d ' ' -f 3 ${SHA1SUMS_FILE} \
42 | sed -e 's_$$_\tusr/share/lojban_' \
43 > debian/${PACKAGE_NAME}.install
44 dh $@
46 .PHONY: binary-indep
47 binary-indep: build install
48 dh $@
50 .PHONY: binary-arch
51 binary-arch:
52 dh $@
54 .PHONY: binary
55 binary: binary-indep binary-arch
58 # Local variables:
59 # coding: utf-8
60 # mode: makefile
61 # End:
62 # vim: fileencoding=utf-8 filetype=make :