ossv4 and dbus-free cups
[dbus-free.git] / dev-python / pyinstaller / pyinstaller-6.2.0.ebuild
blob0cdb0f757932c8e37a33f16d5c9e5d58c9dd9c93
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 DISTUTILS_USE_PEP517=setuptools
7 PYTHON_COMPAT=( python3_{10..12} )
8 PYTHON_REQ_USE='threads(+)'
10 inherit distutils-r1 pypi
12 DESCRIPTION="Program converting Python programs into stand-alone executables"
13 HOMEPAGE="https://www.pyinstaller.org"
15 if [[ ${PV} == 9999 ]]; then
16 inherit git-r3
17 EGIT_REPO_URI="https://github.com/pyinstaller/pyinstaller"
18 EGIT_BRANCH="develop"
19 else
20 # MY_PN="PyInstaller"
21 # MY_P="${MY_PN}-${PV}"
22 # SRC_URI="https://github.com/pyinstaller/pyinstaller/releases/download/v${PV}/${MY_P}.tar.gz"
23 KEYWORDS="amd64 ~arm64 x86"
25 # S="${WORKDIR}/${MY_P}"
28 LICENSE="GPL-2"
29 SLOT="0"
30 IUSE="clang debug doc leak-detector"
31 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
33 RESTRICT="test"
35 QA_PREBUILT="usr/lib/python*/site-packages/PyInstaller/bootloader/Linux-*"
37 RDEPEND="${PYTHON_DEPS}
38 sys-libs/zlib
39 dev-python/altgraph[${PYTHON_USEDEP}]
40 >=dev-python/pefile-2022.5.30[${PYTHON_USEDEP}]
41 >=dev-python/macholib-1.8[${PYTHON_USEDEP}]
42 >=dev-python/pyinstaller-hooks-contrib-2021.4[${PYTHON_USEDEP}]
43 >=dev-python/packaging-22.0[${PYTHON_USEDEP}]
45 DEPEND="${RDEPEND}
46 leak-detector? ( dev-libs/boehm-gc )
47 clang? ( sys-devel/clang )
48 !clang? ( sys-devel/gcc )"
50 src_install() {
51 distutils-r1_src_install
52 insinto /etc/revdep-rebuild
53 doins "${FILESDIR}"/50${PN}