Fix bug introduced with iSchedule support.
[davical.git] / debian / rules
blob1f6d0525a5cd0fbf0d27aa91eb96e5d5e4021e95
1 #!/usr/bin/make -f
3 # rules for DAViCal
5 # This file allows you to build any of the binary packages independantly, via binary-<package> targets.
7 # Uncomment this to turn on verbose mode.
8 #export DH_VERBOSE=1
10 # This has to be exported to make some magic below work.
11 export DH_OPTIONS
13 build: build-stamp
14 build-stamp:
15 dh_testdir
16 $(MAKE)
17 touch build-stamp
19 clean:
20 dh_testdir
21 dh_testroot
22 rm -f build-stamp
24 $(MAKE) clean
25 -rm -f build
27 dh_clean
29 install: DH_OPTIONS=
30 install: build
31 dh_testdir
32 dh_testroot
33 dh_prep
34 dh_installdirs
36 dh_install
38 # This single target is used to build all the packages, all at once, or
39 # one at a time. So keep in mind: any options passed to commands here will
40 # affect _all_ packages. Anything you want to only affect one package
41 # should be put in another target, such as the install target.
42 binary-common:
43 dh_testdir
44 dh_testroot
45 dh_installchangelogs ChangeLog
46 dh_installdocs --exclude=.gitignore
47 # dh_installexamples
48 # dh_installmenu
49 # dh_installdebconf
50 # dh_installlogrotate
51 # dh_installemacsen
52 # dh_installcatalogs
53 # dh_installpam
54 # dh_installmime
55 # dh_installinit
56 # dh_installman
57 # dh_installcron
58 # dh_installinfo
59 # dh_installwm
60 # dh_installudev
61 # dh_lintian
62 # dh_undocumented
63 # dh_strip
64 # dh_link
65 dh_compress --exclude=.js
66 dh_fixperms
67 rm debian/davical/usr/share/davical/htdocs/.htaccess || true
68 # dh_perl
69 # dh_python
70 # dh_makeshlibs
71 dh_installdeb
72 # dh_shlibdeps
73 dh_gencontrol
74 dh_md5sums
75 dh_builddeb
77 # Build architecture independant packages using the common target.
78 binary-indep: build install
79 $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
81 # Build architecture dependant packages using the common target.
82 binary-arch: build install
84 # Any other binary targets build just one binary package at a time.
85 binary-%: build install
86 make -f debian/rules binary-common DH_OPTIONS=-p$*
88 binary: binary-indep binary-arch
90 .PHONY: build clean binary-indep binary-arch binary-common binary install