5 # This file allows you to build any of the binary packages independantly, via binary-<package> targets.
7 # Uncomment this to turn on verbose mode.
10 # This has to be exported to make some magic below work.
38 # This single target is used to build all the packages, all at once, or
39 # one at a time. So keep in mind: any options passed to commands here will
40 # affect _all_ packages. Anything you want to only affect one package
41 # should be put in another target, such as the install target.
45 dh_installchangelogs ChangeLog
46 dh_installdocs
--exclude
=.gitignore
65 dh_compress
--exclude
=.js
67 rm debian
/davical
/usr
/share
/davical
/htdocs
/.htaccess || true
77 # Build architecture independant packages using the common target.
78 binary-indep
: build
install
79 $(MAKE
) -f debian
/rules DH_OPTIONS
=-i binary-common
81 # Build architecture dependant packages using the common target.
82 binary-arch
: build
install
84 # Any other binary targets build just one binary package at a time.
85 binary-
%: build
install
86 make
-f debian
/rules binary-common DH_OPTIONS
=-p
$*
88 binary
: binary-indep binary-arch
90 .PHONY
: build
clean binary-indep binary-arch binary-common binary
install