3 # Uncomment this to turn on verbose mode.
6 # This has to be exported to make some magic below work.
9 # Generating a xulrunner build id and other strings
10 DEBIAN_VERSION
:= $(shell echo
-n
`head -1 debian/changelog | sed -e 's/^.*(\(.*\)).*$$/\\1/'`)
12 BUILDID
:= $(shell echo
-n
`whoami`@
`hostname`)_
$(shell date
+%s
)
14 include /usr
/share
/quilt
/quilt.make
16 configure
: configure-stamp
17 configure-stamp
: $(QUILT_STAMPFN
)
19 # Add here commands to configure the package.
24 build
: build-arch build-indep
26 build-arch
: build-arch-stamp
27 build-arch-stamp
: configure-stamp
28 # Add here commands to compile the arch part of the package.
33 build-indep
: build-indep-stamp
34 build-indep-stamp
: configure-stamp
35 # Add here commands to compile the indep part of the package.
43 rm -f build-arch-stamp build-indep-stamp configure-stamp
45 # Add here commands to clean up after the build process.
50 install: install-indep install-arch
57 # Add here commands to install the indep part of the package into
59 cp
-pr branding chrome components content defaults \
60 locale modules search-engines help style \
62 $(CURDIR
)/debian
/conkeror
/usr
/share
/conkeror
/
63 mkdir
-p
$(CURDIR
)/debian
/conkeror
/usr
/share
/conkeror
/contrib
/
64 cp
-pr contrib
/xrev contrib
/art contrib
/modules \
65 $(CURDIR
)/debian
/conkeror
/usr
/share
/conkeror
/contrib
/
66 # Add generated Build ID and Debian version to version output
67 sed
-e
's/BuildID=git/BuildID=${BUILDID}/;s/^Version=\(.*\)$$/Version=\1 (Debian-${DEBIAN_VERSION})/' application.ini \
68 > $(CURDIR
)/debian
/conkeror
/usr
/share
/conkeror
/application.ini
69 # Use Debian version for M-x version output
70 sed
-e
's/Version=\(.*\)/Version=\1 (Debian-${DEBIAN_VERSION})/' components
/application.js \
71 > $(CURDIR
)/debian
/conkeror
/usr
/share
/conkeror
/components
/application.js
72 cp
-p debian
/conkeror.bin
$(CURDIR
)/debian
/conkeror
/usr
/bin
/conkeror
73 cp
-p debian
/conkeror.desktop
$(CURDIR
)/debian
/conkeror
/usr
/share
/applications
/
83 # Add here commands to install the arch part of the package into
85 cp
-p conkeror-spawn-helper
$(CURDIR
)/debian
/conkeror-spawn-process-helper
/usr
/lib
/conkeror
/
86 ln
-s
/usr
/lib
/conkeror
/conkeror-spawn-helper
$(CURDIR
)/debian
/conkeror-spawn-process-helper
/usr
/share
/conkeror
/
90 # Must not depend on anything. This is to be called by
91 # binary-arch/binary-indep in another 'make' thread.
114 # Build architecture independant packages using the common target.
115 binary-indep
: build-indep install-indep
116 $(MAKE
) -f debian
/rules DH_OPTIONS
=-i binary-common
118 # Build architecture dependant packages using the common target.
119 binary-arch
: build-arch install-arch
120 $(MAKE
) -f debian
/rules DH_OPTIONS
=-s binary-common
122 binary
: binary-arch binary-indep
123 .PHONY
: build
clean binary-indep binary-arch binary
install install-indep install-arch configure