3 # Uncomment this to turn on verbose mode.
6 # This has to be exported to make some magic below work.
9 # Generating a xulrunner build id and other strings
10 DEBIAN_VERSION
:= $(shell echo
-n
`head -1 debian/changelog | sed -e 's/^.*(\(.*\)).*$$/\\1/'`)
12 BUILDID
:= $(shell echo
-n
`whoami`@
`hostname`)_
$(shell date
+%s
)
14 include /usr
/share
/quilt
/quilt.make
16 configure
: configure-stamp
17 configure-stamp
: $(QUILT_STAMPFN
)
19 # Add here commands to configure the package.
24 build
: build-arch build-indep
26 build-arch
: build-arch-stamp
27 build-arch-stamp
: configure-stamp
28 # Add here commands to compile the arch part of the package.
33 build-indep
: build-indep-stamp
34 build-indep-stamp
: configure-stamp
35 # Add here commands to compile the indep part of the package.
43 rm -f build-arch-stamp build-indep-stamp configure-stamp
45 # Add here commands to clean up after the build process.
50 install: install-indep install-arch
57 # Add here commands to install the indep part of the package into
59 cp
-pr branding chrome components content defaults \
60 locale modules search-engines help style \
61 $(CURDIR
)/debian
/conkeror
/usr
/share
/conkeror
/
62 mkdir
-p
$(CURDIR
)/debian
/conkeror
/usr
/share
/conkeror
/contrib
/
64 $(CURDIR
)/debian
/conkeror
/usr
/share
/conkeror
/contrib
/
65 # Add generated Build ID and Debian version to version output
66 sed
-e
's/BuildID=git/BuildID=${BUILDID}/;s/^Version=\(.*\)$$/Version=\1 (Debian-${DEBIAN_VERSION})/' application.ini \
67 > $(CURDIR
)/debian
/conkeror
/usr
/share
/conkeror
/application.ini
68 # Use Debian version for M-x version output
69 sed
-e
's/Version=\(.*\)/Version=\1 (Debian-${DEBIAN_VERSION})/' components
/application.js \
70 > $(CURDIR
)/debian
/conkeror
/usr
/share
/conkeror
/components
/application.js
71 cp
-p debian
/conkeror.bin
$(CURDIR
)/debian
/conkeror
/usr
/bin
/conkeror
72 cp
-p debian
/conkeror.desktop
$(CURDIR
)/debian
/conkeror
/usr
/share
/applications
/
82 # Add here commands to install the arch part of the package into
84 cp
-p conkeror-spawn-helper
$(CURDIR
)/debian
/conkeror-spawn-process-helper
/usr
/lib
/conkeror
/
85 ln
-s
/usr
/lib
/conkeror
/conkeror-spawn-helper
$(CURDIR
)/debian
/conkeror-spawn-process-helper
/usr
/share
/conkeror
/
89 # Must not depend on anything. This is to be called by
90 # binary-arch/binary-indep in another 'make' thread.
113 # Build architecture independant packages using the common target.
114 binary-indep
: build-indep install-indep
115 $(MAKE
) -f debian
/rules DH_OPTIONS
=-i binary-common
117 # Build architecture dependant packages using the common target.
118 binary-arch
: build-arch install-arch
119 $(MAKE
) -f debian
/rules DH_OPTIONS
=-s binary-common
121 binary
: binary-arch binary-indep
122 .PHONY
: build
clean binary-indep binary-arch binary
install install-indep install-arch configure