Fix lintian warning debhelper-but-no-misc-depends
[conkeror/arlinius.git] / debian / patches / deb-webjumps.diff
blobc15212013e3f42a0239299090ae77ae0710dfeb9
1 Adds and enables some Debian and Ubuntu related webjumps which should
2 not be inlcuded in upstream by default.
4 Index: conkeror-0.9.1/modules/debian/webjumps.js
5 ===================================================================
6 --- /dev/null 1970-01-01 00:00:00.000000000 +0000
7 +++ conkeror-0.9.1/modules/debian/webjumps.js 2009-09-24 02:16:50.000000000 +0200
8 @@ -0,0 +1,22 @@
9 +/**
10 + * (C) Copyright 2008-2009 Axel Beckert
11 + *
12 + * Use, modification, and distribution are subject to the terms specified in the
13 + * COPYING file.
14 + *
15 + * Webjumps to interact with Debian and Ubuntu websites
16 +**/
18 +require("webjump.js");
20 +// Debian //
21 +define_webjump("debpkg", "http://packages.debian.org/%s");
22 +define_webjump("debfile", "http://packages.debian.org/?searchon=contents&keywords=%s&mode=path&suite=unstable&arch=any");
23 +define_webjump("debbugs", "http://bugs.debian.org/%s");
24 +define_webjump("debpts", "http://packages.qa.debian.org/%s");
26 +// Ubuntu //
27 +define_webjump("ubuntupkg", "http://packages.ubuntu.com/%s");
28 +define_webjump("ubuntufile", "http://packages.ubuntu.com/search?searchon=contents&keywords=%s&mode=path&arch=any");
29 +define_webjump("ubuntubugs", "http://launchpad.net/ubuntu/+source/%s");
30 +define_webjump("launchpad", "https://launchpad.net/+search?field.text=%s");
31 Index: conkeror-0.9.1/defaults/preferences/default-modules.js
32 ===================================================================
33 --- conkeror-0.9.1.orig/defaults/preferences/default-modules.js 2009-09-24 02:17:21.000000000 +0200
34 +++ conkeror-0.9.1/defaults/preferences/default-modules.js 2009-09-24 02:17:48.000000000 +0200
35 @@ -61,3 +61,6 @@
36 pref("conkeror.load.page-modes/dailymotion", 1);
37 pref("conkeror.load.page-modes/gmail", 0);
38 pref("conkeror.load.page-modes/xkcd", 1);
40 +// Debian modules
41 +pref("conkeror.load.debian/webjumps", 1);