Debian package: Don't pass locale settings to seq in /usr/bin/conkeror
[conkeror.git] / debian / rules
blob93d05a29bdd8fd326347e9149859b096448c606f
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Uncomment this to turn on verbose mode.
4 #export DH_VERBOSE=1
6 # This has to be exported to make some magic below work.
7 export DH_OPTIONS
9 # Generating a xulrunner build id and other strings
10 DEBIAN_VERSION := $(shell echo -n `head -1 debian/changelog | sed -e 's/^.*(\(.*\)).*$$/\\1/'`)
12 BUILDID := $(shell echo -n `whoami`@`hostname`)_$(shell date +%s)
14 DPKG_EXPORT_BUILDFLAGS = 1
15 include /usr/share/dpkg/buildflags.mk
16 include /usr/share/quilt/quilt.make
18 configure: configure-stamp
19 configure-stamp: $(QUILT_STAMPFN)
20 dh_testdir
21 # Add here commands to configure the package.
23 touch configure-stamp
25 # Architecture
26 build: build-arch build-indep
28 build-arch: build-arch-stamp
29 build-arch-stamp: configure-stamp
30 # Add here commands to compile the arch part of the package.
31 $(MAKE)
33 touch $@
35 build-indep: build-indep-stamp
36 build-indep-stamp: configure-stamp
37 # Add here commands to compile the indep part of the package.
38 #$(MAKE) doc
40 touch $@
42 clean: unpatch
43 dh_testdir
44 dh_testroot
45 rm -f build-arch-stamp build-indep-stamp configure-stamp
47 # Add here commands to clean up after the build process.
48 $(MAKE) clean
50 dh_clean
52 install: install-indep install-arch
53 install-indep:
54 dh_testdir
55 dh_testroot
56 dh_prep -i
57 dh_installdirs -i
59 # Add here commands to install the indep part of the package into
60 # debian/<package>
61 cp -pr branding chrome components content defaults \
62 locale modules search-engines help style \
63 *.manifest \
64 $(CURDIR)/debian/conkeror/usr/share/conkeror/
65 mkdir -p $(CURDIR)/debian/conkeror/usr/share/conkeror/contrib/
66 cp -pr contrib/xrev contrib/art contrib/modules \
67 $(CURDIR)/debian/conkeror/usr/share/conkeror/contrib/
68 # Add generated Build ID and Debian version to version output
69 sed -e 's/BuildID=git/BuildID=${BUILDID}/;s/^Version=\(.*\)$$/Version=\1 (Debian-${DEBIAN_VERSION})/' application.ini \
70 > $(CURDIR)/debian/conkeror/usr/share/conkeror/application.ini
71 # Use Debian version for M-x version output
72 sed -e 's/Version=\(.*\)/Version=\1 (Debian-${DEBIAN_VERSION})/' components/application.js \
73 > $(CURDIR)/debian/conkeror/usr/share/conkeror/components/application.js
74 cp -p debian/conkeror.bin $(CURDIR)/debian/conkeror/usr/bin/conkeror
75 cp -p debian/conkeror.desktop $(CURDIR)/debian/conkeror/usr/share/applications/
77 dh_install -i
79 install-arch:
80 dh_testdir
81 dh_testroot
82 dh_prep -s
83 dh_installdirs -s
85 # Add here commands to install the arch part of the package into
86 # debian/tmp.
87 cp -p conkeror-spawn-helper $(CURDIR)/debian/conkeror-spawn-process-helper/usr/lib/conkeror/
88 ln -s /usr/lib/conkeror/conkeror-spawn-helper $(CURDIR)/debian/conkeror-spawn-process-helper/usr/share/conkeror/
90 dh_install -s
92 # Must not depend on anything. This is to be called by
93 # binary-arch/binary-indep in another 'make' thread.
94 binary-common:
95 dh_testdir
96 dh_testroot
97 dh_installchangelogs
98 dh_installdocs
99 # dh_installexamples
100 dh_installmenu
101 # dh_installemacsen
102 dh_installman
103 dh_bugfiles
104 dh_lintian
105 dh_link
106 dh_strip
107 dh_compress
108 dh_fixperms
109 dh_makeshlibs
110 dh_installdeb
111 dh_shlibdeps
112 dh_gencontrol
113 dh_md5sums
114 dh_builddeb
116 # Build architecture independant packages using the common target.
117 binary-indep: build-indep install-indep
118 $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
120 # Build architecture dependant packages using the common target.
121 binary-arch: build-arch install-arch
122 $(MAKE) -f debian/rules DH_OPTIONS=-s binary-common
124 binary: binary-arch binary-indep
125 .PHONY: build clean binary-indep binary-arch binary install install-indep install-arch configure