Make Debian package working on Ubuntu again.
[conkeror.git] / debian / rules
blobeef8752647af0a71aa8f23144d448a829f09eb6e
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Uncomment this to turn on verbose mode.
4 #export DH_VERBOSE=1
6 # This has to be exported to make some magic below work.
7 export DH_OPTIONS
9 # Generating a xulrunner build id and other strings
10 DEBIAN_VERSION := $(shell echo -n `head -1 debian/changelog | sed -e 's/^.*(\(.*\)).*$$/\\1/'`)
12 BUILDID := $(shell echo -n `whoami`@`hostname`)_$(shell date +%s)
14 include /usr/share/quilt/quilt.make
16 configure: configure-stamp
17 configure-stamp: $(QUILT_STAMPFN)
18 dh_testdir
19 # Add here commands to configure the package.
21 touch configure-stamp
23 # Architecture
24 build: build-arch build-indep
26 build-arch: build-arch-stamp
27 build-arch-stamp: configure-stamp
28 # Add here commands to compile the arch part of the package.
29 make
31 touch $@
33 build-indep: build-indep-stamp
34 build-indep-stamp: configure-stamp
35 # Add here commands to compile the indep part of the package.
36 #$(MAKE) doc
38 touch $@
40 clean: unpatch
41 dh_testdir
42 dh_testroot
43 rm -f build-arch-stamp build-indep-stamp configure-stamp
45 # Add here commands to clean up after the build process.
46 $(MAKE) clean
48 dh_clean
50 install: install-indep install-arch
51 install-indep:
52 dh_testdir
53 dh_testroot
54 dh_prep -i
55 dh_installdirs -i
57 # Add here commands to install the indep part of the package into
58 # debian/<package>
59 cp -pr branding chrome components content defaults \
60 locale modules search-engines help style \
61 $(CURDIR)/debian/conkeror/usr/share/conkeror/
62 mkdir -p $(CURDIR)/debian/conkeror/usr/share/conkeror/contrib/
63 cp -pr contrib/xrev \
64 $(CURDIR)/debian/conkeror/usr/share/conkeror/contrib/
65 # Add generated Build ID and Debian version to version output
66 sed -e 's/BuildID=git/BuildID=${BUILDID}/;s/^Version=\(.*\)$$/Version=\1 (Debian-${DEBIAN_VERSION})/' application.ini \
67 > $(CURDIR)/debian/conkeror/usr/share/conkeror/application.ini
68 # Use Debian version for M-x version output
69 sed -e 's/Version=\(.*\)/Version=\1 (Debian-${DEBIAN_VERSION})/' components/application.js \
70 > $(CURDIR)/debian/conkeror/usr/share/conkeror/components/application.js
71 cp -p debian/conkeror.bin $(CURDIR)/debian/conkeror/usr/bin/conkeror
72 cp -p debian/conkeror.desktop $(CURDIR)/debian/conkeror/usr/share/applications/
74 dh_install -i
76 install-arch:
77 dh_testdir
78 dh_testroot
79 dh_prep -s
80 dh_installdirs -s
82 # Add here commands to install the arch part of the package into
83 # debian/tmp.
84 cp -p conkeror-spawn-helper $(CURDIR)/debian/conkeror-spawn-process-helper/usr/lib/conkeror/
85 ln -s /usr/lib/conkeror/conkeror-spawn-helper $(CURDIR)/debian/conkeror-spawn-process-helper/usr/share/conkeror/
87 dh_install -s
89 # Must not depend on anything. This is to be called by
90 # binary-arch/binary-indep in another 'make' thread.
91 binary-common:
92 dh_testdir
93 dh_testroot
94 dh_installchangelogs
95 dh_installdocs
96 # dh_installexamples
97 dh_installmenu
98 # dh_installemacsen
99 dh_installman
100 dh_link
101 dh_strip
102 dh_compress
103 dh_fixperms
104 dh_makeshlibs
105 dh_installdeb
106 dh_shlibdeps
107 dh_gencontrol
108 dh_md5sums
109 dh_builddeb
111 # Build architecture independant packages using the common target.
112 binary-indep: build-indep install-indep
113 $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
115 # Build architecture dependant packages using the common target.
116 binary-arch: build-arch install-arch
117 $(MAKE) -f debian/rules DH_OPTIONS=-s binary-common
119 binary: binary-arch binary-indep
120 .PHONY: build clean binary-indep binary-arch binary install install-indep install-arch configure