Fix saveURI: aReferrerPolicy argument added
[conkeror.git] / debian / rules
blob92f1b2f3981e19f4d9981dbf222457cc11bea6f6
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Uncomment this to turn on verbose mode.
4 #export DH_VERBOSE=1
6 # Generating a xulrunner build id and other strings
7 DEBIAN_VERSION := $(shell echo -n `head -1 debian/changelog | sed -e 's/^.*(\(.*\)).*$$/\\1/'`)
8 DATE := $(shell dpkg-parsechangelog | awk -F ': ' '$$1=="Date" {print $$2}')
9 BUILDID := debian@$(DEBIAN_VERSION)_$(shell date -d "$(DATE)" +%s)
10 US = $(CURDIR)/debian/tmp/usr/share
11 USC = $(US)/conkeror
14 dh $@
16 override_dh_auto_install:
17 dh_auto_install -- PREFIX=/usr
18 rm -f $(US)/doc/conkeror/COPYING $(USC)/Info.plist
20 # Add generated Build ID and Debian version to version output
21 sed -e 's/BuildID=git/BuildID=${BUILDID}/;s/^Version=\(.*\)$$/Version=\1 (Debian-${DEBIAN_VERSION})/' \
22 -i $(USC)/application.ini