Debian package: Mention changed CFLAGS handling in debian/changelog
[conkeror.git] / debian / patches / deb-webjumps.diff
blob6b59ff336c81056deaf2c806289fa72f7c1d3ae3
1 Adds and enables some Debian and Ubuntu related webjumps which should
2 not be inlcuded in upstream by default.
4 Index: conkeror/modules/debian/debian-webjumps.js
5 ===================================================================
6 --- /dev/null 1970-01-01 00:00:00.000000000 +0000
7 +++ conkeror/modules/debian/debian-webjumps.js 2010-09-29 07:55:36.000000000 +0200
8 @@ -0,0 +1,29 @@
9 +/**
10 + * (C) Copyright 2008-2010 Axel Beckert
11 + *
12 + * Use, modification, and distribution are subject to the terms specified in the
13 + * COPYING file.
14 + *
15 + * Webjumps to interact with Debian and Ubuntu websites
16 +**/
18 +require("webjump.js");
20 +// Debian //
21 +define_webjump("debpkg", "http://packages.debian.org/%s");
22 +define_webjump("debfile", "http://packages.debian.org/?searchon=contents&keywords=%s&mode=path&suite=unstable&arch=any");
23 +define_webjump("debbugs", "http://bugs.debian.org/%s");
24 +define_webjump("debpts", "http://packages.qa.debian.org/%s");
25 +define_webjump("debpopcon", "http://qa.debian.org/popcon.php?package=%s");
26 +define_webjump("buildd", "https://buildd.debian.org/%s");
27 +define_webjump("buildd-ports", "http://buildd.debian-ports.org/%s");
28 +define_webjump("debqa", "http://qa.debian.org/developer.php?login=%s");
29 +define_webjump("debpopcon", "http://qa.debian.org/popcon.php?package=%s");
31 +// Ubuntu //
32 +define_webjump("ubuntupkg", "http://packages.ubuntu.com/%s");
33 +define_webjump("ubuntufile", "http://packages.ubuntu.com/search?searchon=contents&keywords=%s&mode=path&arch=any");
34 +define_webjump("ubuntubugs", "http://bugs.launchpad.net/ubuntu/+source/%s");
35 +define_webjump("launchpad", "https://launchpad.net/+search?field.text=%s");
37 +provide("debian-webjumps");
38 Index: conkeror/defaults/preferences/debian-default-modules.js
39 ===================================================================
40 --- conkeror.orig/defaults/preferences/debian-default-modules.js 2010-09-28 01:47:21.000000000 +0200
41 +++ conkeror/defaults/preferences/debian-default-modules.js 2010-09-29 07:57:40.000000000 +0200
42 @@ -0,0 +1,1 @@
43 +pref("conkeror.load.debian/debian-webjumps", 1);