Bump Gecko MaxVersion to 5.*
[conkeror.git] / debian / patches / deb-webjumps.diff
blob332e7d6e48d7d96976465db4bcbec9636acb1fd8
1 Adds and enables some Debian and Ubuntu related webjumps which should
2 not be inlcuded in upstream by default.
4 Index: conkeror/modules/debian/debian-webjumps.js
5 ===================================================================
6 --- /dev/null 1970-01-01 00:00:00.000000000 +0000
7 +++ conkeror/modules/debian/debian-webjumps.js 2010-09-29 07:55:36.000000000 +0200
8 @@ -0,0 +1,30 @@
9 +/**
10 + * (C) Copyright 2008-2010 Axel Beckert
11 + *
12 + * Use, modification, and distribution are subject to the terms specified in the
13 + * COPYING file.
14 + *
15 + * Webjumps to interact with Debian and Ubuntu websites
16 +**/
18 +in_module(null);
20 +require("webjump.js");
22 +// Debian //
23 +define_webjump("debpkg", "http://packages.debian.org/%s");
24 +define_webjump("debfile", "http://packages.debian.org/?searchon=contents&keywords=%s&mode=path&suite=unstable&arch=any");
25 +define_webjump("debbugs", "http://bugs.debian.org/%s");
26 +define_webjump("debpts", "http://packages.qa.debian.org/%s");
27 +define_webjump("debpopcon", "http://qa.debian.org/popcon.php?package=%s");
28 +define_webjump("buildd", "https://buildd.debian.org/%s");
29 +define_webjump("buildd-ports", "http://buildd.debian-ports.org/build.php?pkg=%s");
30 +define_webjump("debqa", "http://qa.debian.org/developer.php?login=%s");
32 +// Ubuntu //
33 +define_webjump("ubuntupkg", "http://packages.ubuntu.com/%s");
34 +define_webjump("ubuntufile", "http://packages.ubuntu.com/search?searchon=contents&keywords=%s&mode=path&arch=any");
35 +define_webjump("ubuntubugs", "http://bugs.launchpad.net/ubuntu/+source/%s");
36 +define_webjump("launchpad", "https://launchpad.net/+search?field.text=%s");
38 +provide("debian-webjumps");
39 Index: conkeror/defaults/preferences/debian-default-modules.js
40 ===================================================================
41 --- conkeror.orig/defaults/preferences/debian-default-modules.js 2010-09-28 01:47:21.000000000 +0200
42 +++ conkeror/defaults/preferences/debian-default-modules.js 2010-09-29 07:57:40.000000000 +0200
43 @@ -0,0 +1,1 @@
44 +pref("conkeror.load.debian/debian-webjumps", 1);