components, modules: change deprecated replace flag
[conkeror.git] / debian / rules
blobdc2c92798c2056ca046fcb84996d1b81a828945e
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Uncomment this to turn on verbose mode.
4 #export DH_VERBOSE=1
6 # Generating a xulrunner build id and other strings
7 DEBIAN_VERSION := $(shell echo -n `head -1 debian/changelog | sed -e 's/^.*(\(.*\)).*$$/\\1/'`)
8 DATE := $(shell dpkg-parsechangelog | awk -F ': ' '$$1=="Date" {print $$2}')
9 BUILDID := debian@$(DEBIAN_VERSION)_$(shell date -d "$(DATE)" +%s)
10 US = $(CURDIR)/debian/tmp/usr/share
11 USC = $(US)/conkeror
13 export DEB_BUILD_MAINT_OPTIONS=hardening=+all
14 DPKG_EXPORT_BUILDFLAGS = 1
15 include /usr/share/dpkg/buildflags.mk
16 export CFLAGS+=$(LDFLAGS)
19 dh $@
21 override_dh_auto_install:
22 dh_auto_install -- PREFIX=/usr
23 rm -f $(US)/doc/conkeror/COPYING $(USC)/Info.plist
25 # Add generated Build ID and Debian version to version output
26 sed -e 's/BuildID=git/BuildID=${BUILDID}/;s/^Version=\(.*\)$$/Version=\1 (Debian-${DEBIAN_VERSION})/' \
27 -i $(USC)/application.ini