r1009: Move the dependencies to newer package names
[cinelerra_cv/mob.git] / debian / rules
blobb918fd7bfd2c80ec1f2b7cecfb767ea85a44509e
1 #!/usr/bin/make -f
2 # Made with the aid of debmake, by Christoph Lameter,
3 # based on the sample debian/rules file for GNU hello by Ian Jackson.
5 package=hvirtual
6 export DH_COMPAT=4
8 CONFFLAGS=
9 #since we are building from .svn
10 +export DH_ALWAYS_EXCLUDE=.svn
12 ifneq ($(DEB_HOST_ARCH),powerpc)
13 CFLAGS=-ffast-math -O3 -mmmx -march=pentium4 -msse -msse2 -minline-all-stringops -fprefetch-loop-arrays -funroll-loops
14 # CFLAGS=-ffast-math -g -mmmx -march=pentium-mmx
15 CXXFLAGS=$(CFLAGS) -fno-check-new
16 CONFFLAGS+=--enable-mmx --enable-x86 --without-pic
17 endif
19 ifneq (, $(findstring smp2,$(DEB_BUILD_OPTIONS)))
20 MAKEFLAGS=-j2
21 endif
23 config.status: configure
24 $(checkdir)
25 @if [ -z "$(CFLAGS)" ] ; then CFLAGS="$(CFLAGS)" ; fi ;
26 @if [ -z "$(CXXFLAGS)" ] ; then CXXFLAGS="$(CXXFLAGS)" ; fi ;
27 CFLAGS="$(CFLAGS)" CXXFLAGS="$(CXXFLAGS)" \
28 ./configure --prefix=/usr $(CONFFLAGS)
30 build: build-stamp
31 build-stamp: config.status
32 $(checkdir)
33 $(MAKE) $(MAKEFLAGS)
34 docbook-to-man debian/cinelerra.sgml > debian/cinelerra.1
35 docbook-to-man debian/mplexhi.sgml > debian/mplexhi.1
36 docbook-to-man debian/mplexlo.sgml > debian/mplexlo.1
37 touch build-stamp
39 clean:
40 $(checkdir)
41 -$(MAKE) -i distclean
42 dh_clean -a
43 -rm -f debian/cinelerra.1
44 -rm -f debian/mplexhi.1
45 -rm -f debian/mplexlo.1
46 -rm -f build-stamp
48 binary-indep: checkroot build-stamp
49 binary-arch: checkroot build-stamp
50 $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
51 chmod -x debian/tmp/usr/lib/cinelerra/*
52 chmod +x debian/tmp/usr/lib/cinelerra/fonts
53 chmod -x debian/tmp/usr/lib/cinelerra/fonts/*
54 dh_install --sourcedir=debian/tmp --autodest
55 dh_installdocs -XCVS
56 dh_installchangelogs -a
57 dh_installman
58 dh_installmenu
60 dh_fixperms -a
61 dh_compress -a
62 # Since Cinelerra is far from stable, I prefer leaving the debug info
63 dh_strip -a
64 strip -x -s -R .comment -R .note debian/cinelerra/usr/lib/cinelerra/*.so
66 # AFAIK bootstraping should be gone now -- minmax
68 # Rename defaulttheme to blondtheme
69 # guicast/bootstrap debian/cinelerra/usr/lib/cinelerra/blondtheme.so plugins/defaulttheme/data/*.png
70 # Add bluedottheme
71 # guicast/bootstrap debian/cinelerra/usr/lib/cinelerra/bluedottheme.so plugins/bluedottheme/data/*.png
72 # guicast/bootstrap debian/cinelerra/usr/bin/cinelerra cinelerra/data/mode_*.png
73 # not present anymore?
74 # guicast/bootstrap debian/cinelerra/usr/lib/cinelerra/microtheme.so plugins/microtheme/data/*.png
76 dh_makeshlibs -V -a
77 dh_shlibdeps -a
79 dh_gencontrol
80 dh_builddeb
83 binary: binary-indep binary-arch
85 checkroot:
86 dh_testroot