comment patch which is not ready
[cdrkit.git] / cdrkit.spec
blob8235e5bfca22c8432c91a2838e2b444e124c7dce
1 Summary: A collection of CD/DVD utilities
2 Name: cdrkit
3 Version: 1.1.9
4 Release: 10%{?dist}
5 License: GPLv2
6 Group: Applications/System
7 URL: http://cdrkit.org/
8 Source: http://cdrkit.org/releases/cdrkit-%{version}.tar.gz
10 Patch1: cdrkit-1.1.8-werror.patch
11 Patch2: cdrkit-1.1.9-efi-boot.patch
12 Patch3: cdrkit-1.1.9-types.patch
13 Patch4: cdrkit-1.1.9-no_mp3.patch
14 Patch5: cdrkit-1.1.9-buffer_overflow.patch
15 #Patch6: cdrkit-1.1.9-rr_joliet.patch
16 Patch7: cdrkit-1.1.9-root_option.patch
18 BuildRequires: cmake libcap-devel zlib-devel perl file-devel bzip2-devel
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
22 %description
23 cdrkit is a collection of CD/DVD utilities.
25 %package -n wodim
26 Summary: A command line CD/DVD recording program
27 Group: Applications/Archiving
28 Obsoletes: dvdrecord <= 0:0.1.5
29 Provides: dvdrecord = 0:0.1.5.1
30 Obsoletes: cdrecord < 9:2.01-12
31 Provides: cdrecord = 9:2.01-12
32 Requires(preun): %{_sbindir}/alternatives chkconfig coreutils
33 Requires(post): %{_sbindir}/alternatives chkconfig coreutils
35 %description -n wodim
36 Wodim is an application for creating audio and data CDs. Wodim
37 works with many different brands of CD recorders, fully supports
38 multi-sessions and provides human-readable error messages.
40 %package -n genisoimage
41 Summary: Creates an image of an ISO9660 filesystem
42 Group: Applications/System
43 Obsoletes: mkisofs < 9:2.01-12
44 Provides: mkisofs = 9:2.01-12
45 Requires(preun): %{_sbindir}/alternatives chkconfig coreutils
46 Requires(post): %{_sbindir}/alternatives chkconfig coreutils
48 %description -n genisoimage
49 The genisoimage program is used as a pre-mastering program; i.e., it
50 generates the ISO9660 filesystem. Genisoimage takes a snapshot of
51 a given directory tree and generates a binary image of the tree
52 which will correspond to an ISO9660 filesystem when written to
53 a block device. Genisoimage is used for writing CD-ROMs, and includes
54 support for creating bootable El Torito CD-ROMs.
56 Install the genisoimage package if you need a program for writing
57 CD-ROMs.
59 %package -n dirsplit
60 Summary: dirsplit utility
61 Group: Applications/System
62 Requires: perl >= 4:5.8.1
63 Requires: genisoimage = %{version}-%{release}
65 %description -n dirsplit
66 dirsplit
68 %package -n icedax
69 Group: Applications/Multimedia
70 Summary: A utility for sampling/copying .wav files from digital audio CDs
71 Obsoletes: cdda2wav < 9:2.01-12
72 Provides: cdda2wav = 9:2.01-12
73 Requires(preun): %{_sbindir}/alternatives chkconfig coreutils
74 Requires(post): %{_sbindir}/alternatives chkconfig coreutils
75 Requires: vorbis-tools
77 %description -n icedax
78 Icedax is a sampling utility for CD-ROM drives that are capable of
79 providing a CD's audio data in digital form to your host. Audio data
80 read from the CD can be saved as .wav or .sun format sound files.
81 Recording formats include stereo/mono, 8/12/16 bits and different
82 rates. Icedax can also be used as a CD player.
84 %prep
85 %setup -q
86 %patch1 -p1 -b .werror
87 %patch2 -p1 -b .efi
88 %patch3 -p1 -b .types
89 %patch4 -p1 -b .no_mp3
90 %patch5 -p1 -b .buffer_overflow
91 #%patch6 -p1 -b .rr_joliet
92 %patch7 -p1 -b .root_option
94 find . -type f -print0 | xargs -0 perl -pi -e 's#/usr/local/bin/perl#/usr/bin/perl#g'
95 find doc -type f -print0 | xargs -0 chmod a-x
98 %build
99 mkdir fedora
100 cd fedora
101 export CFLAGS="$RPM_OPT_FLAGS -Wall -Werror -Wno-unused-function -Wno-unused-variable -fno-strict-aliasing"
102 export CXXFLAGS="$CFLAGS"
103 export FFLAGS="$CFLAGS"
104 cmake .. \
105 -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
106 -DBUILD_SHARED_LIBS:BOOL=ON
107 make VERBOSE=1 %{?_smp_mflags}
109 %install
110 rm -rf $RPM_BUILD_ROOT
111 cd fedora
112 make install DESTDIR=$RPM_BUILD_ROOT
113 perl -pi -e 's#^require v5.8.1;##g' $RPM_BUILD_ROOT%{_bindir}/dirsplit
114 ln -s genisoimage $RPM_BUILD_ROOT%{_bindir}/mkisofs
115 ln -s genisoimage $RPM_BUILD_ROOT%{_bindir}/mkhybrid
116 ln -s icedax $RPM_BUILD_ROOT%{_bindir}/cdda2wav
117 ln -s wodim $RPM_BUILD_ROOT%{_bindir}/cdrecord
118 ln -s wodim $RPM_BUILD_ROOT%{_bindir}/dvdrecord
120 # we don't need cdda2mp3 since we don't have any mp3 {en,de}coder
121 rm $RPM_BUILD_ROOT%{_bindir}/cdda2mp3
123 %clean
124 rm -rf $RPM_BUILD_ROOT
126 %post -n wodim
127 link=`readlink %{_bindir}/cdrecord`
128 if [ "$link" == "%{_bindir}/wodim" ]; then
129 rm -f %{_bindir}/cdrecord
131 link=`readlink %{_bindir}/dvdrecord`
132 if [ "$link" == "wodim" ]; then
133 rm -f %{_bindir}/dvdrecord
136 %{_sbindir}/alternatives --install %{_bindir}/cdrecord cdrecord \
137 %{_bindir}/wodim 50 \
138 --slave %{_mandir}/man1/cdrecord.1.gz cdrecord-cdrecordman \
139 %{_mandir}/man1/wodim.1.gz \
140 --slave %{_bindir}/dvdrecord cdrecord-dvdrecord %{_bindir}/wodim \
141 --slave %{_mandir}/man1/dvdrecord.1.gz cdrecord-dvdrecordman \
142 %{_mandir}/man1/wodim.1.gz \
143 --slave %{_bindir}/readcd cdrecord-readcd %{_bindir}/readom \
144 --slave %{_mandir}/man1/readcd.1.gz cdrecord-readcdman \
145 %{_mandir}/man1/readom.1.gz
147 %preun -n wodim
148 if [ $1 = 0 ]; then
149 %{_sbindir}/alternatives --remove cdrecord %{_bindir}/wodim
152 %post -n genisoimage
153 link=`readlink %{_bindir}/mkisofs`
154 if [ "$link" == "genisoimage" ]; then
155 rm -f %{_bindir}/mkisofs
158 %{_sbindir}/alternatives --install %{_bindir}/mkisofs mkisofs \
159 %{_bindir}/genisoimage 50 \
160 --slave %{_mandir}/man1/mkisofs.1.gz mkisofs-mkisofsman \
161 %{_mandir}/man1/genisoimage.1.gz \
162 --slave %{_bindir}/mkhybrid mkisofs-mkhybrid %{_bindir}/genisoimage
164 %preun -n genisoimage
165 if [ $1 = 0 ]; then
166 %{_sbindir}/alternatives --remove mkisofs %{_bindir}/genisoimage
169 %post -n icedax
170 link=`readlink %{_bindir}/cdda2wav`
171 if [ "$link" == "icedax" ]; then
172 rm -f %{_bindir}/cdda2wav
174 %{_sbindir}/alternatives --install %{_bindir}/cdda2wav cdda2wav \
175 %{_bindir}/icedax 50 \
176 --slave %{_mandir}/man1/cdda2wav.1.gz cdda2wav-cdda2wavman \
177 %{_mandir}/man1/icedax.1.gz
179 %preun -n icedax
180 if [ $1 = 0 ]; then
181 %{_sbindir}/alternatives --remove cdda2wav %{_bindir}/icedax
184 %files -n wodim
185 %defattr(-,root,root)
186 %doc Changelog COPYING FAQ FORK START
187 %doc doc/READMEs doc/wodim
188 %{_bindir}/devdump
189 %{_bindir}/wodim
190 %ghost %{_bindir}/cdrecord
191 %ghost %{_bindir}/dvdrecord
192 %{_bindir}/readom
193 %{_sbindir}/netscsid
194 %{_mandir}/man1/devdump.*
195 %{_mandir}/man1/wodim.*
196 %{_mandir}/man1/readom.*
198 %files -n icedax
199 %defattr(-,root,root)
200 %doc doc/icedax COPYING
201 %{_bindir}/icedax
202 %ghost %{_bindir}/cdda2wav
203 %{_bindir}/cdda2ogg
204 %{_mandir}/man1/icedax.*
205 %{_mandir}/man1/cdda2ogg.*
206 %{_mandir}/man1/list_audio_tracks.*
208 %files -n genisoimage
209 %defattr(-,root,root)
210 %doc doc/genisoimage COPYING
211 %{_bindir}/genisoimage
212 %ghost %{_bindir}/mkisofs
213 %ghost %{_bindir}/mkhybrid
214 %{_bindir}/isodebug
215 %{_bindir}/isodump
216 %{_bindir}/isoinfo
217 %{_bindir}/isovfy
218 %{_bindir}/pitchplay
219 %{_bindir}/readmult
220 %{_mandir}/man5/genisoimagerc.*
221 %{_mandir}/man1/genisoimage.*
222 %{_mandir}/man1/isodebug.*
223 %{_mandir}/man1/isodump.*
224 %{_mandir}/man1/isoinfo.*
225 %{_mandir}/man1/isovfy.*
226 %{_mandir}/man1/pitchplay.*
227 %{_mandir}/man1/readmult.*
229 %files -n dirsplit
230 %defattr(-,root,root)
231 %{_bindir}/dirsplit
232 %{_mandir}/man1/dirsplit.*
234 %changelog
235 * Tue Aug 11 2009 Nikola Pajkovsky <npajkovs@redhat.com> 1.1.9-10
236 - fix #508449. fix string overflow breakage when using the -root
238 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.9-9
239 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
241 * Thu Jul 16 2009 Nikola Pajkovsky <npajkovs@redhat.com> 1.1.9-8
242 - fix buffer overflow
244 * Fri Jul 10 2009 Adam Jackson <ajax@redhat.com> 1.1.9-7
245 - Move dirsplit to a subpackage to isolate the perl dependency.
247 * Tue Jun 15 2009 Roman Rakus <rrakus@redhat.com> - 1.1.9-6
248 - rename functions as they conflict with glibc
249 - Don't push cdda2mp3 because we don't have any mp3 coder
250 Resolves: #505918
252 * Tue Jun 02 2009 Roman Rakus <rrakus@redhat.com> - 1.1.9-5
253 - Added Requires vorbis-tools in icedax (rhbz #503699)
255 * Wed Feb 25 2009 Peter Jones <pjones@redhat.com> - 1.1.9-4
256 - Add support for EFI boot images.
258 * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.9-3
259 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
261 * Thu Feb 12 2009 Roman Rakus <rrakus@redhat.com> - 1.1.9-2
262 - Use -fno-strict-aliasing to prevent strict_aliasing warnings/errors
264 * Mon Oct 27 2008 Roman Rakus <rrakus@redhat.com> - 1.1.9-1
265 - Bump to version 1.1.9
267 * Tue May 27 2008 Roman Rakus <rrakus@redhat.com> - 1.1.8-1
268 - Version 1.1.8 - old patches included
269 - added bzip2-devel to build requirements
270 - fixed #171510 - preserve directory permissions
272 * Wed Feb 27 2008 Harald Hoyer <harald@redhat.com> 1.1.6-11
273 - refined -Werror patch
275 * Mon Feb 25 2008 Harald Hoyer <harald@redhat.com> 1.1.6-10
276 - patched to compile with -Werror (rhbz#429385)
278 * Thu Feb 21 2008 Harald Hoyer <harald@redhat.com> 1.1.6-9
279 - fixed loop on error message for old dev syntax (rhbz#429386)
281 * Thu Feb 21 2008 Harald Hoyer <harald@redhat.com> 1.1.6-8
282 - added file-devel to build requirements
284 * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.1.6-7
285 - Autorebuild for GCC 4.3
287 * Tue Sep 25 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-6
288 - fixed readcd man page symlink
290 * Fri Sep 21 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-5
291 - fixed rhbz#255001 - icedax --devices segfaults
292 - fixed rhbz#249357 - Typo in wodim output
294 * Fri Sep 21 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-4
295 - play stupid tricks, to let alternatives make the links and
296 rpm not removing them afterwards
297 - removed bogus warning for "." and ".."
299 * Thu Sep 20 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-3
300 - fixed rhbz#248262
301 - switched to alternatives
303 * Fri Aug 17 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-2
304 - changed license to GPLv2
306 * Wed Jun 20 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-1
307 - version 1.1.6
308 - added readcd symlink
310 * Mon Apr 23 2007 Harald Hoyer <harald@redhat.com> - 1.1.2-4
311 - bump obsoletes/provides
313 * Tue Feb 27 2007 Harald Hoyer <harald@redhat.com> - 1.1.2-3
314 - applied specfile changes as in bug #224365
316 * Wed Jan 24 2007 Harald Hoyer <harald@redhat.com> - 1.1.2-1
317 - version 1.1.2