faulty and unneeded memset caused a -Werror during build
[cdrkit.git] / cdrkit.spec
blobd257559610264480a7aef61a0096a3ff0b84ff40
1 Summary: A collection of CD/DVD utilities
2 Name: cdrkit
3 Version: 1.1.11
4 Release: 16%{?dist}
5 License: GPLv2
6 Group: Applications/System
7 URL: http://cdrkit.org/
8 Source: http://cdrkit.org/releases/cdrkit-%{version}.tar.gz
10 Patch1: cdrkit-1.1.8-werror.patch
11 Patch2: cdrkit-1.1.9-efi-boot.patch
12 Patch4: cdrkit-1.1.9-no_mp3.patch
13 Patch5: cdrkit-1.1.9-buffer_overflow.patch
14 Patch6: cdrkit-1.1.10-build-fix.patch
15 Patch7: cdrkit-1.1.11-manpagefix.patch
16 Patch8: cdrkit-1.1.11-rootstat.patch
17 Patch9: cdrkit-1.1.11-usalinst.patch
18 Patch10: cdrkit-1.1.11-readsegfault.patch
19 Patch11: cdrkit-1.1.11-format.patch
20 Patch12: cdrkit-1.1.11-handler.patch
21 Patch13: cdrkit-1.1.11-dvdman.patch
22 Patch14: cdrkit-1.1.11-paranoiacdda.patch
23 Patch15: cdrkit-1.1.11-utf8.patch
24 Patch16: cdrkit-1.1.11-cmakewarn.patch
25 Patch17: cdrkit-1.1.11-edcspeed_memset.patch
27 BuildRequires: cmake libcap-devel zlib-devel perl file-devel bzip2-devel
29 %description
30 cdrkit is a collection of CD/DVD utilities.
32 %package -n wodim
33 Summary: A command line CD/DVD recording program
34 Group: Applications/Archiving
35 Obsoletes: dvdrecord <= 0:0.1.5
36 Provides: dvdrecord = 0:0.1.5.1
37 Obsoletes: cdrecord < 9:2.01-12
38 Provides: cdrecord = 9:2.01-12
39 Requires: libusal = %{version}-%{release}
40 Requires(preun): %{_sbindir}/alternatives coreutils
41 Requires(post): %{_sbindir}/alternatives coreutils
43 %description -n wodim
44 Wodim is an application for creating audio and data CDs. Wodim
45 works with many different brands of CD recorders, fully supports
46 multi-sessions and provides human-readable error messages.
48 %package -n genisoimage
49 Summary: Creates an image of an ISO9660 file-system
50 Group: Applications/System
51 Obsoletes: mkisofs < 9:2.01-12
52 Provides: mkisofs = 9:2.01-12
53 Requires: libusal = %{version}-%{release}
54 Requires(preun): %{_sbindir}/alternatives coreutils
55 Requires(post): %{_sbindir}/alternatives coreutils
57 %description -n genisoimage
58 The genisoimage program is used as a pre-mastering program; i.e., it
59 generates the ISO9660 file-system. Genisoimage takes a snapshot of
60 a given directory tree and generates a binary image of the tree
61 which will correspond to an ISO9660 file-system when written to
62 a block device. Genisoimage is used for writing CD-ROMs, and includes
63 support for creating boot-able El Torito CD-ROMs.
65 Install the genisoimage package if you need a program for writing
66 CD-ROMs.
68 %package -n dirsplit
69 Summary: Utility to split directories
70 Group: Applications/System
71 Requires: perl >= 4:5.8.1
72 Requires: genisoimage = %{version}-%{release}
74 %description -n dirsplit
75 This utility is used to split directories into chunks before burning.
76 Chunk size is usually set to fit to a CD/DVD.
78 %package -n icedax
79 Group: Applications/Multimedia
80 Summary: A utility for sampling/copying .wav files from digital audio CDs
81 Obsoletes: cdda2wav < 9:2.01-12
82 Provides: cdda2wav = 9:2.01-12
83 Requires: libusal = %{version}-%{release}
84 Requires(preun): %{_sbindir}/alternatives chkconfig coreutils
85 Requires(post): %{_sbindir}/alternatives chkconfig coreutils
86 Requires: vorbis-tools
87 Requires: cdparanoia
88 BuildRequires: cdparanoia-devel
90 %description -n icedax
91 Icedax is a sampling utility for CD-ROM drives that are capable of
92 providing a CD's audio data in digital form to your host. Audio data
93 read from the CD can be saved as .wav or .sun format sound files.
94 Recording formats include stereo/mono, 8/12/16 bits and different
95 rates. Icedax can also be used as a CD player.
97 %package -n libusal
98 Summary: Library to communicate with SCSI devices
99 Group: Development/Libraries
101 %description -n libusal
102 The libusal package contains C libraries that allows applications
103 to communicate with SCSI devices and is well suitable for writing
104 CD-R media.
106 %package -n libusal-devel
107 Summary: Development files for libusal
108 Group: Development/Libraries
109 Requires: libusal = %{version}-%{release}
111 %description -n libusal-devel
112 The libusal-devel package contains C libraries and header files
113 for developing applications that use libusal for communication with
114 SCSI devices.
116 %prep
117 %setup -q
118 %patch1 -p1 -b .werror
119 %patch2 -p1 -b .efi
120 %patch4 -p1 -b .no_mp3
121 %patch5 -p1 -b .buffer_overflow
122 %patch6 -p1 -b .build-fix
123 %patch7 -p1 -b .manpagefix
124 %patch8 -p1 -b .rootstat
125 %patch9 -p1 -b .usalinst
126 %patch10 -p1 -b .readsegfault
127 %patch11 -p1 -b .format
128 %patch12 -p1 -b .handler
129 %patch13 -p1 -b .dvdman
130 %patch14 -p1 -b .paranoiacdda
131 # not using -b since otherwise backup files would be included into rpm
132 %patch15 -p1
133 %patch16 -p1 -b .cmakewarn
134 %patch17 -p1 -b .edcspeed
136 # we do not want bundled paranoia library
137 rm -rf libparanoia
139 find . -type f -print0 | xargs -0 perl -pi -e 's#/usr/local/bin/perl#/usr/bin/perl#g'
140 find doc -type f -print0 | xargs -0 chmod a-x
143 %build
144 mkdir fedora
145 cd fedora
146 export CFLAGS="$RPM_OPT_FLAGS -Wall -Werror -Wno-unused-function -Wno-unused-variable -Wno-unused-but-set-variable -Wno-array-bounds -fno-strict-aliasing"
147 export CXXFLAGS="$CFLAGS"
148 export FFLAGS="$CFLAGS"
149 %cmake CMAKE_VERBOSE=1 \
150 -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
151 -DBUILD_SHARED_LIBS:BOOL=ON \
154 make VERBOSE=1 %{?_smp_mflags}
156 %install
157 cd fedora
158 make install DESTDIR=$RPM_BUILD_ROOT
159 perl -pi -e 's#^require v5.8.1;##g' $RPM_BUILD_ROOT%{_bindir}/dirsplit
160 ln -s genisoimage $RPM_BUILD_ROOT%{_bindir}/mkisofs
161 ln -s genisoimage $RPM_BUILD_ROOT%{_bindir}/mkhybrid
162 ln -s icedax $RPM_BUILD_ROOT%{_bindir}/cdda2wav
163 ln -s wodim $RPM_BUILD_ROOT%{_bindir}/cdrecord
164 ln -s wodim $RPM_BUILD_ROOT%{_bindir}/dvdrecord
166 # missing man page. Do symlink like in debian
167 ln -sf wodim.1.gz $RPM_BUILD_ROOT/%{_mandir}/man1/netscsid.1.gz
169 # we don't need cdda2mp3 since we don't have any mp3 {en,de}coder
170 rm $RPM_BUILD_ROOT%{_bindir}/cdda2mp3
172 %post -n wodim
173 link=`readlink %{_bindir}/cdrecord`
174 if [ "$link" == "%{_bindir}/wodim" ]; then
175 rm -f %{_bindir}/cdrecord
177 link=`readlink %{_bindir}/dvdrecord`
178 if [ "$link" == "wodim" ]; then
179 rm -f %{_bindir}/dvdrecord
182 %{_sbindir}/alternatives --install %{_bindir}/cdrecord cdrecord \
183 %{_bindir}/wodim 50 \
184 --slave %{_mandir}/man1/cdrecord.1.gz cdrecord-cdrecordman \
185 %{_mandir}/man1/wodim.1.gz \
186 --slave %{_bindir}/dvdrecord cdrecord-dvdrecord %{_bindir}/wodim \
187 --slave %{_mandir}/man1/dvdrecord.1.gz cdrecord-dvdrecordman \
188 %{_mandir}/man1/wodim.1.gz \
189 --slave %{_bindir}/readcd cdrecord-readcd %{_bindir}/readom \
190 --slave %{_mandir}/man1/readcd.1.gz cdrecord-readcdman \
191 %{_mandir}/man1/readom.1.gz
193 %preun -n wodim
194 if [ $1 = 0 ]; then
195 %{_sbindir}/alternatives --remove cdrecord %{_bindir}/wodim
198 %post -n genisoimage
199 link=`readlink %{_bindir}/mkisofs`
200 if [ "$link" == "genisoimage" ]; then
201 rm -f %{_bindir}/mkisofs
204 %{_sbindir}/alternatives --install %{_bindir}/mkisofs mkisofs \
205 %{_bindir}/genisoimage 50 \
206 --slave %{_mandir}/man1/mkisofs.1.gz mkisofs-mkisofsman \
207 %{_mandir}/man1/genisoimage.1.gz \
208 --slave %{_bindir}/mkhybrid mkisofs-mkhybrid %{_bindir}/genisoimage \
209 --slave %{_mandir}/man1/mkhybrid.1.gz mkisofs-mkhybridman \
210 %{_mandir}/man1/genisoimage.1.gz
212 %preun -n genisoimage
213 if [ $1 = 0 ]; then
214 %{_sbindir}/alternatives --remove mkisofs %{_bindir}/genisoimage
217 %post -n icedax
218 link=`readlink %{_bindir}/cdda2wav`
219 if [ "$link" == "icedax" ]; then
220 rm -f %{_bindir}/cdda2wav
222 %{_sbindir}/alternatives --install %{_bindir}/cdda2wav cdda2wav \
223 %{_bindir}/icedax 50 \
224 --slave %{_mandir}/man1/cdda2wav.1.gz cdda2wav-cdda2wavman \
225 %{_mandir}/man1/icedax.1.gz
227 %preun -n icedax
228 if [ $1 = 0 ]; then
229 %{_sbindir}/alternatives --remove cdda2wav %{_bindir}/icedax
232 %post -n libusal -p /sbin/ldconfig
234 %postun -n libusal -p /sbin/ldconfig
236 %files -n wodim
237 %doc Changelog COPYING FAQ FORK START
238 %doc doc/READMEs doc/wodim
239 %{_bindir}/devdump
240 %{_bindir}/wodim
241 %ghost %{_bindir}/cdrecord
242 %ghost %{_bindir}/dvdrecord
243 %{_bindir}/readom
244 %{_sbindir}/netscsid
245 %{_mandir}/man1/devdump.*
246 %{_mandir}/man1/wodim.*
247 %{_mandir}/man1/netscsid.*
248 %{_mandir}/man1/readom.*
250 %files -n icedax
251 %doc doc/icedax COPYING
252 %{_bindir}/icedax
253 %ghost %{_bindir}/cdda2wav
254 %{_bindir}/cdda2ogg
255 %{_mandir}/man1/icedax.*
256 %{_mandir}/man1/cdda2ogg.*
257 %{_mandir}/man1/list_audio_tracks.*
259 %files -n genisoimage
260 %doc doc/genisoimage COPYING
261 %{_bindir}/genisoimage
262 %ghost %{_bindir}/mkisofs
263 %ghost %{_bindir}/mkhybrid
264 %{_bindir}/isodebug
265 %{_bindir}/isodump
266 %{_bindir}/isoinfo
267 %{_bindir}/isovfy
268 %{_bindir}/pitchplay
269 %{_bindir}/readmult
270 %{_mandir}/man5/genisoimagerc.*
271 %{_mandir}/man1/genisoimage.*
272 %{_mandir}/man1/isodebug.*
273 %{_mandir}/man1/isodump.*
274 %{_mandir}/man1/isoinfo.*
275 %{_mandir}/man1/isovfy.*
276 %{_mandir}/man1/pitchplay.*
277 %{_mandir}/man1/readmult.*
279 %files -n dirsplit
280 %{_bindir}/dirsplit
281 %{_mandir}/man1/dirsplit.*
283 %files -n libusal
284 %doc doc/plattforms/README.linux Changelog COPYING FAQ FORK START
285 %{_libdir}/libusal.so.*
286 %{_libdir}/librols.so.*
288 %files -n libusal-devel
289 %doc COPYING
290 %{_libdir}/libusal.so
291 %{_libdir}/librols.so
292 %{_includedir}/usal
294 %changelog
295 * Fri Feb 22 2013 Frantisek Kluknavsky <fkluknav@redhat.com> - 1.1.11-16
296 - faulty and unneeded memset in edcspeed.c caused a -Werror during build
298 * Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.11-15
299 - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
301 * Wed Oct 03 2012 Honza Horak <hhorak@redhat.com> - 1.1.11-14
302 - Add coreutils as preun/post requirements for wodim and genisoimage
303 Resolves: #862554
305 * Mon Aug 27 2012 Honza Horak <hhorak@redhat.com> - 1.1.11-13
306 - Add mkhybrid(1) as a symlink to genisoimage(1)
307 - Spec file cleanup
309 * Mon Jul 30 2012 Honza Horak <hhorak@redhat.com> - 1.1.11-12
310 - Use system cdparanoia instead of old bundled version
311 - Build libusal as a shared library
312 - Messages from rpmlint clean-up
314 * Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.11-11
315 - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
317 * Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.11-10
318 - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
320 * Wed Dec 07 2011 Honza Horak <hhorak@redhat.com> - 1.1.11-9
321 - Fix driver specification in man pages
322 (Resolves: #711623)
324 * Thu Jun 02 2011 Honza Horak <hhorak@redhat.com> - 1.1.11-8
325 - Fix segmentation fault when icedax exits while sleeping after ctrl-c
326 (Resolves: #709902)
328 * Tue May 17 2011 Honza Horak <hhorak@redhat.com> - 1.1.11-7
329 - Fix automatic formatting of DVD+RW if needed
330 (Resolves: #519465)
332 * Thu Mar 17 2011 Honza Horak <hhorak@redhat.com> - 1.1.11-6
333 - Added Provides: libusal-static for libusal-devel subpackage
334 (Resolves: #688347)
336 * Mon Mar 07 2011 Honza Horak <hhorak@redhat.com> - 1.1.11-5
337 - Fix segmentation fault in readom
338 (Resolves: #682591)
340 * Thu Feb 17 2011 Honza Horak <hhorak@redhat.com> - 1.1.11-4
341 - Library libusal is installed in order to be used by other apps
342 (Resolves: #588508)
343 https://bugzilla.redhat.com/show_bug.cgi?id=588508
345 * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.11-3
346 - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
348 * Mon Jan 31 2011 Honza Horak <hhorak@redhat.com> 1.1.11-2
349 - fixed man page missing arguments (Resolves: #647024)
350 https://bugzilla.redhat.com/show_bug.cgi?id=647024
351 - fixed erroneous "Unknown file type (unallocated)" warning
352 (Resolves: #174667)
353 https://bugzilla.redhat.com/show_bug.cgi?id=174667
355 * Mon Oct 18 2010 Nikola Pajkovsky <npajkovs@redhat.com> 1.1.11-1
356 - new upstream version 1.1.11
358 * Mon Jun 21 2010 Roman Rakus <rrakus@redhat.com> - 1.1.10-2
359 - Added missing manpage for netscsid (symlink to wodim manpage)
361 * Wed Jan 20 2010 Nikola Pajkovsky <npajkovs@redhat.com> - 1.1.10-1
362 - new upstream version 1.1.10
364 * Tue Aug 11 2009 Nikola Pajkovsky <npajkovs@redhat.com> 1.1.9-10
365 - fix #508449. fix string overflow breakage when using the -root
367 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.9-9
368 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
370 * Thu Jul 16 2009 Nikola Pajkovsky <npajkovs@redhat.com> 1.1.9-8
371 - fix buffer overflow
373 * Fri Jul 10 2009 Adam Jackson <ajax@redhat.com> 1.1.9-7
374 - Move dirsplit to a subpackage to isolate the perl dependency.
376 * Tue Jun 15 2009 Roman Rakus <rrakus@redhat.com> - 1.1.9-6
377 - rename functions as they conflict with glibc
378 - Don't push cdda2mp3 because we don't have any mp3 coder
379 Resolves: #505918
381 * Tue Jun 02 2009 Roman Rakus <rrakus@redhat.com> - 1.1.9-5
382 - Added Requires vorbis-tools in icedax (rhbz #503699)
384 * Wed Feb 25 2009 Peter Jones <pjones@redhat.com> - 1.1.9-4
385 - Add support for EFI boot images.
387 * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.9-3
388 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
390 * Thu Feb 12 2009 Roman Rakus <rrakus@redhat.com> - 1.1.9-2
391 - Use -fno-strict-aliasing to prevent strict_aliasing warnings/errors
393 * Mon Oct 27 2008 Roman Rakus <rrakus@redhat.com> - 1.1.9-1
394 - Bump to version 1.1.9
396 * Tue May 27 2008 Roman Rakus <rrakus@redhat.com> - 1.1.8-1
397 - Version 1.1.8 - old patches included
398 - added bzip2-devel to build requirements
399 - fixed #171510 - preserve directory permissions
401 * Wed Feb 27 2008 Harald Hoyer <harald@redhat.com> 1.1.6-11
402 - refined -Werror patch
404 * Mon Feb 25 2008 Harald Hoyer <harald@redhat.com> 1.1.6-10
405 - patched to compile with -Werror (rhbz#429385)
407 * Thu Feb 21 2008 Harald Hoyer <harald@redhat.com> 1.1.6-9
408 - fixed loop on error message for old dev syntax (rhbz#429386)
410 * Thu Feb 21 2008 Harald Hoyer <harald@redhat.com> 1.1.6-8
411 - added file-devel to build requirements
413 * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.1.6-7
414 - Autorebuild for GCC 4.3
416 * Tue Sep 25 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-6
417 - fixed readcd man page symlink
419 * Fri Sep 21 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-5
420 - fixed rhbz#255001 - icedax --devices segfaults
421 - fixed rhbz#249357 - Typo in wodim output
423 * Fri Sep 21 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-4
424 - play stupid tricks, to let alternatives make the links and
425 rpm not removing them afterwards
426 - removed bogus warning for "." and ".."
428 * Thu Sep 20 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-3
429 - fixed rhbz#248262
430 - switched to alternatives
432 * Fri Aug 17 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-2
433 - changed license to GPLv2
435 * Wed Jun 20 2007 Harald Hoyer <harald@redhat.com> - 1.1.6-1
436 - version 1.1.6
437 - added readcd symlink
439 * Mon Apr 23 2007 Harald Hoyer <harald@redhat.com> - 1.1.2-4
440 - bump obsoletes/provides
442 * Tue Feb 27 2007 Harald Hoyer <harald@redhat.com> - 1.1.2-3
443 - applied specfile changes as in bug #224365
445 * Wed Jan 24 2007 Harald Hoyer <harald@redhat.com> - 1.1.2-1
446 - version 1.1.2