1 { mkDerivation, array, async, base, base16-bytestring, binary
2 , bytestring, Cabal, containers, cryptohash-sha256, deepseq
3 , directory, echo, edit-distance, filepath, hackage-security
4 , hashable, HTTP, mtl, network, network-uri, pretty, pretty-show
5 , process, QuickCheck, random, regex-posix, stdenv, stm, tagged
6 , tar, tasty, tasty-hunit, tasty-quickcheck, time, unix, zlib
9 pname = "cabal-install";
14 setupHaskellDepends = [ base Cabal filepath process ];
15 executableHaskellDepends = [
16 array async base base16-bytestring binary bytestring Cabal
17 containers cryptohash-sha256 deepseq directory echo edit-distance
18 filepath hackage-security hashable HTTP mtl network network-uri
19 pretty process random stm tar time unix zlib
21 testHaskellDepends = [
22 array async base base16-bytestring binary bytestring Cabal
23 containers cryptohash-sha256 deepseq directory filepath
24 hackage-security hashable HTTP mtl network network-uri pretty
25 pretty-show process QuickCheck random regex-posix stm tagged tar
26 tasty tasty-hunit tasty-quickcheck time unix zlib
31 mv bash-completion $out/etc/bash_completion.d
33 homepage = "http://www.haskell.org/cabal/";
34 description = "The command-line interface for Cabal and Hackage";
35 license = stdenv.lib.licenses.bsd3;