Add applicative import for old GHCs in BuildToolsPathForeign test
[cabal.git] / cabal-install / default.nix
blob506d8f49ee66390d220470a158fe6def7f81cff4
1 { mkDerivation, array, async, base, base16-bytestring, binary
2 , bytestring, Cabal, containers, cryptohash-sha256, deepseq
3 , directory, echo, edit-distance, filepath, hackage-security
4 , hashable, HTTP, mtl, network, network-uri, pretty, pretty-show
5 , process, QuickCheck, random, regex-posix, stdenv, stm, tagged
6 , tar, tasty, tasty-hunit, tasty-quickcheck, time, unix, zlib
7 }:
8 mkDerivation {
9   pname = "cabal-install";
10   version = "1.25.0.0";
11   src = ./.;
12   isLibrary = false;
13   isExecutable = true;
14   setupHaskellDepends = [ base Cabal filepath process ];
15   executableHaskellDepends = [
16     array async base base16-bytestring binary bytestring Cabal
17     containers cryptohash-sha256 deepseq directory echo edit-distance
18     filepath hackage-security hashable HTTP mtl network network-uri
19     pretty process random stm tar time unix zlib
20   ];
21   testHaskellDepends = [
22     array async base base16-bytestring binary bytestring Cabal
23     containers cryptohash-sha256 deepseq directory filepath
24     hackage-security hashable HTTP mtl network network-uri pretty
25     pretty-show process QuickCheck random regex-posix stm tagged tar
26     tasty tasty-hunit tasty-quickcheck time unix zlib
27   ];
28   doCheck = false;
29   postInstall = ''
30     mkdir $out/etc
31     mv bash-completion $out/etc/bash_completion.d
32   '';
33   homepage = "http://www.haskell.org/cabal/";
34   description = "The command-line interface for Cabal and Hackage";
35   license = stdenv.lib.licenses.bsd3;