Comment.
[cabal.git] / Cabal.nix
blobb8f7a0693617ffd65e469b36c7590e817a5ebfec
1 { mkDerivation, array, base, binary, bytestring, containers
2 , deepseq, directory, exceptions, filepath, old-time, pretty
3 , process, QuickCheck, regex-posix, stdenv, tagged, tasty
4 , tasty-hunit, tasty-quickcheck, time, transformers, unix
5 }:
6 mkDerivation {
7   pname = "Cabal";
8   version = "1.25.0.0";
9   src = ./Cabal;
10   libraryHaskellDepends = [
11     array base binary bytestring containers deepseq directory filepath
12     pretty process time unix
13   ];
14   testHaskellDepends = [
15     array base bytestring containers directory exceptions filepath
16     old-time pretty process QuickCheck regex-posix tagged tasty
17     tasty-hunit tasty-quickcheck time transformers unix
18   ];
19   doCheck = false;
20   homepage = "http://www.haskell.org/cabal/";
21   description = "A framework for packaging Haskell software";
22   license = stdenv.lib.licenses.bsd3;