pass ARCH down to uClibc
[buildroot.git] / package / libgpg-error / libgpg-error.mk
blobc4229da20dbd1242443c744d3a790c619e76b659
1 #############################################################
3 # libgpg-error
5 #############################################################
6 LIBGPG_ERROR_VERSION:=1.5
7 LIBGPG_ERROR_SOURCE:=libgpg-error-$(LIBGPG_ERROR_VERSION).tar.bz2
8 LIBGPG_ERROR_SITE:=ftp://gd.tuwien.ac.at/privacy/gnupg/libgpg-error
9 LIBGPG_ERROR_DIR:=$(BUILD_DIR)/libgpg-error-$(LIBGPG_ERROR_VERSION)
10 LIBGPG_ERROR_LIBRARY:=src/libgpg-error.la
11 LIBGPG_ERROR_DESTDIR:=lib
12 LIBGPG_ERROR_TARGET_LIBRARY=$(LIBGPG_ERROR_DESTDIR)/libgpg-error.so
14 $(DL_DIR)/$(LIBGPG_ERROR_SOURCE):
15 $(WGET) -P $(DL_DIR) $(LIBGPG_ERROR_SITE)/$(LIBGPG_ERROR_SOURCE)
17 $(LIBGPG_ERROR_DIR)/.source: $(DL_DIR)/$(LIBGPG_ERROR_SOURCE)
18 $(BZCAT) $(DL_DIR)/$(LIBGPG_ERROR_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
19 toolchain/patch-kernel.sh $(LIBGPG_ERROR_DIR) package/libgpg-error/ libgpg-error\*.patch
20 $(CONFIG_UPDATE) $(LIBGPG_ERROR_DIR)
21 touch $(LIBGPG_ERROR_DIR)/.source
23 $(LIBGPG_ERROR_DIR)/.configured: $(LIBGPG_ERROR_DIR)/.source
24 (cd $(LIBGPG_ERROR_DIR); rm -f config.cache; \
25 $(TARGET_CONFIGURE_OPTS) \
26 $(TARGET_CONFIGURE_ARGS) \
27 ./configure \
28 --target=$(GNU_TARGET_NAME) \
29 --host=$(GNU_TARGET_NAME) \
30 --build=$(GNU_HOST_NAME) \
31 --prefix=/usr \
32 --exec-prefix=/usr \
33 --bindir=/usr/bin \
34 --sbindir=/usr/sbin \
35 --libdir=/lib \
36 --libexecdir=/$(LIBGPG_ERROR_DESTDIR) \
37 --sysconfdir=/etc \
38 --datadir=/usr/share \
39 --localstatedir=/var \
40 --includedir=/usr/include \
41 --mandir=/usr/man \
42 --infodir=/usr/info \
43 $(DISABLE_NLS) \
45 touch $(LIBGPG_ERROR_DIR)/.configured
47 $(LIBGPG_ERROR_DIR)/$(LIBGPG_ERROR_LIBRARY): $(LIBGPG_ERROR_DIR)/.configured
48 $(MAKE) CC=$(TARGET_CC) -C $(LIBGPG_ERROR_DIR)
50 $(STAGING_DIR)/$(LIBGPG_ERROR_TARGET_LIBRARY): $(LIBGPG_ERROR_DIR)/$(LIBGPG_ERROR_LIBRARY)
51 $(MAKE) DESTDIR=$(STAGING_DIR) -C $(LIBGPG_ERROR_DIR) install
54 $(TARGET_DIR)/$(LIBGPG_ERROR_TARGET_LIBRARY): $(STAGING_DIR)/$(LIBGPG_ERROR_TARGET_LIBRARY)
55 cp -dpf $<* $(TARGET_DIR)/$(LIBGPG_ERROR_DESTDIR)
57 libgpg-error: $(TARGET_DIR)/$(LIBGPG_ERROR_TARGET_LIBRARY)
59 libgpg-error-source: $(DL_DIR)/$(LIBGPG_ERROR_SOURCE)
61 libgpg-error-clean:
62 rm -f $(TARGET_DIR)/$(LIBGPG_ERROR_TARGET_LIBRARY)*
63 -$(MAKE) -C $(LIBGPG_ERROR_DIR) clean
65 libgpg-error-dirclean:
66 rm -rf $(LIBGPG_ERROR_DIR)
68 #############################################################
70 # Toplevel Makefile options
72 #############################################################
73 ifeq ($(BR2_PACKAGE_LIBGPG_ERROR),y)
74 TARGETS+=libgpg-error
75 endif