1 #############################################################
5 #############################################################
7 # Seems to be broken -- topbar icons and such are misplaced etc
8 #METACITY_VERSION:=2.17.5
10 METACITY_VERSION
:=2.16.3
11 METACITY_SOURCE
:=metacity-
$(METACITY_VERSION
).
tar.bz2
12 METACITY_SITE
:=http
://ftp.gnome.org
/pub
/gnome
/sources
/metacity
/2.16
13 METACITY_DIR
:=$(BUILD_DIR
)/metacity-
$(METACITY_VERSION
)
14 METACITY_CAT
:=$(BZCAT
)
16 METACITY_SOURCE2
:=MCity-Clearlooks2.
tar.gz
17 METACITY_CAT2
:=$(ZCAT
)
18 METACITY_SITE2
:=http
://art.gnome.org
/download
/themes
/metacity
/1190
20 $(DL_DIR
)/$(METACITY_SOURCE
):
21 $(WGET
) -P
$(DL_DIR
) $(METACITY_SITE
)/$(METACITY_SOURCE
)
23 $(DL_DIR
)/$(METACITY_SOURCE2
):
24 $(WGET
) -P
$(DL_DIR
) $(METACITY_SITE2
)/$(METACITY_SOURCE2
)
26 metacity-source
: $(DL_DIR
)/$(METACITY_SOURCE
) $(DL_DIR
)/$(METACITY_SOURCE2
)
28 $(METACITY_DIR
)/.unpacked
: $(DL_DIR
)/$(METACITY_SOURCE
) $(DL_DIR
)/$(METACITY_SOURCE2
)
29 $(METACITY_CAT
) $(DL_DIR
)/$(METACITY_SOURCE
) |
tar -C
$(BUILD_DIR
) $(TAR_OPTIONS
) -
30 toolchain
/patch-kernel.sh
$(METACITY_DIR
) package
/metacity
/ \
*.patch
*
31 (cd
$(METACITY_DIR
); libtoolize
--force;)
32 $(CONFIG_UPDATE
) $(METACITY_DIR
)
33 (cd
$(METACITY_DIR
); autoconf
;)
34 touch
$(METACITY_DIR
)/.unpacked
36 $(METACITY_DIR
)/.configured
: $(METACITY_DIR
)/.unpacked
37 (cd
$(METACITY_DIR
); rm -rf config.cache
; \
38 $(TARGET_CONFIGURE_OPTS
) \
39 $(TARGET_CONFIGURE_ARGS
) \
41 PKG_CONFIG
=$(STAGING_DIR
)/usr
/bin
/pkg-config \
42 GLIB_CONFIG
=$(STAGING_DIR
)/bin
/glib-config \
43 ac_cv_func_posix_getpwuid_r
=yes \
44 glib_cv_stack_grows
=no \
46 ac_cv_func_strtod
=yes \
47 ac_fsusage_space
=yes \
48 fu_cv_sys_stat_statfs2_bsize
=yes \
49 ac_cv_func_closedir_void
=no \
50 ac_cv_func_getloadavg
=no \
51 ac_cv_lib_util_getloadavg
=no \
52 ac_cv_lib_getloadavg_getloadavg
=no \
53 ac_cv_func_getgroups
=yes \
54 ac_cv_func_getgroups_works
=yes \
55 ac_cv_func_chown_works
=yes \
56 ac_cv_have_decl_euidaccess
=no \
57 ac_cv_func_euidaccess
=no \
58 ac_cv_have_decl_strnlen
=yes \
59 ac_cv_func_strnlen_working
=yes \
60 ac_cv_func_lstat_dereferences_slashed_symlink
=yes \
61 ac_cv_func_lstat_empty_string_bug
=no \
62 ac_cv_func_stat_empty_string_bug
=no \
63 vb_cv_func_rename_trailing_slash_bug
=no \
64 ac_cv_have_decl_nanosleep
=yes \
65 jm_cv_func_nanosleep_works
=yes \
66 gl_cv_func_working_utimes
=yes \
67 ac_cv_func_utime_null
=yes \
68 ac_cv_have_decl_strerror_r
=yes \
69 ac_cv_func_strerror_r_char_p
=no \
70 jm_cv_func_svid_putenv
=yes \
71 ac_cv_func_getcwd_null
=yes \
72 ac_cv_func_getdelim
=yes \
73 ac_cv_func_mkstemp
=yes \
74 utils_cv_func_mkstemp_limitations
=no \
75 utils_cv_func_mkdir_trailing_slash_bug
=no \
76 ac_cv_func_memcmp_working
=yes \
77 ac_cv_have_decl_malloc
=yes \
78 gl_cv_func_malloc_0_nonnull
=yes \
79 ac_cv_func_malloc_0_nonnull
=yes \
80 ac_cv_func_calloc_0_nonnull
=yes \
81 ac_cv_func_realloc_0_nonnull
=yes \
82 jm_cv_func_gettimeofday_clobber
=no \
83 gl_cv_func_working_readdir
=yes \
84 jm_ac_cv_func_link_follows_symlink
=no \
85 utils_cv_localtime_cache
=no \
86 ac_cv_struct_st_mtim_nsec
=no \
87 gl_cv_func_tzset_clobber
=no \
88 gl_cv_func_getcwd_null
=yes \
89 gl_cv_func_getcwd_path_max
=yes \
90 ac_cv_func_fnmatch_gnu
=yes \
91 am_getline_needs_run_time_check
=no \
92 am_cv_func_working_getline
=yes \
93 gl_cv_func_mkdir_trailing_slash_bug
=no \
94 gl_cv_func_mkstemp_limitations
=no \
95 ac_cv_func_working_mktime
=yes \
96 jm_cv_func_working_re_compile_pattern
=yes \
97 ac_use_included_regex
=no \
99 ac_cv_path_GLIB_GENMARSHAL
=/usr
/bin
/glib-genmarshal \
100 --target
=$(GNU_TARGET_NAME
) \
101 --host
=$(GNU_TARGET_NAME
) \
102 --build
=$(GNU_HOST_NAME
) \
107 --x-includes
=$(STAGING_DIR
)/usr
/X11R6
/include \
108 --x-libraries
=$(STAGING_DIR
)/usr
/X11R6
/lib \
111 --disable-dependency-tracking \
114 --disable-startup-notification \
116 touch
$(METACITY_DIR
)/.configured
118 $(METACITY_DIR
)/.compiled
: $(METACITY_DIR
)/.configured
119 $(MAKE
) -C
$(METACITY_DIR
)
120 touch
$(METACITY_DIR
)/.compiled
122 $(STAGING_DIR
)/lib
/*metacity
*.so
: $(METACITY_DIR
)/.compiled
123 $(MAKE
) DESTDIR
=$(STAGING_DIR
) -C
$(METACITY_DIR
) install
124 touch
-c
$(STAGING_DIR
)/lib
/*metacity
*.so
126 $(TARGET_DIR
)/lib
/*metacity
*.so
: $(STAGING_DIR
)/lib
/*metacity
*.so
127 cp
-dpf
$(STAGING_DIR
)/lib
/*metacity
*.so
* $(TARGET_DIR
)/lib
/
128 -$(STRIPCMD
) $(STRIP_STRIP_UNNEEDED
) $(TARGET_DIR
)/lib
/*metacity
*.so
129 cp
-dpf
$(STAGING_DIR
)/bin
/*metacity
* $(TARGET_DIR
)/bin
/
130 mkdir
-p
$(TARGET_DIR
)/usr
/share
/metacity
/icons
131 cp
-dpf
$(STAGING_DIR
)/usr
/share
/metacity
/icons
/* $(TARGET_DIR
)/usr
/share
/metacity
/icons
/
132 mkdir
-p
$(TARGET_DIR
)/usr
/share
/themes
133 $(METACITY_CAT2
) $(DL_DIR
)/$(METACITY_SOURCE2
) | \
134 tar -C
$(STAGING_DIR
)/usr
/share
/themes
$(TAR_OPTIONS
) -
135 cp
-a
$(STAGING_DIR
)/usr
/share
/themes
/Clearlooks \
136 $(TARGET_DIR
)/usr
/share
/themes
/
137 (cd
$(TARGET_DIR
)/usr
/share
/themes
; rm -rf Atlanta
; ln
-s Clearlooks Atlanta
)
138 cp
-a package
/metacity
/Xsession
$(TARGET_DIR
)/etc
/X11
/
140 metacity
: uclibc zlib
$(XSERVER
) libgtk2
$(TARGET_DIR
)/lib
/*metacity
*.so
143 -$(MAKE
) -C
$(METACITY_DIR
) clean
146 rm -rf
$(METACITY_DIR
)
148 #############################################################
150 # Toplevel Makefile options
152 #############################################################
153 ifeq ($(BR2_PACKAGE_METACITY
),y
)