fix copy'n paste error
[buildroot.git] / package / hotplug / hotplug.mk
blob8f4a937a93b292003fc1c726965e8d5a71a96343
1 #############################################################
3 # hotplug support
5 #############################################################
6 HOTPLUG_VERSION:=0.5
7 HOTPLUG_SOURCE=package/hotplug/diethotplug-$(HOTPLUG_VERSION).tar.bz2
8 HOTPLUG_SITE=$(BR2_KERNEL_MIRROR)/linux/utils/kernel/hotplug/
9 HOTPLUG_DIR=$(BUILD_DIR)/diethotplug-$(HOTPLUG_VERSION)
10 HOTPLUG_CAT=$(BZCAT)
12 $(HOTPLUG_DIR): $(HOTPLUG_SOURCE)
13 $(HOTPLUG_CAT) $(HOTPLUG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
14 toolchain/patch-kernel.sh $(HOTPLUG_DIR) package/hotplug/ hotplug\*.patch
16 $(HOTPLUG_DIR)/hotplug: $(HOTPLUG_DIR)
17 $(MAKE) CROSS=$(TARGET_CROSS) DEBUG=false KLIBC=false \
18 KERNEL_INCLUDE_DIR=$(STAGING_DIR)/usr/include \
19 TARGET_DIR=$(TARGET_DIR) -C $(HOTPLUG_DIR)
20 touch -c $@
22 $(TARGET_DIR)/sbin/hotplug: $(HOTPLUG_DIR)/hotplug
23 $(INSTALL) -D -m 0755 $(HOTPLUG_DIR)/hotplug $(TARGET_DIR)/sbin/hotplug
24 $(STRIPCMD) $(STRIP_STRIP_ALL) $@
26 hotplug: $(TARGET_DIR)/sbin/hotplug
28 hotplug-source: $(HOTPLUG_SOURCE)
30 hotplug-clean:
31 -$(MAKE) -C $(HOTPLUG_DIR) clean
32 rm -f $(TARGET_DIR)/sbin/hotplug
34 hotplug-dirclean:
35 rm -rf $(HOTPLUG_DIR)
37 #############################################################
39 # Toplevel Makefile options
41 #############################################################
42 ifeq ($(BR2_PACKAGE_HOTPLUG),y)
43 TARGETS+=hotplug
44 endif