expand helptext of dm
[buildroot.git] / package / rxvt / rxvt.mk
blobe81076db0c9f9b684b5efe371ddf052745c5f467
1 #############################################################
3 # rxvt
5 #############################################################
6 # Copyright (C) 2002 by Tom Walsh <Tom@OpenHardware.net>
8 # This program is free software; you can redistribute it and/or modify
9 # it under the terms of the GNU Library General Public License as
10 # published by the Free Software Foundation; either version 2 of the
11 # License, or (at your option) any later version.
13 # This program is distributed in the hope that it will be useful, but
14 # WITHOUT ANY WARRANTY; without even the implied warranty of
15 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
16 # Library General Public License for more details.
18 # You should have received a copy of the GNU Library General Public
19 # License along with this program; if not, write to the Free Software
20 # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
21 # USA
23 RXVT_VERSION:=2.7.5
24 RXVT_SOURCE:=rxvt-$(RXVT_VERSION).tar.gz
25 RXVT_SITE:=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/rxvt
26 RXVT_CAT:=$(ZCAT)
27 RXVT_DIR:=$(BUILD_DIR)/rxvt-$(RXVT_VERSION)
28 RXVT_BINARY:=$(RXVT_DIR)/src/rxvt
30 $(DL_DIR)/$(RXVT_SOURCE):
31 $(WGET) -P $(DL_DIR) $(RXVT_SITE)/$(RXVT_SOURCE)
33 rxvt-source: $(DL_DIR)/$(RXVT_SOURCE)
35 $(RXVT_DIR)/.unpacked: $(DL_DIR)/$(RXVT_SOURCE)
36 $(RXVT_CAT) $(DL_DIR)/$(RXVT_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
37 toolchain/patch-kernel.sh $(RXVT_DIR) package/rxvt/ \*.patch
38 touch $(RXVT_DIR)/.unpacked
40 $(RXVT_DIR)/.configured: $(RXVT_DIR)/.unpacked
41 (cd $(RXVT_DIR); rm -rf config.cache; \
42 $(TARGET_CONFIGURE_OPTS) \
43 $(TARGET_CONFIGURE_ARGS) \
44 rxvt_cv_ptys=GLIBC \
45 ./configure \
46 --target=$(GNU_TARGET_NAME) \
47 --host=$(GNU_TARGET_NAME) \
48 --build=$(GNU_HOST_NAME) \
49 --prefix=$(X11_PREFIX) \
50 --mandir=/usr/man \
51 --infodir=/usr/info \
52 --x-includes=$(STAGING_DIR)$(X11_PREFIX)/include \
53 --x-libraries=$(STAGING_DIR)$(X11_PREFIX)/lib \
54 --disable-resources \
55 --disable-memset \
57 touch $(RXVT_DIR)/.configured
59 $(RXVT_BINARY): $(RXVT_DIR)/.configured
60 $(MAKE) CC=$(TARGET_CC) -C $(RXVT_DIR)
61 $(STRIPCMD) $(STRIP_DISCARD_ALL) $(RXVT_BINARY)
63 $(TARGET_DIR)$(X11_PREFIX)/bin/rxvt: $(RXVT_BINARY)
64 cp -f $(RXVT_BINARY) $(TARGET_DIR)$(X11_PREFIX)/bin
65 (cd $(TARGET_DIR)$(X11_PREFIX)/bin; ln -fs rxvt xterm)
67 rxvt: $(XSERVER) $(TARGET_DIR)$(X11_PREFIX)/bin/rxvt
69 rxvt-clean:
70 rm -f $(TARGET_DIR)$(X11_PREFIX)/bin/rxvt
71 -$(MAKE) -C $(RXVT_DIR) clean
73 rxvt-dirclean:
74 rm -rf $(RXVT_DIR)
76 #############################################################
78 # Toplevel Makefile options
80 #############################################################
81 ifeq ($(BR2_PACKAGE_RXVT),y)
82 TARGETS+=rxvt
83 endif