bump version
[buildroot.git] / package / hostap / hostap.mk
blob35363919e57e5d604dd539b9ce020f275a3b6231
1 #############################################################
3 # hostap
5 # Note! Host AP driver was added into the main kernel tree in Linux v2.6.14.
6 # The version in the kernel tree should be used instead of this external
7 # hostap-driver package.
8 # The external releases are only for older kernel versions and all
9 # the future development will be in the main kernel tree.
11 #############################################################
12 HOSTAP_VERSION=0.4.9
13 HOSTAP_SOURCE=hostap-driver-$(HOSTAP_VERSION).tar.gz
14 HOSTAP_SITE=http://hostap.epitest.fi/releases
15 HOSTAP_DIR=$(BUILD_DIR)/hostapd-$(HOSTAP_VERSION)
17 $(DL_DIR)/$(HOSTAP_SOURCE):
18 $(WGET) -P $(DL_DIR) $(HOSTAP_SITE)/$(HOSTAP_SOURCE)
20 hostap-source: $(DL_DIR)/$(HOSTAP_SOURCE)
22 $(HOSTAP_DIR)/.unpacked: $(DL_DIR)/$(HOSTAP_SOURCE)
23 $(ZCAT) $(DL_DIR)/$(HOSTAP_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
24 mv -f $(BUILD_DIR)/hostap $(HOSTAP_DIR)
25 touch $@
27 $(HOSTAP_DIR)/.configured: $(HOSTAP_DIR)/.unpacked
28 #$(SED) "s,/.*#define PRISM2_DOWNLOAD_SUPPORT.*/,#define PRISM2_DOWNLOAD_SUPPORT,g" \
29 # $(HOSTAP_DIR)/driver/modules/hostap_config.h
30 touch $@
32 $(HOSTAP_DIR)/utils/hostap_crypt_conf: $(HOSTAP_DIR)/.configured
33 $(MAKE) -C $(HOSTAP_DIR)/utils \
34 CC=$(TARGET_CC) \
35 CFLAGS="-Os -Wall $(TARGET_CFLAGS) -I../driver/modules"
36 $(MAKE) -C $(HOSTAP_DIR)/hostapd \
37 CC=$(TARGET_CC) \
38 CFLAGS="-Os -Wall $(TARGET_CFLAGS) -I../driver/modules -I../utils"
39 touch -c $(HOSTAP_DIR)/driver/modules/hostap.o
41 $(TARGET_DIR)//usr/bin/hostap_crypt_conf: $(HOSTAP_DIR)/utils/hostap_crypt_conf
42 # Make the dir
43 rm -rf $(HOSTAP_TARGET_MODULE_DIR)
44 mkdir -p $(HOSTAP_TARGET_MODULE_DIR)
45 # Copy the pcmcia-cs conf file
46 mkdir -p $(TARGET_DIR)/etc/pcmcia
47 cp -af $(HOSTAP_DIR)/driver/etc/hostap_cs.conf $(TARGET_DIR)/etc/pcmcia/
48 # Copy The Utils
49 cp -af $(HOSTAP_DIR)/utils/hostap_crypt_conf $(TARGET_DIR)/usr/bin/
50 cp -af $(HOSTAP_DIR)/utils/hostap_diag $(TARGET_DIR)/usr/bin/
51 cp -af $(HOSTAP_DIR)/utils/prism2_param $(TARGET_DIR)/usr/bin/
52 cp -af $(HOSTAP_DIR)/utils/prism2_srec $(TARGET_DIR)/usr/bin/
53 # Copy hostapd
54 cp -af $(HOSTAP_DIR)/hostapd/hostapd $(TARGET_DIR)/usr/sbin/
56 hostap: pcmcia $(TARGET_DIR)//usr/bin/hostap_crypt_conf
58 hostap-clean:
59 $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(HOSTAP_DIR) uninstall
60 -$(MAKE) -C $(HOSTAP_DIR) clean
62 hostap-dirclean:
63 rm -rf $(HOSTAP_DIR)
65 #############################################################
67 # Toplevel Makefile options
69 #############################################################
70 ifeq ($(BR2_PACKAGE_HOSTAP),y)
71 TARGETS+=hostap
72 endif