honour NO_LONG_DOUBLE_MATH
[buildroot.git] / package / customize / customize.mk
blob4fe4b8bbd253fc2b0cdc9ed0262878fdff859f89
1 #############################################################
3 # Any custom stuff you feel like doing....
5 #############################################################
6 CUST_DIR:=package/customize/source
8 $(BUILD_DIR)/.customize:
9 rm -f $(PROJECT_BUILD_DIR)/series
10 (cd $(CUST_DIR); \
11 /bin/ls -d * > $(PROJECT_BUILD_DIR)/series || \
12 touch $(PROJECT_BUILD_DIR)/series )
13 for f in `cat $(PROJECT_BUILD_DIR)/series`; do \
14 cp -af $(CUST_DIR)/$$f $(TARGET_DIR)/$$f; \
15 done
16 rm -f $(PROJECT_BUILD_DIR)/series
17 touch $@
19 customize: $(BUILD_DIR)/.customize
21 customize-clean:
22 rm -f $(BUILD_DIR)/.customize
24 .PHONY: customize
25 #############################################################
27 # Toplevel Makefile options
29 #############################################################
30 ifeq ($(BR2_PACKAGE_CUSTOMIZE),y)
31 TARGETS+=customize
32 endif