bump version
[buildroot.git] / package / libraw1394 / libraw1394.mk
blob01f4f2a51dd849bd50a883d2ccc12f6488f01ad0
1 #############################################################
3 # libraw1394
5 #############################################################
7 LIBRAW1394_VERSION:=1.2.1
8 LIBRAW1394_SOURCE:=libraw1394-$(LIBRAW1394_VERSION).tar.gz
9 LIBRAW1394_SITE:=http://www.linux1394.org/dl
10 LIBRAW1394_DIR:=$(BUILD_DIR)/libraw1394-$(LIBRAW1394_VERSION)
12 $(DL_DIR)/$(LIBRAW1394_SOURCE):
13 $(WGET) -P $(DL_DIR) $(LIBRAW1394_SITE)/$(LIBRAW1394_SOURCE)
15 $(LIBRAW1394_DIR)/.unpacked: $(DL_DIR)/$(LIBRAW1394_SOURCE)
16 $(ZCAT) $(DL_DIR)/$(LIBRAW1394_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
17 touch $@
19 $(LIBRAW1394_DIR)/.configured: $(LIBRAW1394_DIR)/.unpacked
20 (cd $(LIBRAW1394_DIR); rm -rf config.cache; \
21 $(TARGET_CONFIGURE_OPTS) \
22 $(TARGET_CONFIGURE_ARGS) \
23 ./configure \
24 --target=$(GNU_TARGET_NAME) \
25 --host=$(GNU_TARGET_NAME) \
26 --build=$(GNU_HOST_NAME) \
27 --prefix=/usr \
28 --exec-prefix=/usr \
29 --bindir=/usr/bin \
30 --sbindir=/usr/sbin \
31 --libdir=/usr/lib \
32 --libexecdir=/usr/lib \
33 --sysconfdir=/etc \
34 --datadir=/usr/share \
35 --localstatedir=/var \
36 --includedir=/include \
37 --mandir=/usr/man \
38 --infodir=/usr/info \
40 touch $@
42 $(LIBRAW1394_DIR)/.compiled: $(LIBRAW1394_DIR)/.configured
43 $(MAKE) -C $(LIBRAW1394_DIR)
44 touch $@
46 $(STAGING_DIR)/usr/lib/libraw1394.so: $(LIBRAW1394_DIR)/.compiled
47 $(MAKE) DESTDIR=$(STAGING_DIR) -C $(LIBRAW1394_DIR)/src install
49 $(TARGET_DIR)/usr/lib/libraw1394.so: $(STAGING_DIR)/lib/libraw1394.so
50 cp -dpf $(STAGING_DIR)/usr/lib/libraw1394.so* $(TARGET_DIR)/usr/lib/
52 libraw1394: $(TARGET_DIR)/usr/lib/libraw1394.so
54 libraw1394-source: $(DL_DIR)/$(LIBRAW1394_SOURCE)
56 libraw1394-clean:
57 rm $(TARGET_DIR)/usr/lib/libraw1394.so*
58 -$(MAKE) -C $(LIBRAW1394_DIR) clean
60 libraw1394-dirclean:
61 rm -rf $(LIBRAW1394_DIR)
63 #############################################################
65 # Toplevel Makefile options
67 #############################################################
68 ifeq ($(BR2_PACKAGE_LIBRAW1394),y)
69 TARGETS+=libraw1394
70 endif