package/x11r7/xserver_xorg-server: bump to version 1.19.3
[buildroot-gz.git] / package / fio / fio.mk
blob5c02bc92ee56052f405cb62c24e083a7d388957e
1 ################################################################################
3 # fio
5 ################################################################################
7 FIO_VERSION = fio-2.13
8 FIO_SITE = git://git.kernel.dk/fio.git
9 FIO_LICENSE = GPLv2 + special obligations
10 FIO_LICENSE_FILES = COPYING
12 ifeq ($(BR2_PACKAGE_LIBAIO),y)
13 FIO_DEPENDENCIES += libaio
14 endif
16 ifeq ($(BR2_PACKAGE_NUMACTL),y)
17 FIO_DEPENDENCIES += numactl
18 endif
20 ifeq ($(BR2_PACKAGE_ZLIB),y)
21 FIO_DEPENDENCIES += zlib
22 endif
24 define FIO_CONFIGURE_CMDS
25 (cd $(@D); $(TARGET_MAKE_ENV) ./configure --cc="$(TARGET_CC)" --extra-cflags="$(TARGET_CFLAGS)")
26 endef
28 define FIO_BUILD_CMDS
29 $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
30 endef
32 define FIO_INSTALL_TARGET_CMDS
33 $(INSTALL) -D $(@D)/fio $(TARGET_DIR)/usr/bin/fio
34 endef
36 $(eval $(generic-package))