package/x11r7/xserver_xorg-server: bump to version 1.19.3
[buildroot-gz.git] / package / autofs / autofs.mk
blob23e683688b619cac4191f5c321864df2fea63a69
1 ################################################################################
3 # autofs
5 ################################################################################
7 AUTOFS_VERSION = 5.1.2
8 AUTOFS_SOURCE = autofs-$(AUTOFS_VERSION).tar.xz
9 AUTOFS_SITE = $(BR2_KERNEL_MIRROR)/linux/daemons/autofs/v5
10 AUTOFS_LICENSE = GPLv2+
11 AUTOFS_LICENSE_FILES = COPYING COPYRIGHT
12 AUTOFS_DEPENDENCIES = host-flex host-bison
13 # For 0002-autofs-configure-check-for-clock_gettime-in-librt.patch and
14 # 0003-configure-add-cache-variable-for-Linux-proc-filesyst.patch.
15 AUTOFS_AUTORECONF = YES
17 # autofs looks on the build machine for the path of modprobe, so tell
18 # it explicitly where it will be located on the target.
19 AUTOFS_CONF_ENV = \
20 ac_cv_path_KRB5_CONFIG=no \
21 ac_cv_path_MODPROBE=/sbin/modprobe \
22 ac_cv_linux_procfs=yes
24 # instead of looking in the PATH like any reasonable package, autofs
25 # configure looks only in an hardcoded search path for host tools,
26 # which we have to override with --with-path.
27 AUTOFS_CONF_OPTS = \
28 --disable-mount-locking \
29 --enable-ignore-busy \
30 --without-openldap \
31 --without-sasl \
32 --with-path="$(BR_PATH)" \
33 --with-hesiod=no
35 AUTOFS_MAKE_ENV = DONTSTRIP=1
37 $(eval $(autotools-package))