btrfs-progs: bump version to 4.8.3
[buildroot-gz.git] / package / stella / stella.mk
blob2e9d57b8c1ea6a25d344f4c446e566343530a774
1 ################################################################################
3 # stella
5 ################################################################################
7 STELLA_VERSION = 4.7.2
8 STELLA_SOURCE = stella-$(STELLA_VERSION)-src.tar.xz
9 STELLA_SITE = http://downloads.sourceforge.net/stella
10 STELLA_LICENSE = GPLv2+
11 STELLA_LICENSE_FILES = Copyright.txt License.txt
13 STELLA_DEPENDENCIES = sdl2 libpng zlib
15 STELLA_CONF_OPTS = \
16 --host=$(GNU_TARGET_NAME) \
17 --prefix=/usr \
18 --with-sdl-prefix=$(STAGING_DIR)/usr
20 # The configure script is not autoconf based, so we use the
21 # generic-package infrastructure
22 define STELLA_CONFIGURE_CMDS
23 (cd $(@D); \
24 $(TARGET_CONFIGURE_OPTS) \
25 $(TARGET_CONFIGURE_ARGS) \
26 ./configure $(STELLA_CONF_OPTS) \
28 endef
30 define STELLA_BUILD_CMDS
31 $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
32 endef
34 define STELLA_INSTALL_TARGET_CMDS
35 $(TARGET_MAKE_ENV) $(MAKE) DESTDIR="$(TARGET_DIR)" -C $(@D) install
36 endef
38 $(eval $(generic-package))