pkg-autotools: move the libtool patching call out of the autoreconf hook
[buildroot-gz.git] / package / pcre / pcre.mk
blob4ff7abd874914a32eded207a79b46adf6b3bb832
1 ################################################################################
3 # pcre
5 ################################################################################
7 PCRE_VERSION = 8.36
8 PCRE_SITE = ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre
9 PCRE_LICENSE = BSD-3c
10 PCRE_LICENSE_FILES = LICENCE
11 PCRE_INSTALL_STAGING = YES
12 PCRE_CONFIG_SCRIPTS = pcre-config
14 ifneq ($(BR2_INSTALL_LIBSTDCPP),y)
15 # pcre will use the host g++ if a cross version isn't available
16 PCRE_CONF_OPTS = --disable-cpp
17 endif
19 PCRE_CONF_OPTS += --enable-pcre8
20 PCRE_CONF_OPTS += $(if $(BR2_PACKAGE_PCRE_16),--enable-pcre16,--disable-pcre16)
21 PCRE_CONF_OPTS += $(if $(BR2_PACKAGE_PCRE_32),--enable-pcre32,--disable-pcre32)
22 PCRE_CONF_OPTS += $(if $(BR2_PACKAGE_PCRE_UTF),--enable-utf,--disable-utf)
23 PCRE_CONF_OPTS += $(if $(BR2_PACKAGE_PCRE_UCP),--enable-unicode-properties,--disable-unicode-properties)
25 $(eval $(autotools-package))
26 $(eval $(host-autotools-package))