pkg-autotools: move the libtool patching call out of the autoreconf hook
[buildroot-gz.git] / package / libev / libev.mk
blobdc428583fcbb6a7601f7d2dc08a4de402aec9514
1 ################################################################################
3 # libev
5 ################################################################################
7 LIBEV_VERSION = 4.15
8 LIBEV_SITE = http://dist.schmorp.de/libev
9 LIBEV_INSTALL_STAGING = YES
10 LIBEV_LICENSE = BSD-2c or GPLv2+
11 LIBEV_LICENSE_FILES = LICENSE
13 # The 'compatibility' event.h header conflicts with libevent
14 # It's completely unnecessary for BR packages so remove it
15 define LIBEV_DISABLE_EVENT_H_INSTALL
16 $(SED) 's/ event.h//' $(@D)/Makefile.in
17 endef
18 LIBEV_POST_PATCH_HOOKS += LIBEV_DISABLE_EVENT_H_INSTALL
20 $(eval $(autotools-package))