package/luaposix: add .hash file
[buildroot-gz.git] / package / slang / slang.mk
blob9078bf293c5a3f8196406b33684d9c7735805899
1 ################################################################################
3 # slang
5 ################################################################################
7 SLANG_VERSION = 2.3.0
8 SLANG_SITE = http://www.jedsoft.org/releases/slang
9 SLANG_LICENSE = GPLv2+
10 SLANG_LICENSE_FILES = COPYING
11 SLANG_INSTALL_STAGING = YES
12 SLANG_CONF_OPTS = --with-onig=no
13 SLANG_MAKE = $(MAKE1)
15 # Racy and we don't have/do libtermcap
16 define SLANG_DISABLE_TERMCAP
17 $(SED) '/^TERMCAP=/s:=.*:=:' $(@D)/configure
18 endef
19 SLANG_POST_PATCH_HOOKS += SLANG_DISABLE_TERMCAP
21 # Absolute path hell, sigh...
22 ifeq ($(BR2_PACKAGE_LIBPNG),y)
23 SLANG_CONF_OPTS += --with-png=$(STAGING_DIR)/usr
24 SLANG_DEPENDENCIES += libpng
25 else
26 SLANG_CONF_OPTS += --with-png=no
27 endif
28 ifeq ($(BR2_PACKAGE_PCRE),y)
29 SLANG_CONF_OPTS += --with-pcre=$(STAGING_DIR)/usr
30 SLANG_DEPENDENCIES += pcre
31 else
32 SLANG_CONF_OPTS += --with-pcre=no
33 endif
34 ifeq ($(BR2_PACKAGE_ZLIB),y)
35 SLANG_CONF_OPTS += --with-z=$(STAGING_DIR)/usr
36 SLANG_DEPENDENCIES += zlib
37 else
38 SLANG_CONF_OPTS += --with-z=no
39 endif
41 ifeq ($(BR2_PACKAGE_NCURSES),y)
42 SLANG_DEPENDENCIES += ncurses
43 SLANG_CONF_ENV += ac_cv_path_nc5config=$(STAGING_DIR)/usr/bin/ncurses5-config
44 else
45 SLANG_CONF_OPTS += ac_cv_path_nc5config=no
46 endif
48 ifeq ($(BR2_PACKAGE_READLINE),y)
49 SLANG_CONF_OPTS += --with-readline=gnu
50 SLANG_DEPENDENCIES += readline
51 ifeq ($(BR2_STATIC_LIBS),y)
52 SLANG_CONF_ENV += LIBS="`$(STAGING_DIR)/usr/bin/ncurses5-config --libs`"
53 endif
54 endif
56 ifeq ($(BR2_STATIC_LIBS),y)
57 SLANG_MAKE_OPTS = static
58 SLANG_INSTALL_STAGING_OPTS = DESTDIR=$(STAGING_DIR) install-static
59 SLANG_INSTALL_TARGET_OPTS = DESTDIR=$(TARGET_DIR) install-static
60 endif
62 $(eval $(autotools-package))